You are not logged in.

#1 2013-10-12 16:07:57

Lockheed
Member
Registered: 2010-03-16
Posts: 1,429

Suspend mechanism freezing before shutting down

Every other time I try to suspend my system (not hibernate, although the issue also exists for hibernation, and possibly even shutdown) the system just stops at the blinking "_" sign just before it is supposed to suspend.
It appears to be completely random. Sometimes it suspends, sometimes it stops and I see no pattern to it. I would rate it on 66/33 to 50/50 basis (successful/frozen).

This is not a hardware issue, because I had the same problem on the same system but on previous laptop (ThinkPad, just as my current one). It also is not graphic-card related, because I used to have Nvidia, and now have an ATI card.

Unlike for hibernation, I found no logs for suspend mechanism - does it leave any?


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#2 2013-10-13 03:36:27

tazee
Member
Registered: 2013-10-13
Posts: 24

Re: Suspend mechanism freezing before shutting down

Your symptoms are like the issue being discussed at https://bbs.archlinux.org/viewtopic.php?id=170110. Take a look at that issue. Both may be the same.

Offline

#3 2013-10-13 10:13:20

Lockheed
Member
Registered: 2010-03-16
Posts: 1,429

Re: Suspend mechanism freezing before shutting down

Thanks, but it is not really similar issue.
First, there the problem occurs upon resume, not upon suspend.
Second, I don't even have alx module loaded.


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

#4 2013-10-16 00:05:34

Evilandi666
Member
Registered: 2010-10-28
Posts: 105

Re: Suspend mechanism freezing before shutting down

Maybe it is that issue: https://bbs.archlinux.org/viewtopic.php?id=169970
If yes..sorry, no other fix than downgrading to lts kernel available.

Offline

#5 2013-10-16 08:16:54

Lockheed
Member
Registered: 2010-03-16
Posts: 1,429

Re: Suspend mechanism freezing before shutting down

I don't think this is it. I had this issue even in August, when there was still no kernel 3.11, and I only upgraded to 3.11 few days ago.


Laptop: ThinkPad W500, C2D P9500, 8GB, Radeon RV635 (HD3650), Arch | Server/fw: Zotac AQ01, A4-5000 Kabini, 4GB, Arch/pfSense VM

Offline

Board footer

Powered by FluxBB