You are not logged in.

#1 2013-10-13 00:34:23

Niemand
Member
Registered: 2013-10-13
Posts: 4

[SOLVED]I can't connect to wireless networks.

Hi all, i'm new in the world of Arch Linux but not on the Linux world.
I'm having problems with wireless networks, and i had read all what the wiki says and tried all but nothing worked. I wanna say that wired works perfect.

I think the problem comes from dhcpcd. Because in the begins the problem was that dhcpcd stuck on "Waiting for carrier", i read the wiki and seted the channel on auto but didnt work. Now i cant even connect to a wireless red.

iwconfig wlp2s0 essid "Name"

Nothing happens

Here are some of my list-unit-files:

$ systemctl list-unit-files 

dhcpcd.service                              enabled 
dhcpcd@.service                             enabled 
netctl-auto@.service                        enabled 
netctl-ifplugd@.service                     disabled
netctl-sleep.service                        disabled
netctl.service                              disabled
netctl@.service                             static  
netctl@wlp2s0\x2dCandy.service              enabled 
NetworkManager-dispatcher.service           enabled 
NetworkManager-wait-online.service          disabled
NetworkManager.service                      enabled 
nscd.service                                disabled
wpa_supplicant-nl80211@.service             disabled
wpa_supplicant-wired@.service               disabled
wpa_supplicant.service                      disabled
wpa_supplicant@.service                     disabled

Here the --failed:

$ systemctl --failed
UNIT                          LOAD   ACTIVE SUB    DESCRIPTION
dhcpcd.service                loaded failed failed dhcpcd on all interfaces
dhcpcd@enp7s0.service         loaded failed failed dhcpcd on enp7s0
dhcpcd@wlp2s0.service         loaded failed failed dhcpcd on wlp2s0
netctl-auto@wlp2s0.service    loaded failed failed Automatic wireless network co
netctl@wl...i\x206283.service loaded failed failed Networking for netctl profile

My ip link:

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP mode DEFAULT qlen 1000
    link/ether 70:71:bc:92:00:1f brd ff:ff:ff:ff:ff:ff
3: wlp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DEFAULT qlen 1000
    link/ether 74:f0:6d:3d:ee:f4 brd ff:ff:ff:ff:ff:ff

What aditional info do u need?

Thanx for all guys, i have days trying to solve this problem.

Last edited by Niemand (2013-10-13 18:03:45)

Offline

#2 2013-10-13 00:43:04

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 26,169
Website

Re: [SOLVED]I can't connect to wireless networks.

Niemand wrote:

What aditional info do u need?

You say you followed the wiki page(s), but the relevant output isn't here.

Follow the manual connection steps on the wireless wiki page and post the results/output of each of the steps here.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2013-10-13 00:44:02

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,078

Re: [SOLVED]I can't connect to wireless networks.

Well, lets start with something really basic.  Please post the output of iw  wlp2s0 scan when run as root.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#4 2013-10-13 00:45:35

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: [SOLVED]I can't connect to wireless networks.

You have enabled NetworkManager and netctl and dhcpcd, and all those are fighting over controll of your wireless. Choose one method of managing your connections and disable the other ones, then you should be fine.

Offline

#5 2013-10-13 06:17:44

Niemand
Member
Registered: 2013-10-13
Posts: 4

Re: [SOLVED]I can't connect to wireless networks.

Trilby wrote:
Niemand wrote:

What aditional info do u need?

You say you followed the wiki page(s), but the relevant output isn't here.

Follow the manual connection steps on the wireless wiki page and post the results/output of each of the steps here.

ewaller wrote:

Well, lets start with something really basic.  Please post the output of iw  wlp2s0 scan when run as root.

Here are the steps:

sudo iwconfig wlp2s0
wlp2s0    IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off


iwlist wlp2so scan

Cell 02 - Address: E0:75:7D:D0:56:98
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=70/70  Signal level=-23 dBm  
                    Encryption key:off
                    ESSID:"MOTOROLA RAZR i 6283"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=00000000026122fd
                    Extra: Last beacon: 63ms ago
                    IE: Unknown: 00144D4F544F524F4C412052415A5220692036323833
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030106
                    IE: Unknown: 2A0100
                    IE: Unknown: 32043048606C
                    IE: Unknown: 2D1A3C0118FF00000000000000000048000100000000000000000000
                    IE: Unknown: 3D1606000000000000000000000000000000000000000000
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: DD7F0050F204104A00011010440001021057000101103B00010310470010123456789ABCDEF0123456789ABCDEF0102100084D6F746F726F6C6110230003574150102400033132331042000531323334351054000800060050F20400011011000B576972656C657373204150100800020004103C0001011049000600372A000120

sudo iwconfig wlp2s0 essid "MOTOROLA RAZR i 6283"


and then

iwconfig
wlp2s0    IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

There is no change. Is not connected to the Essid "MOTOROLA..."

If i ask for an IP

sudo dhcpcd wlp2s0
dhcpcd[9823]: version 6.0.5 starting
dhcpcd[9823]: wlp2s0: waiting for carrier
dhcpcd[9823]: timed out
dhcpcd[9823]: exited
cookies wrote:

You have enabled NetworkManager and netctl and dhcpcd, and all those are fighting over controll of your wireless. Choose one method of managing your connections and disable the other ones, then you should be fine.

Wich one should i pick? Can you tell me please how i do it?

Thanks guys, i really appreciate it.

Offline

#6 2013-10-13 06:47:37

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,078

Re: [SOLVED]I can't connect to wireless networks.

Well, the good news is that your hardware works just fine.  It looks to me like you are using your phone as a wireless access point -- and you are sitting right on top of it.

Cookies nailed it.  Disable the dhcpcd systemd service.  dhcpcd will be controlled by netctl or NetworkManager.  You have to pick either netctl or NetworkManager and you have to diable the systemd service of the other.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2013-10-13 07:27:15

Niemand
Member
Registered: 2013-10-13
Posts: 4

Re: [SOLVED]I can't connect to wireless networks.

ewaller wrote:

Well, the good news is that your hardware works just fine.  It looks to me like you are using your phone as a wireless access point -- and you are sitting right on top of it.

Cookies nailed it.  Disable the dhcpcd systemd service.  dhcpcd will be controlled by netctl or NetworkManager.  You have to pick either netctl or NetworkManager and you have to diable the systemd service of the other.

Here we go:

$ sudo systemctl disable dhcpcd.service 
rm '/etc/systemd/system/multi-user.target.wants/dhcpcd.service'
$ sudo systemctl disable dhcpcd@.service 
$ sudo systemctl disable netctl-auto@.service 
$ sudo systemctl disable netctl@wlp2s0\x2dCandy.service 
$ sudo iwconfig wlp2s0 essid "MOTOROLA RAZR i 6283"
$ iwconfig
wlp2s0    IEEE 802.11bgn  ESSID:"MOTOROLA RAZR i 6283"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
lo        no wireless extensions.

enp7s0    no wireless extensions.

$ sudo dhcpcd wlp2s0
dhcpcd[10431]: version 6.0.5 starting
dhcpcd[10431]: wlp2s0: waiting for carrier
dhcpcd[10431]: timed out
dhcpcd[10431]: exited

If i do iwconfig again, i dont see any essid attached.

should i let

netctl@.service                             static

like this?


Thanks again.

Offline

#8 2013-10-13 07:44:51

DarkCerberus
Banned
From: Holsworthy, Devon
Registered: 2011-12-31
Posts: 252

Re: [SOLVED]I can't connect to wireless networks.

You should try it with just NetworkManager.service or just netctl.service without the @ symbol - with my knowledge - dhcpcd, netctl and NetworkManager all conflicts together, try disabling the other network services like dhcpcd, netctl, NetworkManager etc. And just use one of them and see what the end result is.


Our enemies are your enemies, Nick. Disorder, war. It's just a matter of time before a dirty bomb goes off in Moscow, or an EMP fries Chicago.  ---  Alexander Pierce, Captain America: Winter Soldier
Access Denied! De-cryption failed, override denied all files sealed! --- Triskelion, Shield OS
-----
How to ask questions the smart way

Offline

#9 2013-10-13 15:17:08

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 18,078

Re: [SOLVED]I can't connect to wireless networks.

Niemand,
Yes that is what I was working toward. 
I am worried about one thing, however.  I note that you are using an Android phone as your AP.  Have you done that successfully with other machines?  The reason I ask is some carriers here in the states (*cough*Verizon*cough*) make it as difficult as possible to tether their phones.  I know that on my phone, I had to turn on NAT forwarding in the phone to make it work.  That required I root the phone.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#10 2013-10-13 17:05:58

Niemand
Member
Registered: 2013-10-13
Posts: 4

Re: [SOLVED]I can't connect to wireless networks.

ewaller wrote:

Niemand,
Yes that is what I was working toward. 
I am worried about one thing, however.  I note that you are using an Android phone as your AP.  Have you done that successfully with other machines?  The reason I ask is some carriers here in the states (*cough*Verizon*cough*) make it as difficult as possible to tether their phones.  I know that on my phone, I had to turn on NAT forwarding in the phone to make it work.  That required I root the phone.

Yes it works perfect with anothers PCs and with this PC on Windows too. I tried on anothers Networks, D-Link Router, Micronet and others. I tried in a lot of connections but it doesn't work.

DarkCerberus wrote:

You should try it with just NetworkManager.service or just netctl.service without the @ symbol - with my knowledge - dhcpcd, netctl and NetworkManager all conflicts together, try disabling the other network services like dhcpcd, netctl, NetworkManager etc. And just use one of them and see what the end result is.


I could't disable the following services:

netctl-auto@.service
dhcpcd@.service

I tried with:

- sudo systemctl disable dhcpcd@.service
- sudo systemctl disable netctl-auto@.service
- sudo netctl-auto disable-all

Then, i restarted and try again with:

$sudo iwlist wlan0 scan

$sudo iwconfig wlan0 essid "MOTO..."

$sudo dhcpcd wlan0

$ sudo dhcpcd wlan0
version 6.0.5 starting
wlan0: soliciting an IPv6 router
wlan0: soliciting a DHCP lease
wlan0: offered 192.168.43.17 from 192.168.43.1
wlan0: leased 192.168.43.17 for 43200 seconds
wlan0: adding host route to 192.168.43.17 via 127.0.0.1
wlan0: adding route to 192.168.43.0/24
wlan0: adding default route via 192.168.43.1
forked to background, child pid 700

IT'S WORKS!!

The status of the services are:

$ systemctl list-unit-files 

dhcpcd.service                              disabled 
dhcpcd@.service                             enabled 
netctl-auto@.service                        enabled 
netctl-ifplugd@.service                     disabled
netctl-sleep.service                        disabled
netctl.service                              disabled
netctl@.service                             static  
netctl@wlp2s0\x2dCandy.service              disabled 
NetworkManager-dispatcher.service           disabled
NetworkManager-wait-online.service          disabled
NetworkManager.service                      disabled
nscd.service                                disabled
wpa_supplicant-nl80211@.service             disabled
wpa_supplicant-wired@.service               disabled
wpa_supplicant.service                      disabled
wpa_supplicant@.service                     disabled

Now my ip link is:

$ ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
    link/ether 70:71:bc:92:00:1f brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP mode DEFAULT qlen 1000
    link/ether 74:f0:6d:3d:ee:f4 brd ff:ff:ff:ff:ff:ff

And my iwconfig:

$ iwconfig
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"MOTOROLA RAZR i 6283"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: E0:75:7D:D0:56:98   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:22   Missed beacon:0

In the begins i didnt have Ethernet but then i turn on manually eth0 and boths works perfect.

Thanks a lot for all.
[SOLVED]

Offline

#11 2013-10-13 18:14:54

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: [SOLVED]I can't connect to wireless networks.

Niemand wrote:

I could't disable the following services:

netctl-auto@.service
dhcpcd@.service

Upon disabling a service, systemd just removes the symlink to the actual service file like in this case:

$ sudo systemctl disable dhcpcd.service 
rm '/etc/systemd/system/multi-user.target.wants/dhcpcd.service'

So if you want to disable those, too, just look for the corresponding symlinks (they're propably in /etc/systemd/system/multi-user.target.wants, too) and delete them yourself (might be a good idea since it won't cause any confusion later on).

Offline

#12 2013-11-04 03:48:27

jjshinobi
Member
Registered: 2013-04-06
Posts: 97

Re: [SOLVED]I can't connect to wireless networks.

I had this same problem and fixed it by doing the above, plus following on and removing wants/dhcpcd.service and rebooting. Is that all there is to do to permanently remove dhcpcd?

Last edited by jjshinobi (2013-11-04 03:54:17)

Offline

#13 2013-11-04 05:14:03

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [SOLVED]I can't connect to wireless networks.

@jjshinobi, you need to do a bit more researching/learning about systemd.  Enabling and disabling services is one of the most basic functions of systemd, and you must have had to at least enable a few things when you set your system up.  When you do that, the output of the command tells you exactly what is being done to make that happen.  So even just simply using systemctl should have been able to yield that answer for you.

Offline

Board footer

Powered by FluxBB