You are not logged in.

#1 2013-10-20 12:43:01

illpill
Member
Registered: 2013-10-20
Posts: 8

Failure to connect to wireless internet

Hello, I just installed arch linux on my laptop and i have the wifi setup yet to complete. The problem I'm having is that the command "$ sudo dhcpcd wlp2s0" gets stuck on waiting for carrier. I have browsed around for solutions but I have not been able to solve my problems. I don't know exactly what information you need to help me out but ill tell you what i know.
Driver: ath9k
Interface: wlp2s0
Security: wpa
iwconfig output:
[ill@Archill ~]$ iwconfig
enp3s0f2  no wireless extensions.

wlp2s0    IEEE 802.11bgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.

lspci -k:
02:00.0 Network controller: Qualcomm Atheros AR9485 Wireless Network Adapter (rev 01)
    Subsystem: AzureWave Device 2c97
    Kernel driver in use: ath9k
    Kernel modules: ath9k

I installed the 2013.10.01 release.

Please help me out and thanks in advance!

Offline

#2 2013-10-20 12:57:55

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: Failure to connect to wireless internet

That dhcpcd command is the last step in a manual wireless setup - have you completed the steps that are required before that?

To put in another way - why do you think 'dhcpcd wlp2s0' should work?

Offline

#3 2013-10-20 12:59:45

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,758
Website

Re: Failure to connect to wireless internet

Please read and follow the wireless page on the wiki to know what steps you should be doing.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-10-20 15:15:06

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

I have done so, but I have trouble understanding some things, for example if I'm to use netctl can i just skip the manual setup? because that's like 80% of the page

Offline

#5 2013-10-20 15:16:28

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

And I have been configuring netctl, like setting up the profile for my internet connection

The problem occurs when i do the netctl start profile command

Last edited by illpill (2013-10-20 15:18:58)

Offline

#6 2013-10-20 15:22:26

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,758
Website

Re: Failure to connect to wireless internet

You can either use the manual steps, or use netctl [1].  Trying to mix both will lead to problems.  In either case, you'll need to let us know what you have actually done.  What commands have you executed, what are the results (actual output and/or error messages), and what are the contents of the relevant configuration files or profiles.  Saying a "problem occurs" doesn't give us anything to work with.

[1] I'd recommend the manual steps first.  These are much easier to troubleshoot and allows for pinpointing exactly where the problem is.  If/when that works, you can change over to netctl which will basically just automate those steps.

Last edited by Trilby (2013-10-20 15:23:46)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#7 2013-10-20 15:44:40

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,800

Re: Failure to connect to wireless internet

For a sanity check, what is the output of iw wlp2s0 scan (when run as root)?
Does your access point show up in the output?
What type of security are you using?  Open? WEP? WPA? WPA2?

And, to expand on what Trilby said, DHCP is a fairly high level protocol.  You have to establish the link first.  Note that your output in post #1 clearly stated you were Not-Associated to access point;  that is akin to having the cable unplugged on a wired interface.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#8 2013-10-21 14:42:54

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

Okay here's the steps and messages after each command

# ip link set wlp2s0 up

no message

# dmesg | grep firmware
[    6.069040] psmouse serio4: elantech: assuming hardware version 4 (with firmware version 0x361f03)

# dmesg | grep ath9k   

no message

# iw dev
phy#0
	Interface wlp2s0
		ifindex 3
		wdev 0x1
		addr 6c:71:d9:2c:0b:3b
		type managed

# iw dev wlp2s0 link
Not connected.

 iw dev wlp2s0 station dump

no message

# ip link set wlp2s0 up

no message

# iw dev wlp2s0 scan | less

SS 58:98:35:79:95:91(on wlp2s0)
        TSF: 863045206292 usec (9d, 23:44:05)
        freq: 2437
        beacon interval: 100 TUs
        capability: ESS Privacy ShortSlotTime (0x0411)
        signal: -72.00 dBm
        last seen: 513 ms ago
        Information elements from Probe Response frame:
        SSID: my ssid
        Supported rates: 1.0* 2.0* 5.5* 11.0* 18.0 24.0 36.0 54.0 
        DS Parameter set: channel 6
        ERP: <no flags>
        ERP D4.0: <no flags>
        RSN:     * Version: 1
                 * Group cipher: TKIP
                 * Pairwise ciphers: CCMP
                 * Authentication suites: PSK
                 * Capabilities: 16-PTKSA-RC 1-GTKSA-RC (0x000c)
        Extended supported rates: 6.0 9.0 12.0 48.0 
        HT capabilities:
				Capabilities: 0x181c
                        HT20
                        SM Power Save disabled
                        RX Greenfield
                        No RX STBC
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT RX MCS rate indexes supported: 0-15
                HT TX MCS rate indexes are undefined
        HT operation:
                 * primary channel: 6
                 * secondary channel offset: no secondary
                 * STA channel width: 20 MHz
                 * RIFS: 1
                 * HT protection: no
                 * non-GF present: 1
                 * OBSS non-GF present: 0
                 * dual beacon: 0
                 * dual CTS protection: 0
 				 * STBC beacon: 0
                 * L-SIG TXOP Prot: 0
                 * PCO active: 0
                 * PCO phase: 0
        WPA:     * Version: 1
                 * Group cipher: TKIP
                 * Pairwise ciphers: TKIP
                 * Authentication suites: PSK
        WMM:     * Parameter version 1
                 * BE: CW 15-1023, AIFSN 3
                 * BK: CW 15-1023, AIFSN 7
                 * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
                 * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

# iw dev wlp2s0 set type ibss

no message

# wpa_supplicant -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
Successfully initialized wpa_supplicant
Line 994: unknown EAP method 'SIM'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
Line 994: failed to parse eap 'SIM'.
Line 997: failed to parse network block.
Line 1004: unknown EAP method 'PSK'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
Line 1004: failed to parse eap 'PSK'.
Line 1008: failed to parse network block.
Line 1040: unknown EAP method 'IKEV2'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
Line 1040: failed to parse eap 'IKEV2'.
Line 1043: failed to parse network block.
Line 1049: unknown EAP method 'FAST'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
Line 1049: failed to parse eap 'FAST'.
Line 1055: failed to parse network block.
Line 1060: unknown EAP method 'FAST'
You may need to add support for this EAP method during wpa_supplicant
build time configuration.
See README for more information.
Line 1060: failed to parse eap 'FAST'.
Line 1066: failed to parse network block.
Failed to read or parse configuration '/etc/wpa_supplicant/wpa_supplicant.conf'.

Moderator edit:  Added BBCode code tags (ewaller).

Last edited by ewaller (2013-10-21 15:19:24)

Offline

#9 2013-10-21 14:43:26

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

security is wpa

Offline

#10 2013-10-21 15:23:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,800

Re: Failure to connect to wireless internet

I would say there are problems with your file.  You may want to post it -- but use code tags tongue

Edit:  See Trilby's comment below.  Yes, that is the file I meant.  I know I copied the file name.  I must have failed to paste it hmm

Last edited by ewaller (2013-10-21 16:30:11)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#11 2013-10-21 15:36:18

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,758
Website

Re: Failure to connect to wireless internet

Building on ewaller's comment (assuming he means the wpa_supplicant.conf,) none of the steps listed generated a suitable wpa_supplicant.conf file.  There are various guides online for creating these, but I strongly suggest just using wpa_passphrase.  It is idiot-proof[1] and very reliable for a vast majority of configurations.


[1] This is not to imply anyone is an idiot, at least no one but me.  There is a reason I like wpa_passphrase: it's simple enough for me.

Last edited by Trilby (2013-10-21 15:37:55)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#12 2013-10-21 15:57:33

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

Allright I used wpa_passphrase and got the following:

$ wpa_passphrase myessid passphrase
network={
    ssid="myessid"
    #psk="passphrase"
    psk=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
}

However I can still not use $wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf

I get the same message as I posted above

Offline

#13 2013-10-21 17:01:33

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 14,758
Website

Re: Failure to connect to wireless internet

You need to write that output to wpa_supplicant.conf.  If you have anything you've previously set up in wpa_supplicant.conf you may want to save that first, but otherwise the following should work:

# wpa_passphrase myessid passphrase > /etc/wpa_supplicant/wpa_supplicant.conf

# wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf

InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#14 2013-10-22 16:32:19

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

Now when I do the wpa_passphrase myessid passphrase > /etc/wpa_supplicant/wpa_supplicant.conf
and then  wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
I get :
Successfully initialized wpa_supplicant
ioctl[SIOCSIWPMKSA]: Invalid agrument

Offline

#15 2013-10-22 18:05:49

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,800

Re: Failure to connect to wireless internet

illpill wrote:

Now when I do the wpa_passphrase myessid passphrase > /etc/wpa_supplicant/wpa_supplicant.conf
and then  wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant/wpa_supplicant.conf
I get :
Successfully initialized wpa_supplicant
ioctl[SIOCSIWPMKSA]: Invalid agrument

As root?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#16 2013-10-22 18:31:44

illpill
Member
Registered: 2013-10-20
Posts: 8

Re: Failure to connect to wireless internet

Ah, foolish of me =p. I get only Successfully initialized wpa_supplicant now. However I still get "not connected" when running the command: iw dev wlp2s0 link. The only thing I can think of is that my passphrase or id is wrong? This is a similar id and pass to mine, just scrambled. ID LekiaJanesmoy23-53-75-87-75-32 PASS 482DT9S426. Should I write it in a different way or something? the wifi-menu shows my ID as  wlp2s0-LekiaJanesmoy23-53-75-87-75-32 if that helps

Offline

Board footer

Powered by FluxBB