You are not logged in.

#1 2013-10-24 09:32:45

JJK
Member
Registered: 2013-10-24
Posts: 36

ipw2200 wireless network gives errors and drops connection

hey guys,

I recently installed arch linux on my laptop. I'm quite new to archlinux.

installation went fine, no problems.

after installation i got errors that ipw2200 couldnt find the firmware, so I installed ipw2200-fw package using
# pacman -S ipw2200-fw

that stopped those errors, but as soon as i tried to connect to the network, by typing these commands:

# rfkill unblock all                               unblock my hardware switch
# modprobe -r ipw2200                       
# modprobe ipw2200
# iwconfig                                          to show my wireless interfaces
# ifconfig wlp2s4 up                            enable my wireless interface which i found using iwconfig
# wpa_passphrase Korpershoek secretpassword > /etc/wpa_supplicant.conf                   generate conf file for my AP
# wpa_supplicant -B -Dwext -iwlp2s4 -c/etc/wpa_supplicant.conf                                    connect to my AP
# dhcpcd wlp2s4                                                                                                        enable dhcp
# ping 8.8.8.8                                                                                                            this gives response 2 times, and then the                                 
                                                                                                                                network drops out again

I also get the errors:

ipw2200 failed to send CARD_DISABLE: command timed out.                                    once after #rfkill unblock all
ipw2200 failed to send SYSTEM_CONFIG already sending a command.                      every now and then.

I've searched a lot of topics, and tried some fixes. But none worked.

i tried downgrading ipw2200 firmware to 3.0
and downgrading linux (didn't know how to, so that didn't work)

I hope you can help me

JJK

Last edited by JJK (2013-10-24 09:49:06)

Offline

#2 2013-10-24 19:18:10

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: ipw2200 wireless network gives errors and drops connection

Hi, welcome to the forums.
Couple of things you can try:
* launch wpa_supplicant without naming a driver
* The card does not support N mode, you could try to disable it: https://wiki.archlinux.org/index.php/Wi … nd_ipw2200
* If you want to try downgrading linux, an easy option with Arch is to try the supported "linux-lts" package. However, that just got a bump to 3.10, so it's not really 'antigue' ;-) Of course you can manually downgrade further, but that creates issues with a rolling distro, so I'd rather try other options first.
* The router may be the problem as well. If it uses some "mixed" modes, try a distinct wifi-G with WPA2/AES or WPA2/TKIP.
Post the PCI-ID next time. It is easier for others to help you (searching with a PCI-ID here in the forum can help to get distinct hits as well). Also post log excerpts of a failing connection (but please use [ code] tags for that).

Offline

#3 2013-10-24 19:28:41

GERUM
Member
Registered: 2013-10-18
Posts: 18

Re: ipw2200 wireless network gives errors and drops connection

ipw2200-fw (3.1-5) and 3.11.6-1-ARCH here. Everything has been and still is working great. Personally, I've never done *anything* except installed the firmware, started dhcpcd and connected through wpa_supplicant.

Try after rebooting:

# systemctl start dhcpcd
# wpa_supplicant -Dwext -iwlp2s4 -c/etc/wpa_supplicant.conf -B

Since you haven't shared your wpa_supplicant.conf, here's what I use (though, in a separate file under /etc/wpa_supplicant/):

network={
    ssid="MY-ROUTER"
    psk="PASSWORD"
}

Offline

#4 2013-10-25 11:04:06

JJK
Member
Registered: 2013-10-24
Posts: 36

Re: ipw2200 wireless network gives errors and drops connection

thx for the quick reaction

I don't know what you mean by pci-id, but the output of lscpci is down here:

jjk@jjk-laptop:~$ lspci | grep -i network
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)

launching wpa_supplicant without driver didn't fix the problem.

my router settings:

Wireless Access Point - Korpershoek	

	Configuration

WLAN Enable:	Yes

Interface Enabled:	Yes

Power Reduction Enabled:	No

Physical Address:	a4:b1:e9:a8:32:eb

Network Name (SSID):	Korpershoek

Interface Type:	802.11b/g/n

Actual Speed [Mbps]:	18

Band:	2.4GHz

Channel Selection:	Auto

Region:	Europe

Channel:	6

Allow multicast from Broadband Network:	No

WMM:	Enabled

	Security

WPS Enabled:	No

Broadcast Network Name:	Yes

Allow New Devices:	New stations are allowed (automatically)

Security Mode:	WPA-PSK

WPA-PSK Preshared Key:	secretpassword

WPA-PSK Encryption:	AES

WPA-PSK Version:	WPA2

to GERUM:
I basically did the same as you did...
for you it worked, for me it didn't sad

edit:
I tried your way GERUM,
it basically gives the same result, i can connect, i ping directly after the commands to 8.8.8.8
i get to replies and then the network drops out again.

I just discovered that i do have network when i chroot from ubuntu into my arch install:

jjk@jjk-laptop:~$ sudo mount /dev/sda7 /mnt
jjk@jjk-laptop:~$ cd /mnt
jjk@jjk-laptop:/mnt$ sudo su
root@jjk-laptop:/mnt# mount -t proc proc proc
root@jjk-laptop:/mnt# mount -t sysfs sysfs sys
root@jjk-laptop:/mnt# mount -o bind /dev dev
root@jjk-laptop:/mnt# mount -t devpts devpts dev/pts
root@jjk-laptop:/mnt# chroot ./
[root@jjk-laptop /]# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=48 time=14.3 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=48 time=9.67 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=48 time=9.37 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=48 time=9.71 ms
^C
--- 8.8.8.8 ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 9.378/10.790/14.395/2.088 ms
[root@jjk-laptop /]# 

maybe this can be used to solve the problem?

It's a bit hard for me to provide good error logs, since i can't post them from archlinux, but if you need some i'll be happy to provide them.

btw: I also see an error coming by when i boot:
it looks  like this:

*********************WARNING*****************
* the root device is not configured to be mounted *
* read-write! It may be fsck'd again later.              *
***********************************************

could this have anything to do with the problem?

Last edited by JJK (2013-10-25 12:04:44)

Offline

#5 2013-10-25 12:46:54

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 715

Re: ipw2200 wireless network gives errors and drops connection

The fsck warning is benign and unrelated to your networking problem.  There is a long running thread about this issue at https://bbs.archlinux.org/viewtopic.php?id=167153

The simplest way to stop the warning is to remove the fsck HOOK from the /etc/mkinitcpio.conf as in the comment #5 at https://bbs.archlinux.org/viewtopic.php … 4#p1303674  and then run mkinitcpio -p linux before rebooting.  However read the full thread first.

For the networking wifi issue, I have a laptop with ipw2200 which does not have a problem - I have the current kernel, and installed the firmware package as you did ages back. It works fine, so I expect that it is possible that you have not set up the network correctly.  I use KDE and set the wifi connection with NetworkManager - make sure that you have the correct systemd service running after boot. If you use networkmanager then you need to check with

systemctl status NetworkManager
NetworkManager.service - Network Manager
   Loaded: loaded (/etc/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Fri 2013-10-25 11:28:16 BST; 2h 12min ago
 Main PID: 246 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─246 /usr/sbin/NetworkManager --no-daemon

There will likely be other lines on your output for this command as well. If it is not running then use systemctl start NetworkManager, and to make it come up automatically at boot also use systemctl enable NetworkManager.  However you should also read the wiki to make sure that you don't need additional services.  If you are getting an address from your access point then you will need the dhcpcd service as has already been mentioned.

You should not need to reload the ipw2200 module.

I used to use wpa-supplicant and it should certainly work fine provided the configs are set up correctly. However I would caution against connecting to an AP which has 802.11N - I know that ipw2200 cannot connect using N, but is fine using G.  One thing therefore that is worth trying is to change the settings on the access point to only have 802.11G (or B/G) and remove the N availability and see if you can connect without a problem. Some of our family laptops here can't connect to N either and I had to get an access point which has two wireless networks - with one of them set as a guest network with only G, which then works fine with the laptops that have a problem with 802.11N - so it is worth running that test.

Last edited by mcloaked (2013-10-25 12:53:37)


Mike C

Offline

#6 2013-11-05 12:13:33

JJK
Member
Registered: 2013-10-24
Posts: 36

Re: ipw2200 wireless network gives errors and drops connection

sorry for the late reaction, haven't had time to try yet. I'll try to install lxde first, and then use network manager to connect to the network,

the summary of the problem is:
ipw2200 in combination with wpa_supplicant is just not compatible with all wpa encryptions.

i'll post back when i installed lxde.

thx a lot for helping guys.

JJK

Offline

Board footer

Powered by FluxBB