You are not logged in.

#1 2013-11-05 18:54:14

From: Australia
Registered: 2005-02-10
Posts: 138

Boot up error: Systemd

The system will hang on boot up with this error:


It occurred after a pacman -Syu

I tried reinstalling grub, tried editing fstab

This solution didn't fix it either.

nor did this

the uuid for 5f47b406.... is the root partition in /etc/fstab  ... and was changed to /dev/sda3 ... still did nothing. boot up still tries to search for the uuid. Any idea what I have missed?

"The ecological crisis is a moral issue."


#2 2013-11-05 18:56:09

From: Australia
Registered: 2005-02-10
Posts: 138

Re: Boot up error: Systemd

Sorry this is what I meant to post in img ...

"The ecological crisis is a moral issue."


#3 2013-11-05 19:02:27

Registered: 2009-05-06
Posts: 25,440

Re: Boot up error: Systemd

Link to the original file: Warning! 2.8 MB.


#4 2013-11-06 08:49:02

From: Australia
Registered: 2005-02-10
Posts: 138

Re: Boot up error: Systemd

I have tried several things

removing devpts / shm
removing UUID and using /dev/sda (like below)
Using labels instead of UUID
having a blank fstab with no info what so ever ( systemd still finds the root directory )

# /etc/fstab: static file system information
# <file system>					<dir>		<type>		<options>				<dump>	<pass>
# devpts and shm removed since update glibc 2.18
devpts						/dev/pts	devpts		defaults				0	0
shm						/dev/shm	tmpfs		nodev,nosuid				0	0

##/dev/sda2					swap		swap		defaults				0	0
##LABEL=swap					swap		swap		defaults				0	0
#UUID=5f47b406-39d1-4abc-8c63-04fe527d12ca	/		ext3		noauto,x-systemd.automount				0	1
##LABEL=root					/		ext3		noauto,x-systemd.automount				0	1

/dev/sda4					/home		ext3		defaults,noatime				0	2
/dev/sda1					/boot		ext2		defaults,noatime				0	1
/dev/sda3					/			ext3		defaults,noatime				0	1

#UUID=f5001cb8-eb3b-4c45-8d73-fd3eac7441c5	/boot		ext2		noauto,x-systemd.automount				0	1
#UUID=770641d1-001a-4dfa-a2cf-7cc061331f07	/home		ext3		defaults				0	2

#LABEL=USS-ShuttleBusA				/media/shuttle	ntfs-3g		gid=users,fmask=113,dmask=002,nofail	0	2
#LABEL=BOART					/media/boart	vfat		users,fmask=113,dmask=002,nofail	0	2
#LABEL=CORSAIR					/media/corsair	vfat		users,fmask=113,dmask=002,nofail	0	2
#LABEL=MOT					/media/moto	auto		users,fmask=113,dmask=002,nofail	0	2
#LABEL=BOART					/media/boart	vfat		defaults				0	2

# USS-Enterprize-NX-01:/mnt/mc-server		/home/b15hop/mc	nfs4		defaults				0	0

## 58ad9303-932e-4fd7-bba2-3cb62fa1c9ff -> ../../sda2
## 5f47b406-39d1-4abc-8c63-04fe527d12ca -> ../../sda3
## 770641d1-001a-4dfa-a2cf-7cc061331f07 -> ../../sda4
## f5001cb8-eb3b-4c45-8d73-fd3eac7441c5 -> ../../sda1

This is the output of lsblk -f
Note that I'm not able to even boot up, so this is the view of lsblk from the linux live boot from usb... ie after mounting /dev/sda3 and viewing contents of all files...

NAME              FSTYPE   LABEL       UUID                                 MOUNTPOINT
├─sda1            ext2     boot        f5001cb8-eb3b-4c45-8d73-fd3eac7441c5 
├─sda2            swap     swap        58ad9303-932e-4fd7-bba2-3cb62fa1c9ff 
├─sda3            ext3     root        5f47b406-39d1-4abc-8c63-04fe527d12ca /mnt/arch
└─sda4            ext3     home        770641d1-001a-4dfa-a2cf-7cc061331f07 
└─sdb1            vfat     MYLINUXLIVE A86D-743A                            /run/archiso/bootmnt
loop0             squashfs                                                  /run/archiso/sfs/root-image
loop1             ext4                 2e0fdb16-a55b-4fa0-90d1-8aac2389d612 
└─arch_root-image ext4                 2e0fdb16-a55b-4fa0-90d1-8aac2389d612 /
loop2             ext4                 2e0fdb16-a55b-4fa0-90d1-8aac2389d612 
└─arch_root-image ext4                 2e0fdb16-a55b-4fa0-90d1-8aac2389d612 /

this is /etc/default/grub


# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"


Any idea where the boot up log files are? I have grub set to


...which has allowed me to see the error showing the uuid even though it's not set in fstab (above pic on first post)
If I set it to debug, I get spammed with info which I'm unable to figure out what or where the problem lays.

Last edited by B15HOP (2013-11-06 09:01:50)

"The ecological crisis is a moral issue."


#5 2013-11-09 00:54:39

From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: Boot up error: Systemd

This is not the problem but you should (1) remove devpts and shm from fstab (2) alter lines in fstab ending in "0 1" to "0 2" with the sole exception of /. That is, /boot should be "0 2".

I'm afraid I can't figure out how to view your image - I get a thumbnail or a bunch of links to the thumbnail and file info. What does the error actually say?

CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L


Board footer

Powered by FluxBB