You are not logged in.

#1 2012-04-13 15:47:21

retzu
Member
Registered: 2012-04-12
Posts: 9

[Solved] grub2: file not found but booting fine

I just ran grub-mkconfig to update my grub.cfg because I installed E4rat. But now I have a problem: Every entry in grub2 can be booted and E4rat really boosted my boot process so actually everything is fine. But while grub2 is loading it says something like:

Grub 2 is loading...
Welcome to Grub 2!

error: file not found.
error: file not found.
error: file not found.

Now grub shows up and everything is as it should be. When I select Arch it again says "error: file not found." three times and continues with a normal boot process. So basically it's nothing that would brake my system but something seems not right and that's just a huge annoyance.

Here's my grub.cfg just in case:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
set default="0"

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

set menu_color_normal=light-blue/black
set menu_color_highlight=light-cyan/blue

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  f7960d1a-77ab-4230-ab43-ff931f0b2175
else
  search --no-floppy --fs-uuid --set=root f7960d1a-77ab-4230-ab43-ff931f0b2175
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=1440x900x32
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_GB
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
insmod part_msdos
insmod ext2
set root='hd0,msdos5'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  f7960d1a-77ab-4230-ab43-ff931f0b2175
else
  search --no-floppy --fs-uuid --set=root f7960d1a-77ab-4230-ab43-ff931f0b2175
fi
insmod png
background_image -m stretch /boot/grub/archlinux.png
set timeout=5
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux GNU/Linux, with Linux core repo kernel' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-true-f7960d1a-77ab-4230-ab43-ff931f0b2175' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  f7960d1a-77ab-4230-ab43-ff931f0b2175
	else
	  search --no-floppy --fs-uuid --set=root f7960d1a-77ab-4230-ab43-ff931f0b2175
	fi
	echo	'Loading Linux core repo kernel ...'
	linux	/boot/vmlinuz-linux root=UUID=f7960d1a-77ab-4230-ab43-ff931f0b2175 ro init=/sbin/e4rat-preload quiet loglevel=3 logo.nologo console=tty1 splash=silent,fadein,fadeout,theme:arch-black
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-linux.img
}
menuentry 'Arch Linux GNU/Linux, with Linux core repo kernel (Fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-core repo kernel-fallback-f7960d1a-77ab-4230-ab43-ff931f0b2175' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='hd0,msdos5'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 --hint='hd0,msdos5'  f7960d1a-77ab-4230-ab43-ff931f0b2175
	else
	  search --no-floppy --fs-uuid --set=root f7960d1a-77ab-4230-ab43-ff931f0b2175
	fi
	echo	'Loading Linux core repo kernel ...'
	linux	/boot/vmlinuz-linux root=UUID=f7960d1a-77ab-4230-ab43-ff931f0b2175 ro init=/sbin/e4rat-preload quiet loglevel=3 logo.nologo console=tty1 splash=silent,fadein,fadeout,theme:arch-black
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-linux-fallback.img
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry 'Windows 7' {
  set root='(hd0,1)'; set legacy_hdbias='0'
  parttool "$root" boot+
  chainloader '+1'
}
### END /etc/grub.d/40_custom ###

And my /etc/default/grub:

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch Linux"
# Default:
#GRUB_CMDLINE_LINUX_DEFAULT="quiet"

# Splashy boot:
GRUB_CMDLINE_LINUX_DEFAULT="quiet loglevel=3 logo.nologo console=tty1 splash=silent,fadein,fadeout,theme:arch-black"

GRUB_CMDLINE_LINUX="init=/sbin/e4rat-preload"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# GRUB_GFXMODE=auto
GRUB_GFXMODE=1440x900x32

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep
GRUB_BACKGROUND="/boot/grub/archlinux.png"

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-blue/black"
GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

I haven't updated my grub.cfg in a while because there was no need to.

Thanks in advance for advices.

Last edited by retzu (2012-04-16 14:16:02)

Offline

#2 2012-04-13 23:05:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: [Solved] grub2: file not found but booting fine

Did you recently update grub2? If so, did you reinstall grub2 to disk before updating grub.cfg? Instructions are on the GRUB2 wiki or there are threads in the forums related to this problem if it is this problem. (I can't tell for sure - it would be easier if we knew *which* files it doesn't find.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#3 2012-04-14 22:38:25

ganastasiou
Member
Registered: 2010-02-03
Posts: 56

Re: [Solved] grub2: file not found but booting fine

Probably some missing modules,which are inside grub.cfg. You have to reinstall grub2 to your disk.

Offline

#4 2012-04-16 13:22:39

retzu
Member
Registered: 2012-04-12
Posts: 9

Re: [Solved] grub2: file not found but booting fine

Yes I recently updated grub2 AND reinstalled it then. I just went through the installation process again to make sure everything is fine. As a result I now get a "file not found" message with a specific file in the message but it's too fast to read. I guess i screwed something up during the update. Let's see if I can identify that missing file now.

Offline

#5 2012-04-16 13:25:27

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [Solved] grub2: file not found but booting fine

@retzu: Update the grub2 package, re-install using grub-install and re-generate grub.cfg . Do all three (or atleast the last two) together. The errors will go off.

Offline

#6 2012-04-16 13:28:24

retzu
Member
Registered: 2012-04-12
Posts: 9

Re: [Solved] grub2: file not found but booting fine

the.ridikulus.rat wrote:

@retzu: Update the grub2 package, re-install using grub-install and re-generate grub.cfg . Do all three (or atleast the last two) together. The errors will go off.

That's what I meant with "going through the installation process again" smile. Oddly enough one file is still reported as missing though.

Offline

#7 2012-04-16 13:35:35

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: [Solved] grub2: file not found but booting fine

retzu wrote:
the.ridikulus.rat wrote:

@retzu: Update the grub2 package, re-install using grub-install and re-generate grub.cfg . Do all three (or atleast the last two) together. The errors will go off.

That's what I meant with "going through the installation process again" smile. Oddly enough one file is still reported as missing though.

https://bugs.archlinux.org/task/29043 ?

EDIT: Solution - https://bbs.archlinux.org/viewtopic.php … 5#p1075065

Last edited by the.ridikulus.rat (2012-04-16 14:03:49)

Offline

#8 2012-04-16 13:54:59

retzu
Member
Registered: 2012-04-12
Posts: 9

Re: [Solved] grub2: file not found but booting fine

Yup, that's the one. Issue solved I guess smile. Thanks everyone.

Offline

#9 2012-05-02 19:53:14

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [Solved] grub2: file not found but booting fine

I have the same error message as in the first post.  "error: file not found" listed three times when I first choose Arch from the Grub2 menu.  The solution linked to by the.ridikulus.rat would not seem to apply as I do not have the locales en* in /boot/grub/locale  BTW, I am in the US.  The system does boot though.

I just fixed this a few seconds ago and was going to post how, basically I just did "cp /boot/grub/locale/en@quot.mo /boot/grub/locale/en_US.mo" which seem to do the trick, the reason I didn't fix this sooner is the error only stays up for a very small fraction of a second making it hard to read.

# ls /boot/grub/locale
ast.mo	da.mo  fi.mo  hu.mo  it.mo  nl.mo  ru.mo  uk.mo  zh_CN.mo
ca.mo	de.mo  fr.mo  id.mo  ko.mo  pl.mo  sv.mo  vi.mo 

EDIT:  I get the same three "error: file not found" messages when I boot Fedora (a multiboot system).  This is with grub2 installed from Arch Linux.

Last edited by David Batson (2012-05-02 20:03:41)

Offline

#10 2012-05-02 20:06:18

retzu
Member
Registered: 2012-04-12
Posts: 9

Re: [Solved] grub2: file not found but booting fine

I probably just made a new config file with grub-mkconfig without reinstalling grub with grub-install after updating grub2. Reinstalling grub to the MBR and generating a new config file fixed it for me.
The fix you are refering to is for a bug in grub. It has nothing to do with your problem smile.

Offline

#11 2012-05-03 01:11:50

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [Solved] grub2: file not found but booting fine

Thanks, I got it now.  This worked for me (from the GRUB2 ArchWiki).

# grub-install --directory=/usr/lib/grub/i386-pc --target=i386-pc --boot-directory=/boot --recheck --debug /dev/sda

# grub-mkconfig -o /boot/grub/grub.cfg

Offline

#12 2012-05-08 23:27:58

Darkzom
Member
Registered: 2011-03-15
Posts: 26

Re: [Solved] grub2: file not found but booting fine

Sorry to jump in and revive this thread, but I just installed grub2 with the updated instructions from wiki and can not find a solution to ES localization (looks like other languages are having this issues too)

There is no "es.mo.gz" in /boot/grub/locale/ nor nothing starting with "es" (Spanish).

Everything is working fine and booting but it this error message just annoys me...

BR

Offline

Board footer

Powered by FluxBB