You are not logged in.

#1 2013-11-05 20:37:11

Registered: 2013-02-09
Posts: 495

[Half-Solved] Amixer won't mute/unmute Master

Copied from terminator terminal:

[user@pc ~]$ amixer set Master mute
amixer: Invalid command!
[user@pc ~]$ amixer set Master unmute
amixer: Invalid command!
[user@pc ~]$ amixer set Master toggle
[user@pc ~]$ 

What could cause this? i can raise/lower volume with "set Master 1db+" etc.

This seems unrelated to WM/DE as it also applies if i log in on a fresh terminal as root.

Update: There's an old thread with a similar issue from 2010. But in his case it seems XFCE related, i however am using openbox.

Temporary workaround:
This problem only seems to apply to the Master channel, i suspect it might have to do with the drivers for my X-Fi card, or just the fact that i have surround sound setup.

Either way if you're having this problem, a hotfix is instead of using the Master channel you can use

amixer set Front toggle

or similar for whatever channel you want to mute. This also applies if i'm within Amixer itself (the user interface for it that is, which can be accessed through any terminal.) i cannot mute the Master channel but i can mute any other channel.

I'd like to know if anybody else is having the problem and what kind of setup they've got (soundcard & how many speakers)

Alternative Workaround:
Install pulseaudio and pulseaudio-alsa. This will set the default channel in alsa to pulseaudio and this will allow the master channel to be muted through pulseaudio.

I believe that this problem is associated with badly supported soundcards, like my Creative X-Fi one, but installing pulseaudio seems to have solved a lot of the problems I was having with my card, so that is the solution I suggest. Just remember to configure it properly for your setup.

Last edited by rabcor (2014-04-25 04:06:04)


Board footer

Powered by FluxBB