You are not logged in.

#1 2013-11-27 20:43:25

tkdncty2
Member
From: Budapest,Hungary
Registered: 2012-05-24
Posts: 23

Black screen for about 5 seconds after unlocking screen in KDE

Under KDE, I have the screen locker set to screen saver - black screen.

When the screen is locked and I move the mouse or press a key, the dialog box to enter my password comes up normally, however, after I enter it, the screen reverts back to the black screensaver for about 5 seconds. Sometimes this doesn't happen, mainly when I just booted up the system and try out this locking thing immediately.

I have a fairly powerful PC that can run KDE smoothly and I have kdm installed as display manager.

Have you ever come across a problem like this? How can I solve it?

Offline

#2 2013-12-01 02:26:22

achilleas.k
Member
From: Sol 3
Registered: 2011-10-30
Posts: 115

Re: Black screen for about 5 seconds after unlocking screen in KDE

Yup. Same here exactly. Happens on my desktop but it doesn't happen on my laptop, although I have almost identical setups on both machines.

It happens both when I resume from suspend and when I unlock after a long period of inactivity. I'll try changing the screensaver to something other than black screen and see if that changes anything. Maybe I'll get the screensaver image hanging instead of a black screen instead and we'll know it might be screensaver related.

Small note: When the black screen hangs, it looks like it's a window. It has a small frame across the top, like a window has then it's maximised above the panels and has no titlebar.

Offline

#3 2013-12-01 02:28:15

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,073

Re: Black screen for about 5 seconds after unlocking screen in KDE

Check your logs to see if there is anything interesting there.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#4 2013-12-01 11:04:03

Chawoosh
Member
From: Russia, Siberia, Tomsk
Registered: 2013-05-11
Posts: 27

Re: Black screen for about 5 seconds after unlocking screen in KDE

It's Nvidia effect, I guess. Last driver.

Offline

Board footer

Powered by FluxBB