You are not logged in.

#1 2014-01-08 21:24:13

Registered: 2012-05-16
Posts: 26

Soo much trouble setting up NIS (and if possible AutoFS)


I have recently started a company, and run an office with 4 workstations running ArchLinux and a server running Debian (Wheezy).

Ultimately I want this out of the network:

1. Centralised user accounts
2. Centralised home directories (mounted over network)
3. All users should be able to FTP in to the server externally, and reach all the files in their home directory.

As of now I will be happy just to get NIS working. The homedirectories i can sync over the network with Rsync and then easily share via FTP with VSFTP. So far, I have followed these guides: … _7.0&p=nis

NIS Problems:

1. I cant get change passwords. If I run yppasswd on a client, I will get "segmentation fault (core dumped)". Somewhere I read that if you only have one master server, no slaves, you can only change passwords in the server. I tried using yppasswd locally, but that just results in "NIS not being able to change password"
2. I want to have a seperate passwd and shadow file for NIS, so I was thinking of putting them in /var/yp/etc/, but will login through FTP work?

General questions:

1. Is it completely retarded of me to think i can get this working running ArchLinux clients? If so, what do you guys recommend?

Please. I'm running on 12 hours with this shit now and I just find more and more errors. I need help.


#2 2014-01-08 21:53:02

Registered: 2012-05-16
Posts: 26

Re: Soo much trouble setting up NIS (and if possible AutoFS)

Set up another box running ArchLinux just to see if i could get it running...

Followed the wiki on NIS, but I cannot start ypbind. I have up to starting the daemons, without problem. The make command runs fine, but i cannot start the goddamn ypbind daemon. Running systemctl status ypbind gives me.

ypbind.service - YP Bind
   Loaded: loaded (/usr/lib/systemd/system/ypbind.service; disabled)
   Active: failed (Result: exit-code) since Wed 2014-01-08 22:47:11 CET; 7s ago
  Process: 492 ExecStart=/usr/bin/ypbind (code=exited, status=1/FAILURE)

Journalctl -xn does not give me anything.

Last edited by iOfWhy (2014-01-08 22:49:58)


Board footer

Powered by FluxBB