You are not logged in.

#1 2014-01-10 02:26:44

Registered: 2013-02-09
Posts: 30

[Solved]NFS Client Not Mounting Shares

Here is my setup:

I have two Arch boxes that I am attempting to setup NFS shares on.  The box that is going to be the server is headless FYI.  So far, I have installed nfs-utils, started `rpc-idmapd` and `rpc-mountd` successfully on the server, and started `rpc-gssd` successfully on the client.

The folder I am trying to share is the /exports folder.

ls -l /exports


total 8
drwxrwxrw-+ 110 daniel  1004 4096 Dec  6 17:26 Movies
drwxrwxrwx+  13 daniel users 4096 Jan  8 19:12 TV-Shows

On the server:

# /etc/exports
# List of directories exported to NFS clients.  See exports(5).
# Use exportfs -arv to reread.
# Example for NFSv2 and NFSv3:
#  /srv/home       hostname1(rw,sync) hostname2(ro,sync)
# Example for NFSv4:
#  /srv/nfs4	   hostname1(rw,sync,fsid=0)
#  /srv/nfs4/home   hostname1(rw,sync,nohide)
# Using Kerberos and integrity checking:
#  /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt)
#  /srv/nfs4/home   gss/krb5i(rw,sync,nohide)

On the client:

showmount -e
Export list for

Everything is looking hunky-dory.  However, I go to mount using

sudo mount -t nfs4 /mnt/Media

and the mount never takes place.  It sits there and does nothing.  I CAN, however, kill the process with Ctrl-c.

So does anybody have ANY idea why my shares aren't working.

EDIT: Just thought I should mention that all of the data in the /exports folder is a mount --bind from /mnt/media.  All of the /mnt/media is contained on a USB external hard drive.  I did notice that there is an ACL.

getfacl /exports
getfacl: Removing leading '/' from absolute path names
# file: exports/
# owner: root
# group: root

Last edited by DaBungalow (2014-01-10 03:18:05)


#2 2014-01-10 03:17:42

Registered: 2013-02-09
Posts: 30

Re: [Solved]NFS Client Not Mounting Shares

I found what the problem was.  Apparently rpc_gssd was causing a problem.  Stopping it fixed everything.


Board footer

Powered by FluxBB