You are not logged in.

#1 2014-01-11 21:13:39

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

[workaround] dhcpcd not running when using Wicd

Recently I switched from networkmanager to Wicd. However, now I regularly get the following error messages:

Jan 11 21:16:14 thinkpad dhcpcd[28086]: dhcpcd not running
Jan 11 21:16:17 thinkpad dhcpcd[28101]: wls1: ipv6nd_sendrsprobe: sendmsg: Cannot assign requested address

As far as I understood the Wiki [1], then dhcpcd should not be running at all.

First, stop all previously running network daemons (like netctl, netcfg, dhcpcd, NetworkManager).
Disable any existing network management services, including netctl, netcfg, dhcpcd, and networkmanager. Refer to Systemd#Using_units.

dhcpcd is disabled on my system:

➜  ~  sudo systemctl status dhcpcd
[sudo] password for orschiro: 
dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled)
   Active: inactive (dead)

So why does the dhcpcd service report this error at all?

[1] https://wiki.archlinux.org/index.php/Wicd

Last edited by orschiro (2014-02-07 06:45:54)

Offline

#2 2014-01-11 23:57:55

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: [workaround] dhcpcd not running when using Wicd

It's not the service, it's the program, probably started by wicd. dhcpcd is a dependency of wicd. wicd is basically a layer on top of dhcpcd (and other tools).

Offline

#3 2014-01-12 05:51:47

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

So Wicd starts dhcpcd (the program) which then reports the error because it sees the service not running?

That sounds a little bit like a bug.

Offline

#4 2014-01-12 06:09:31

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [workaround] dhcpcd not running when using Wicd

No, the service has nothing to do with it.  The dhcpcd.service and dhcpcd@.service are actually unique to Arch.  If you check out abs, those two files are not provided in the srcpackage.  Wicd makes use of dhcpcd to obtain an IP still, but it is merely starting it as a child process.  It doesn't start or check for the dhcpcd.service, which it knows nothing about.

If you want to see if it is dhcpcd itself, then you can have it use dhclient instead.

Offline

#5 2014-01-12 08:34:18

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

Sorry, but I don't get it yet.

Wicd starts dhcpcd to obtain an IP address and then it is dhcpcd recognising that the dhcpcd.service is not running which of course makes sense because Wicd is running.

Is that correct?

In that case I can safely ignore the message, right?

Offline

#6 2014-01-12 12:06:59

Raynman
Member
Registered: 2011-10-22
Posts: 1,094

Re: [workaround] dhcpcd not running when using Wicd

orschiro wrote:

Sorry, but I don't get it yet.

Wicd starts dhcpcd to obtain an IP address and then it is dhcpcd recognising that the dhcpcd.service is not running which of course makes sense because Wicd is running.

Is that correct?

WonderWoofy just said that dhcpcd doesn't know anything about dhcpcd.service so how would it recognise this? It (one instance of dhcpcd) apparently checks if another instance is already running. If there was another instance running, dhcpcd would not know or care how it was started (by systemd using the .service file, by wicd, by you, ...).

In that case I can safely ignore the message, right?

I don't see this message in my journal (I do see the second one about ipv6nd_sendrsprobe), but I use NetworkManager (with dhcpcd) instead of wicd. If wicd is the only thing starting dhcpcd and you don't have any networking issues (or other strange log messages), I wouldn't worry about it.

Last edited by Raynman (2014-01-12 12:07:27)

Offline

#7 2014-01-12 21:51:32

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

I used to use networkmanager too and did not have this message. Apart from switching from networkmanager to wicd I haven't changed anything else. Thus wicd should be the only program actually launching dhcpcd.

➜  ~  ps aux | grep dhcpcd
orschiro  9788  0.0  0.0  12612  1076 pts/0    S+   22:49   0:00 grep dhcpcd
root     27183  0.0  0.0   8600   372 ?        Ss   20:51   0:00 /usr/sbin/dhcpcd -h thinkpad --noipv4ll wls1

But how can I double-check that really only wicd is starting dhcpcd?

Offline

#8 2014-01-15 09:21:10

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

I know that the Wicd wiki page explictly states not to run dhcpcd.service next to wicd.service but by starting dhcpcd.service the error vanishes and I do not encounter any incompatibilities with Wicd.

➜  ~  sudo systemctl status dhcpcd
dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; enabled)
   Active: active (running) since Wed 2014-01-15 06:20:23 CET; 3h 59min ago
 Main PID: 426 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
           └─426 /bin/dhcpcd -q -b

Jan 15 06:21:03 thinkpad dhcpcd[426]: wls1: carrier acquired
Jan 15 06:21:03 thinkpad dhcpcd[426]: wls1: soliciting an IPv6 router
Jan 15 06:21:03 thinkpad dhcpcd[426]: wls1: soliciting a DHCP lease
Jan 15 06:21:03 thinkpad dhcpcd[426]: control command: /usr/sbin/dhcpcd -h thinkpad --noipv4ll wls1
Jan 15 06:21:07 thinkpad dhcpcd[426]: wls1: offered 192.168.178.15 from 192.168.178.1
Jan 15 06:21:14 thinkpad dhcpcd[426]: wls1: leased 192.168.178.15 for 3600 seconds
Jan 15 06:21:14 thinkpad dhcpcd[426]: wls1: adding host route to 192.168.178.15 via 127.0.0.1
Jan 15 06:21:14 thinkpad dhcpcd[426]: wls1: adding route to 192.168.178.0/24
Jan 15 06:21:14 thinkpad dhcpcd[426]: wls1: adding default route via 192.168.178.1
Jan 15 06:21:16 thinkpad dhcpcd[426]: wls1: no IPv6 Routers available
➜  ~  sudo systemctl status wicd  
wicd.service - Wicd a wireless and wired network manager for Linux
   Loaded: loaded (/usr/lib/systemd/system/wicd.service; enabled)
   Active: active (running) since Wed 2014-01-15 06:20:28 CET; 4h 0min ago
 Main PID: 413 (wicd)
   CGroup: /system.slice/wicd.service
           ├─413 /usr/bin/python2 -O /usr/share/wicd/daemon/wicd-daemon.py --no-daemon
           ├─504 /usr/bin/python2 -O /usr/share/wicd/daemon/monitor.py
           └─868 wpa_supplicant -B -i wls1 -c /var/lib/wicd/configurations/08edb9736fbb -Dwext

Jan 15 06:21:08 thinkpad ntpd_intres[961]: host name not found: 0.pool.ntp.org
Jan 15 06:21:08 thinkpad ntpd_intres[961]: host name not found: 1.pool.ntp.org
Jan 15 06:21:08 thinkpad ntpd_intres[961]: host name not found: 2.pool.ntp.org
Jan 15 06:21:16 thinkpad ntpd[946]: Listen normally on 5 wls1 192.168.178.15 UDP 123
Jan 15 06:21:16 thinkpad ntpd[946]: peers refreshed
Jan 15 06:21:16 thinkpad ntpd[946]: new interface(s) found: waking up resolver
Jan 15 06:21:23 thinkpad ntpd_intres[961]: DNS 0.pool.ntp.org -> 5.200.6.34
Jan 15 06:21:23 thinkpad ntpd_intres[961]: DNS 1.pool.ntp.org -> 194.109.64.200
Jan 15 06:21:23 thinkpad ntpd_intres[961]: DNS 2.pool.ntp.org -> 95.85.59.120
Jan 15 06:21:28 thinkpad ntpd[946]: ntpd: time set -1.268633 s

Offline

#9 2014-01-15 15:42:24

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,975

Re: [workaround] dhcpcd not running when using Wicd

I am not near a machine running wicd right now, but the GUI lets you configure the back-end tools.  It should let you choose between Auto, dhcpcd, and dhclient.  You might ensure that you've that set to something rational


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#10 2014-01-15 16:54:23

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [workaround] dhcpcd not running when using Wicd

The curses interface can also be used for those settings as well.

Offline

#11 2014-01-15 20:31:10

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

@ewaller

I left these settings completely untouched (as apparently recommended).

ojOaVzk.png

Offline

#12 2014-01-22 08:38:08

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

Can the dhcpcd issue be related with the network target of systemd? If I comment out Wants and Before in wicd.service, then I do no longer get this error:

➜  ~  cat /etc/systemd/system/wicd.service 
[Unit]
Description=Wicd a wireless and wired network manager for Linux
#After=syslog.target
#Wants=network.target
#Before=network.target

[Service]
Type=dbus
BusName=org.wicd.daemon
ExecStart=/usr/bin/wicd --no-daemon

[Install]
WantedBy=multi-user.target
Alias=dbus-org.wicd.daemon.service

EDIT: Error is still occurring.

Last edited by orschiro (2014-02-07 06:44:32)

Offline

#13 2014-02-07 06:45:37

orschiro
Member
Registered: 2009-06-04
Posts: 2,136
Website

Re: [workaround] dhcpcd not running when using Wicd

For testing I switched from dhcpcd to dhclient in the Wicd settings. So far I cannot detect any obstacles when using dhclient. Plus the error vanishes and I don't have to modify any service files.

For now I will continue testing dhclient over dhcpcd.

Thanks all for your input!

Offline

Board footer

Powered by FluxBB