You are not logged in.

#1 2006-01-07 21:27:39

From: Lithuania
Registered: 2005-12-30
Posts: 40

Touchpad and USB Mouse / USB HDD / KDE

I am experiencing two problems, dunno if they really have something to do with each other, however I`ve decided to save some space and make one thread instead of two.

Touchpad and USB Mouse:
I know, it`s a typical problem, but I couldn`t find anything I could use at google.
Now onto the details: When I boot my laptop with usb mouse plugged in, I just can`t get into X, I get errors about synaptics touchpad not found. However when I boot arch without mouse plugged in, login and only then plug it in, everything`s fine. Google said something about that system automatically converts usb mouse to ps/2 and this causes problems. Anyways, I have no idea how to fix this. Tried comparing lsmod of both after booting with mouse and booting without it. Outputs were identical.

This is wierd, I actually dunno what`s causing this problem, but I guess it`s HDD. When I boot my laptop with External USB HDD plugged in and turned on, arch just can`t find any /dev/sda* not it recognises my mouse or anything (however mouse still gets power from usb, it`s diods are shining).
Then I tried booting with both my mouse and hdd off, plugged them back after login and viola, everything`s fine.

Of course I can live with these problems, but it`s annoying. I would really appreciate any help.

We all knew this was coming.
Third problem - KDE and keyboard:
Everything`s fine in console, but in KDE, when I try to type symbols like `´¨~ i have to press keyboard key twice, instead of once. How come?
This was pretty easy actually. These keys were assigned as dead keys and supposed to help ppl. Ya right!
What I did was
Control Center > Regional & Accessibility > Keyboard Layout > remove us layout and add en_US.
That`s it.


Board footer

Powered by FluxBB