You are not logged in.

#1 2014-03-26 02:05:09

0n3
Member
Registered: 2014-03-25
Posts: 6

[SOLVED]winbind ... Error looking up domain users

I have followed the Active Directory intergration Wiki to the letter, but stuck at the winbind section when i do i wbinfo -u or  i get Error looking up Domain users or domain groups....

[gigabyteme@wkstn1-arch ~]$ sudo wbinfo -u
[sudo] password for gigabyteme: 
Error looking up domain users
[gigabyteme@wkstn1-arch ~]$ wbinfo -u
Error looking up domain users
[gigabyteme@wkstn1-arch ~]$ wbinfo -g
failed to call wbcListGroups: WBC_ERR_WINBIND_NOT_AVAILABLE
Error looking up domain groups
[gigabyteme@wkstn1-arch ~]$ 

Here is my krb.conf file....

[libdefaults]
        default_realm 	= 	CLICK-IT.CA
	clockskew 	= 	300
	ticket_lifetime	=	1d
        forwardable     =       true
        proxiable       =       true
        dns_lookup_realm =      true
        dns_lookup_kdc  =       true
	
[realms]
	CLICK-IT.CA = {
		kdc 	= 	CITADSVR01.CLICK-IT.CA
                admin_server = CITADSVR01.CLICK-IT.CA
		default_domain = CLICK-IT.CA
	}
	
[domain_realm]
        .citadsvr01.click-it.ca = CLICK-IT.CA
	.click-it.ca = CLICK-IT.CA
	click-it.ca = CLICK-IT.CA
	click-it	= CLICK-IT.CA

[appdefaults]
	pam = {
	ticket_lifetime 	= 1d
	renew_lifetime 		= 1d
	forwardable 		= true
	proxiable 		= false
	retain_after_close 	= false
	minimum_uid 		= 0
	debug 			= false
	}

[logging]
	default 		= FILE:/var/log/krb5libs.log
	kdc 			= FILE:/var/log/kdc.log
        admin_server            = FILE:/var/log/kadmind.log

and here is my smb.conf file

/etc/samba/smb.conf

[Global]
  netbios name = WKSTN1-ARCH
  workgroup = CLICK-IT
  realm = CLICK-IT.CA
  server string = %h ArchLinux Host
  security = ads
  encrypt passwords = yes
  password server = citadsvr01.click-it.ca

  idmap config * : backend = rid
  idmap config * : range = 10000-20000

  winbind use default domain = no
  winbind enum users = Yes
  winbind enum groups = Yes
  winbind nested groups = Yes
  winbind separator = +
  winbind refresh tickets = yes

  template shell = /bin/bash
  template homedir = /home/%D/%U
   
  preferred master = no
  dns proxy = no
  wins server = pdc.example.com
  wins proxy = no

  inherit acls = Yes
  map acl inherit = Yes
  acl group control = yes

  load printers = no
  debug level = 3
  use sendfile = no

Any help with this would be greatly aprecieated...

Last edited by 0n3 (2014-03-28 05:27:43)

Offline

#2 2014-03-26 03:29:24

0n3
Member
Registered: 2014-03-25
Posts: 6

Re: [SOLVED]winbind ... Error looking up domain users

Please mark as solved, for some reason the winbindd service wasnt being started, i enabled and started it manually and it works now

Offline

#3 2014-03-26 08:11:04

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 2,732

Re: [SOLVED]winbind ... Error looking up domain users

0n3 wrote:

Please mark as solved, for some reason the winbindd service wasnt being started, i enabled and started it manually and it works now

You need to do that yourself.
https://wiki.archlinux.org/index.php/Fo … ow_to_Post


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

Board footer

Powered by FluxBB