You are not logged in.

#1 2014-04-04 16:14:49

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,509
Website

Connman --nameservers option "Error...not supported"

I'm trying to set a Nameserver for an SSID with connman and I'm not having any luck.

~ $ sudo connmanctl 
connmanctl> services 
*AO ssid_name          wifi_c48508086d6c_6669726563617434313533_managed_psk
connmanctl> config wifi_c48508086d6c_6669726563617434313533_managed_psk nameservers 8.8.8.8
Error wifi_c48508086d6c_6669726563617434313533_managed_psk: Not supported

I've also tried setting the 'Nameservers' line manually in the config file /var/lib/connman/ssid_name

[service_wifi_c48508086d6c_6669726563617434313533_managed_psk]                                                                          
Type = wifi
Name = ssid_name
Passphrase = secret
Nameservers = 8.8.8.8,8.8.4.4

And it still doesn't use the nameserver. Is this a bug or am I missing something obvious??

Thanks!
Scott

Edit: FYI, I've tried both connman from [community] and connman-git from the AUR.

Last edited by firecat53 (2014-04-04 16:23:20)

Offline

#2 2014-04-04 16:29:35

progandy
Member
Registered: 2012-05-17
Posts: 3,547

Re: Connman --nameservers option "Error...not supported"

AFAIK connman sets /etc/resolv.conf to 127.0.0.1. Then it listens there with a dns proxy which forwards requests to the nameservers set in your configuration.

I guess it should work this way (you did not add the dashes):

> config WIFI_CONN_ID --nameservers 8.8.8.8 8.8.8.4

Last edited by progandy (2014-04-04 16:34:36)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2014-04-04 16:38:12

firecat53
Member
From: Lake Stevens, Wa
Registered: 2007-05-14
Posts: 1,509
Website

Re: Connman --nameservers option "Error...not supported"

Yes, the nameserver line in /etc/resolv.conf is set to 127.0.0.1, and I've tried numerous times with the connmanctl config command (it accepts the argument with or without the dashes) and still get the same 'Error...not supported' result. I guess that's my point...it doesn't *seem* to be working the way it's supposed to and I'm wondering if anyone else is experiencing this or if I'm doing something wrong smile

Thanks,
Scott

Edit: Also, there's no entries or errors in journalctl that speak to setting the nameserver. It mentions setting hostname and domainname though.

Edit1: Hmmm, this is interesting: if I set the 'Nameservers' manually in the config file, it messes with my routing table:

~ $ ip r
default via 192.168.0.1 dev wlp2s0 
default via 192.168.0.1 dev wlp2s0  metric 303 
8.8.8.8 via 192.168.0.1 dev wlp2s0 
192.168.0.0/24 dev wlp2s0  proto kernel  scope link  src 192.168.0.202  metric 303 
192.168.0.1 dev wlp2s0  scope link 

and I get these entries in journalctl:

Apr 04 09:57:41 scotty connmand[12997]: Failed to connect to server 8.8.8.8
Apr 04 09:57:41 scotty connmand[12997]: Failed to connect to server 8.8.4.4

I'm not sure if that's new or I just never noticed it before....is that normal for connman?

Edit2: Well, I guess it does work when I manually add the 'Nameservers=' line to the config file for that network. I just wasn't being patient enough. However, using connmanctl to add the nameservers still fails as above, so I'll leave this topic open.

Last edited by firecat53 (2014-04-04 18:34:50)

Offline

Board footer

Powered by FluxBB