You are not logged in.

#1 2014-04-30 08:51:12

wootsgoinon
Member
Registered: 2013-10-30
Posts: 44

[SOLVED] no audio in some (rather old, native) games

soldier of fortune, unreal tournament, heretic II, postal to name a few work just fine except that there's no sound at all. i understand they use oss. a couple of months back i tried the padsp switcher but that wouldn't work either. I've got alsa and pulseaudio installed. also openal. any hints?

EDIT:
found a possible solution:

modprobe snd-pcm-oss

(theoretically) this applies to all of the loki games.

Last edited by wootsgoinon (2014-04-30 09:13:15)

Offline

#2 2014-04-30 17:55:03

ondoho
Member
Registered: 2013-04-30
Posts: 329

Re: [SOLVED] no audio in some (rather old, native) games

there was this oss emulation for alsa, if i only could remember the name...


To provide support, we have the expectation that you know the decisions that were made about your machine at the time of the install.

Offline

#3 2014-04-30 18:44:27

emeres
Member
Registered: 2013-10-08
Posts: 1,570

Re: [SOLVED] no audio in some (rather old, native) games

@ondoho
You mean aoss found in alsa-oss.

Offline

#4 2014-05-01 07:30:19

ondoho
Member
Registered: 2013-04-30
Posts: 329

Re: [SOLVED] no audio in some (rather old, native) games

why is this marked solved?
others might benefit if you share your solution.


To provide support, we have the expectation that you know the decisions that were made about your machine at the time of the install.

Offline

#5 2014-05-03 08:35:53

wootsgoinon
Member
Registered: 2013-10-30
Posts: 44

Re: [SOLVED] no audio in some (rather old, native) games

i have. see the EDIT section.

Offline

#6 2014-05-03 08:38:05

wootsgoinon
Member
Registered: 2013-10-30
Posts: 44

Re: [SOLVED] no audio in some (rather old, native) games

ondoho wrote:

there was this oss emulation for alsa, if i only could remember the name...

osspd-alsa (and osspd-pulseaudio for pulse). but that one didn't solve it for me.

Offline

Board footer

Powered by FluxBB