You are not logged in.

#1 2014-07-12 21:46:59

grim3271
Member
Registered: 2014-07-12
Posts: 37

[SOLVED] Nvidia drivers conflict with mesa-libgl

 [sol@Sol ~]$ sudo pacman -S nvidia
[sudo] password for sol: 
resolving dependencies...
looking for inter-conflicts...
:: nvidia-libgl and mesa-libgl are in conflict (libgl). Remove mesa-libgl? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: ati-dri: requires mesa-libgl
:: glamor-egl: requires mesa-libgl
:: intel-dri: requires mesa-libgl
:: nouveau-dri: requires mesa-libgl
[sol@Sol ~]$ 

Everytime i install nvidia drivers, I get this, What can i do? Pressing Y does not remove it.

Last edited by grim3271 (2014-07-14 00:00:58)

Offline

#2 2014-07-12 22:00:09

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: [SOLVED] Nvidia drivers conflict with mesa-libgl

I'm guessing you've installed the whole xorg group. Why do you have all these drivers? Remove them all and reinstall only the ones you need.

Offline

#3 2014-07-12 22:08:10

grim3271
Member
Registered: 2014-07-12
Posts: 37

Re: [SOLVED] Nvidia drivers conflict with mesa-libgl

karol wrote:

I'm guessing you've installed the whole xorg group. Why do you have all these drivers? Remove them all and reinstall only the ones you need.

I should have figured, I was kinda scared to remove them, Thanks for the help, First day with arch smile

Offline

#4 2014-07-13 16:53:18

karol
Archivist
Registered: 2009-05-06
Posts: 25,422

Re: [SOLVED] Nvidia drivers conflict with mesa-libgl

If the issue has been solved, please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

Offline

#5 2014-07-14 00:00:45

grim3271
Member
Registered: 2014-07-12
Posts: 37

Re: [SOLVED] Nvidia drivers conflict with mesa-libgl

karol wrote:

If the issue has been solved, please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

Ok, Will do

Offline

Board footer

Powered by FluxBB