You are not logged in.

#1 2014-08-03 20:29:36

homealone
Member
Registered: 2014-08-03
Posts: 1

WiFi Issues, TL-WN822N v.2, stays 'connecting...'

Hello,

I have a problem with my WiFi. I use the TP-LINK TL-WN822N v.2 USB WiFi Adapter.

# lsusb

Bus 003 Device 007: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]

I guess it uses the ath9k_htc driver

# lsmod

ath9k_htc              56055  0 
ath9k_common            8550  1 ath9k_htc
ath9k_hw              397498  2 ath9k_common,ath9k_htc
ath                    19483  3 ath9k_common,ath9k_htc,ath9k_hw
# dmesg | grep usbcore

[    3.580221] usbcore: registered new interface driver ath9k_htc

I work with Cinnamon and NetworkManager on

# uname -a

Linux PCNAME 3.15.7-1-ARCH #1 SMP PREEMPT Mon Jul 28 20:06:17 CEST 2014 x86_64 GNU/Linux

It seems, that all is working pretty well, because I'm able to see SSIDs in my range, but when I try to connect with my home wifi (WPA2), I get asked for the passphrase, which I enter correctly, but the NetworkingMangaer-Applet just stays on 'connecting ...'
For testing I tried to connect to my mobilephone hot-spot (no security) and here I got no problems. Also I have no issues to connect via lan cable. Usually I use DHCP put also when I give my pc static IP it wont work.

The WiFi Module is loaded:

# ip link

4: wlp0s20u9: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000
    link/ether a0:f3:c1:2d:d9:46 brd ff:ff:ff:ff:ff:ff
# iwconfig

wlp0s20u9  IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
# lsusb -v

Bus 003 Device 007: ID 0cf3:7015 Atheros Communications, Inc. TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x0cf3 Atheros Communications, Inc.
  idProduct          0x7015 TP-Link TL-WN821N v3 / TL-WN822N v2 802.11n [Atheros AR7010+AR9287]
  bcdDevice            2.02
  iManufacturer          16 
  iProduct               32 
  iSerial                48 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           60
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0x80
      (Bus Powered)
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           6
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x04  EP 4 OUT
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0040  1x 64 bytes
        bInterval               1
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x05  EP 5 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x06  EP 6 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0

What could be the problem, why can't I establish a connection?

Thnaks for your help!

Offline

#2 2014-08-04 15:47:37

loqs
Member
Registered: 2014-03-06
Posts: 8,141

Offline

Board footer

Powered by FluxBB