You are not logged in.

#1 2014-08-12 06:32:00

bstocker
Member
Registered: 2014-05-22
Posts: 5

[SOLVED] Cannot start X after upgrade

Hi

After upgrading to X Windows x-org-server 1.16, I cannot start X Windows, when typing "startx", I get this error:

  Fatal server error:
  xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

However, this file really exists, but it is owned by root. When I login using root, I can start X. How can I fix this without reverting to an old X version?

Many thanks.

Last edited by bstocker (2014-08-13 06:02:27)

Offline

#2 2014-08-12 10:33:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Cannot start X after upgrade

What's the output of

type startx
type -p startx

Maybe 'startx' is an alias and you're redirecting the output of startx, which breaks xorg-server 1.16.

Offline

#3 2014-08-12 12:06:05

bstocker
Member
Registered: 2014-05-22
Posts: 5

Re: [SOLVED] Cannot start X after upgrade

Thanks. Both commands output the same result: /usr/bin/startx

I've found that the problem is releated to the new X Windows that has been installed last night. After putting this in /etc/X11/Xwrapper.config:

allowed_users=anybody
needs_root_rights=yes

everything works fine again, when starting X Windows using startxfce4. This is maybe releated to my old Arch Linux installation which is at least 4 years old.

Offline

#4 2014-08-12 19:52:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Cannot start X after upgrade

Ummm, did you read the front page news?

Offline

#5 2014-08-12 20:13:13

bstocker
Member
Registered: 2014-05-22
Posts: 5

Re: [SOLVED] Cannot start X after upgrade

Of course I did!

Offline

#6 2014-08-13 01:02:48

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED] Cannot start X after upgrade

OK then, please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309 :-)

Offline

#7 2016-06-15 19:05:57

adam_danischewski
Banned
Registered: 2016-05-06
Posts: 23
Website

Re: [SOLVED] Cannot start X after upgrade

bstocker wrote:

I've found that the problem is releated to the new X Windows that has been installed last night. After putting this in /etc/X11/Xwrapper.config:

allowed_users=anybody
needs_root_rights=yes

everything works fine again, when starting X Windows using startxfce4. This is maybe releated to my old Arch Linux installation which is at least 4 years old.

I recently had this problem setting up xfce4 to run with a new user on a newly installed Virtualbox Arch Linux client and adding the above to /etc/X11/Xwrapper.config worked for me.

Offline

#8 2016-06-15 19:08:16

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,373
Website

Re: [SOLVED] Cannot start X after upgrade

Please don't necrobump; especially solved threads: https://wiki.archlinux.org/index.php/Co … bumping.22


Closing


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB