You are not logged in.

#1 2014-08-18 08:34:03

aligator
Member
Registered: 2013-10-07
Posts: 75

[solved] bumblebee -> can't use NVIDIA

hi

I can't find anything helpfull about this error.

johannes@arch-laptop ~ % optirun steam            
[ 1074.176912] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) systemd-logind: failed to get session: PID 753 does not belong to any known session

[ 1074.176969] [ERROR]Aborting because fallback start is disabled.
1 johannes@arch-laptop ~ %  cat /var/log/Xorg.8.log                                                                                                                                                                                                                         :(
[    25.790]
X.Org X Server 1.16.0
Release Date: 2014-07-16
[    25.790] X Protocol Version 11, Revision 0
[    25.790] Build Operating System: Linux 3.15.5-2-ARCH x86_64 
[    25.790] Current Operating System: Linux arch-laptop 3.16.1-1-ARCH #1 SMP PREEMPT Thu Aug 14 07:40:19 CEST 2014 x86_64
[    25.790] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=b9d0c62c-be3e-43e3-ae89-1908af570819 rw quiet
[    25.790] Build Date: 31 July 2014  11:53:19AM
[    25.790]  
[    25.790] Current version of pixman: 0.32.6
[    25.790]    Before reporting problems, check [url]http://wiki.x.org[/url]
        to make sure that you have the latest version.
[    25.790] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.791] (==) Log file: "/var/log/Xorg.8.log", Time: Tue Aug 19 10:09:35 2014
[    25.791] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[    25.791] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[    25.791] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    25.791] (==) ServerLayout "Layout0"
[    25.791] (==) No screen section available. Using defaults.
[    25.791] (**) |-->Screen "Default Screen Section" (0)
[    25.791] (**) |   |-->Monitor "<default monitor>"
[    25.791] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[    25.791] (**) |   |-->Device "DiscreteNvidia"
[    25.791] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[    25.791] (**) Option "AutoAddDevices" "false"
[    25.791] (**) Option "AutoAddGPU" "false"
[    25.791] (**) Not automatically adding devices
[    25.791] (==) Automatically enabling devices
[    25.791] (**) Not automatically adding GPU devices
[    25.791] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    25.791]    Entry deleted from font path.
[    25.791] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    25.791]    Entry deleted from font path.
[    25.791] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    25.791]    Entry deleted from font path.
[    25.791]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    25.791] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    25.791]    Entry deleted from font path.
[    25.791]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    25.791] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/
[    25.791] (++) ModulePath set to "/usr/lib/nvidia/xorg/,/usr/lib/xorg/modules"
[    25.791] (==) |-->Input Device "<default pointer>"
[    25.791] (==) |-->Input Device "<default keyboard>"
[    25.791] (==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
[    25.791] (==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.
[    25.791] (II) Loader magic: 0x818d80
[    25.791] (II) Module ABI versions:
[    25.791]    X.Org ANSI C Emulation: 0.4
[    25.791]    X.Org Video Driver: 18.0
[    25.791]    X.Org XInput driver : 21.0
[    25.791]    X.Org Server Extension : 8.0
[    25.792] (EE) systemd-logind: failed to get session: PID 753 does not belong to any known session
[    25.792] (II) xfree86: Adding drm device (/dev/dri/card1)
[    25.792] (II) xfree86: Adding drm device (/dev/dri/card0)
[    25.792] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[    25.793] (--) PCI:*(0:1:0:0) 10de:11e2:1558:3537 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    25.793] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    25.793] (II) LoadModule: "glx"
[    25.793] (II) Loading /usr/lib/nvidia/xorg/modules/extensions/libglx.so
[    25.879] (II) Module glx: vendor="NVIDIA Corporation"
[    25.879]    compiled for 4.0.2, module version = 1.0.0
[    25.879]    Module class: X.Org Server Extension
[    25.880] (II) NVIDIA GLX Module  340.32  Tue Aug  5 20:32:43 PDT 2014
[    25.880] (II) LoadModule: "nvidia"
[    25.881] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    25.886] (II) Module nvidia: vendor="NVIDIA Corporation"
[    25.886]    compiled for 4.0.2, module version = 1.0.0
[    25.886]    Module class: X.Org Video Driver
[    25.887] (II) LoadModule: "mouse"
[    25.887] (WW) Warning, couldn't open module mouse
[    25.887] (II) UnloadModule: "mouse"
[    25.887] (II) Unloading mouse
[    25.887] (EE) Failed to load module "mouse" (module does not exist, 0)
[    25.887] (II) LoadModule: "kbd"
[    25.887] (WW) Warning, couldn't open module kbd
[    25.887] (II) UnloadModule: "kbd"
[    25.887] (II) Unloading kbd
[    25.887] (EE) Failed to load module "kbd" (module does not exist, 0)
[    25.887] (II) NVIDIA dlloader X Driver  340.32  Tue Aug  5 20:13:04 PDT 2014
[    25.887] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    25.888] (--) using VT number 1

[    25.888] (II) Loading sub module "fb"
[    25.888] (II) LoadModule: "fb"
[    25.888] (II) Loading /usr/lib/xorg/modules/libfb.so
[    25.889] (II) Module fb: vendor="X.Org Foundation"
[    25.889]    compiled for 1.16.0, module version = 1.0.0
[    25.889]    ABI class: X.Org ANSI C Emulation, version 0.4
[    25.889] (WW) Unresolved symbol: fbGetGCPrivateKey
[    25.889] (II) Loading sub module "wfb"
[    25.889] (II) LoadModule: "wfb"
[    25.889] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    25.890] (II) Module wfb: vendor="X.Org Foundation"
[    25.890]    compiled for 1.16.0, module version = 1.0.0
[    25.890]    ABI class: X.Org ANSI C Emulation, version 0.4
[    25.890] (II) Loading sub module "ramdac"
[    25.890] (II) LoadModule: "ramdac"
[    25.890] (II) Module "ramdac" already built-in
[    25.892] (II) NVIDIA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[    25.892] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    25.892] (==) NVIDIA(0): RGB weight 888
[    25.892] (==) NVIDIA(0): Default visual is TrueColor
[    25.892] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    25.892] (**) NVIDIA(0): Option "NoLogo" "true"
[    25.892] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[    25.892] (**) NVIDIA(0): Option "UseEDID" "false"
[    25.892] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[    25.892] (**) NVIDIA(0): Enabling 2D acceleration
[    25.892] (**) NVIDIA(0): Ignoring EDIDs
[    25.892] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[    25.892] (**) NVIDIA(0):     mode
[    26.062] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    26.062] (EE) NVIDIA(GPU-0):     check your system's kernel log for additional error
[    26.062] (EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the
[    26.062] (EE) NVIDIA(GPU-0):     README for additional information.
[    26.062] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[    26.062] (EE) NVIDIA(0): Failing initialization of X screen 0
[    26.062] (II) UnloadModule: "nvidia"
[    26.062] (II) UnloadSubModule: "wfb"
[    26.062] (II) UnloadSubModule: "fb"
[    26.062] (EE) Screen(s) found, but none have a usable configuration.
[    26.062] (EE) 
Fatal server error:
[    26.062] (EE) no screens found(EE) 
[    26.062] (EE) 
Please consult the The X.Org Foundation support 
         at [url]http://wiki.x.org[/url]
 for help. 
[    26.062] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[    26.062] (EE) 
[    26.062] (EE) Server terminated with error (1). Closing log file.

dmesg:

 [...]

[   21.892672] NVRM: RmInitAdapter failed! (0x24:0x28:1170)
[   21.892678] NVRM: rm_init_adapter failed for device bearing minor number 0
[   21.892694] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5
[   21.897046] NVRM: request_irq() failed (-22)
[   21.897050] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -22
[   21.900586] NVRM: request_irq() failed (-22)
[   21.900590] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -22
[   21.906486] NVRM: request_irq() failed (-22)
[   21.906491] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -22
[   21.910275] NVRM: request_irq() failed (-22)
[   21.910279] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -22
[   22.193946] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off
[   25.312453] bbswitch: enabling discrete graphics
[   25.914870] vgaarb: this pci device is not a vga device
[   25.916494] nvidia 0000:01:00.0: irq 51 for MSI/MSI-X
[   25.918744] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918793] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918819] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918851] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918876] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918900] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918928] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.918953] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   25.964044] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[   26.083073] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   26.085289] NVRM: RmInitAdapter failed! (0x25:0x28:1196)
[   26.085296] NVRM: rm_init_adapter failed for device bearing minor number 0
[   26.085312] NVRM: nvidia_frontend_open: minor 0, module->open() failed, error -5
[   32.838914] bbswitch: enabling discrete graphics
[   54.361747] bbswitch: enabling discrete graphics
[   54.373589] nvidia 0000:01:00.0: Refused to change power state, currently in D3
[  272.255328] [drm] Module unloaded
[  292.733787] NVRM: This is a 64-bit BAR mapped above 4GB by the system
NVRM: BIOS or the Linux kernel, but the PCI bridge
NVRM: immediately upstream of this GPU does not define
NVRM: a matching prefetchable memory window.
[  292.733790] NVRM: This may be due to a known Linux kernel bug.  Please
NVRM: see the README section on 64-bit BARs for additional
NVRM: information.
[  292.733793] nvidia: probe of 0000:01:00.0 failed with error -1
[  292.734134] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  292.734135] NVRM: None of the NVIDIA graphics adapters were initialized!
[  292.734137] [drm] Module unloaded
[  292.734224] NVRM: NVIDIA init module failed!
[  601.447155] bbswitch: enabling discrete graphics
[  601.458443] pci 0000:01:00.0: Refused to change power state, currently in D3
[ 1074.830805] bbswitch: enabling discrete graphics
[ 1074.841537] pci 0000:01:00.0: Refused to change power state, currently in D3

edit: I think it has something to do with the new Xorg-server:
https://github.com/Bumblebee-Project/Bu … issues/600

Last edited by aligator (2014-08-20 17:15:19)

Offline

#2 2014-08-18 08:39:21

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 30,296
Website

Re: [solved] bumblebee -> can't use NVIDIA

Please use code tags, not quote tags, when pasting to the boards: https://wiki.archlinux.org/index.php/Fo … s_and_Code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2014-08-18 10:13:03

okubax
Member
From: Kent, UK.
Registered: 2010-04-24
Posts: 210
Website

Re: [solved] bumblebee -> can't use NVIDIA

Output of

 systemctl status bumblebeed 

and

 sudo lspci -k | grep -A 2 -i "VGA" 

Offline

#4 2014-08-18 10:28:30

aligator
Member
Registered: 2013-10-07
Posts: 75

Re: [solved] bumblebee -> can't use NVIDIA

johannes@arch-laptop ~ %  systemctl status bumblebeed 
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled)
   Active: active (running) since Di 2014-08-19 12:12:40 CEST; 11min ago
 Main PID: 290 (bumblebeed)
   CGroup: /system.slice/bumblebeed.service
           └─290 /usr/bin/bumblebeed

Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738516] [ERROR][XORG] (EE) NVIDIA(0): Failing initialization of X screen 0
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738519] [ERROR][XORG] (EE) Screen(s) found, but none have a usable configuration.
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738521] [ERROR][XORG] (EE)
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738525] [ERROR][XORG] (EE) no screens found(EE)
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738528] [ERROR][XORG] (EE)
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738531] [ERROR][XORG] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738533] [ERROR][XORG] (EE)
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.738535] [ERROR][XORG] (EE) Server terminated with error (1). Closing log file.
Aug 19 12:13:03 arch-laptop bumblebeed[290]: [   26.741900] [ERROR]X did not start properly
Aug 19 12:13:22 arch-laptop bumblebeed[290]: [   45.367149] [ERROR]Could not enable discrete graphics card
1 johannes@arch-laptop ~ %  sudo lspci -k | grep -A 2 -i "VGA"                                                                                                                                                                                                              :(
[sudo] password for johannes: 
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: CLEVO/KAPOK Computer Device 3537
        Kernel driver in use: i915
1 johannes@arch-laptop ~ % sudo lspci -k | grep -A 2 -i "NVIDIA"                                                                                                                                                                                                            :(
01:00.0 3D controller: NVIDIA Corporation GK106M [GeForce GTX 765M] (rev ff)
        Kernel driver in use: nvidia
        Kernel modules: nouveau, nvidia


The strange thing is that sometimes it works great after reboot...

Last edited by aligator (2014-08-18 10:30:10)

Offline

#5 2014-08-18 12:08:39

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: [solved] bumblebee -> can't use NVIDIA

It looks like there are some other people, including me, who suffer from this issue too.
here and here

And there seems to be no explanation nor a solution..although I "feel"(I have no objective measurements) that chenxiaolongs solution makes it work more often. But it still fails for me sometimes too.

Edit:typo

Last edited by dice (2014-08-18 12:09:28)


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

#6 2014-08-18 12:37:30

aligator
Member
Registered: 2013-10-07
Posts: 75

Re: [solved] bumblebee -> can't use NVIDIA

Yes, I found these threads, too...


I have enabled verbose and debug kernel parameters, because of another problem I have and I noticed something:

I don't use a Display Manager, so I get the messages. And there is a message from bbswitch, that it is enabled, but this message shows allways a little bit later. and if I log in and start x before this message shows, bumblebee fails.

I'm not sure if this is realy the problem, maybe it was just by chance...


edit: I tested this a few times now and it really seems to be like this.
so the Xorg-server somehow blocks bbswitch if it is started before bbswitch is fully initialized.

Last edited by aligator (2014-08-18 19:26:37)

Offline

#7 2014-08-18 21:12:02

Akikyo
Member
Registered: 2014-02-13
Posts: 4

Re: [solved] bumblebee -> can't use NVIDIA

I have experianced exactly the same error but solved it by this:

beidl wrote:

1) Upgrade to testing (selectively downloading the new linux, bbswitch and nvidia packages might work as well).

2) In /etc/mkinitcpio.conf I changed the MODULES var to:

MODULES="i915 bbswitch"

and did the usual

# mkinitcpio -p linux

3) In /etc/default/grub I added:

rcutree.rcu_idle_gp_delay=1

to GRUB_CMDLINE_LINUX_DEFAULT. My guess is that this one is crucial to get it running, as it was suggested by bumblebee devs.
And of course:

# grub-mkconfig -o /boot/grub/grub.cfg

4) In my /etc/bumblebee/bumblebee.conf under [optirun] I changed the bridge method to:

Bridge=virtualgl

and of course the usual things like setting the Driver under [bumblebeed] to nvidia.
Manually overriding the bridge method on demand via "optirun -b primus" still works of course.

5) In /etc/bumblebee/xorg.conf.nvidia i set the BusID of my NVIDIA card (lspci | grep VGA | grep NVIDIA):

BusID "PCI:01:00:0"

Aaaaand it's working nicely. smile

https://bbs.archlinux.org/viewtopic.php?pid=1326090

Reboot and then run optirun in x86_64 like this:

optirun glxspheres64

Hope it will work also for you wink

Last edited by Akikyo (2014-08-18 21:26:20)

Offline

#8 2014-08-19 07:56:21

aligator
Member
Registered: 2013-10-07
Posts: 75

Re: [solved] bumblebee -> can't use NVIDIA

Does this MODULES="i915 bbswitch" means that bbswitch is loaded earlier?

if it is so, I think that is what helps. because then bbswitch is allways ready before xorg starts.

edit:
I only did the MODULES-part of your fix and I tested it now a few times.
It seems to solve the problem smile, but the startup time is a litle bit longer sad

Can someone verify this?


edit2:
I added this fix to the Wiki

Last edited by aligator (2014-08-20 17:15:53)

Offline

#9 2014-08-19 15:49:05

dice
Member
From: Germany
Registered: 2014-02-10
Posts: 413

Re: [solved] bumblebee -> can't use NVIDIA

I added the given modules to mkinitcpio and did a couple of reboots and there wasn't a single one on which optirun failed to start. It seems as if this is a solution. But I can't tell 100% because it was randomly failing before so maybe I'm, just lucky at the moment wink
However this

Aug 19 17:39:43 obsidian bumblebeed[629]: [   92.495635] [ERROR][XORG] (EE) systemd-logind: failed to get session: PID 5030 does not belong to any known session

error still appears in journalctl when using optirun but it appears to have no negative effect.


I put at button on it. Yes. I wish to press it, but I'm not sure what will happen if I do.  (Gune | Titan A.E.)

Offline

Board footer

Powered by FluxBB