You are not logged in.

#1 2014-10-07 16:47:19

anatolik
Developer
Registered: 2012-09-27
Posts: 408

[SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

I would like to share solution for a problem with openssh in [testing].

After updating openssh to 6.7p1 I've got a scary warning "key_load_public: invalid format" for my ECDSA plublic key when try to connect to a server. I looked at openssh code and found that it does not like "-----BEGIN" string in the public key (see function sshkey_try_load_public). And it what I had in my public key file - I think previous version of openssh generated it.

I removed "-----BEGIN/END EC PUBLIC KEY-----" lines and now openssh seems happy.

Offline

#2 2014-10-27 22:41:10

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 371
Website

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

This is out of testing, so I got a surprise as well, however I get this with ecdsa key:

debug1: key_parse_private2: missing begin marker

Haven't found a solution yet.


--
JSkier

Offline

#3 2014-10-27 22:59:27

graysky
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2008-12-01
Posts: 9,179
Website

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

jskier wrote:

This is out of testing, so I got a surprise as well, however I get this with ecdsa key:

debug1: key_parse_private2: missing begin marker

Haven't found a solution yet.

@js - There is not an openssh package in [testing]... not sure what you're talking about.

Last edited by graysky (2014-10-27 22:59:40)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#4 2014-10-27 23:08:51

anatolik
Developer
Registered: 2012-09-27
Posts: 408

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

At the time of positing it openssh 6.7p1 was in [testing]. I've decided to share my finding to make other people's life a bit easier.

Offline

#5 2014-10-27 23:15:25

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 23,030
Website

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

Moving from [testing] to avoid further confusion...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#6 2014-10-27 23:36:45

graysky
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2008-12-01
Posts: 9,179
Website

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

anatolik wrote:

At the time of positing it openssh 6.7p1 was in [testing]. I've decided to share my finding to make other people's life a bit easier.

My comment was direct at jskier.  Not too sure why he/she posted to be honest.  Might serve to confuse some folks.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#7 2014-10-27 23:43:39

jskier
Member
From: Minnesota, USA
Registered: 2003-07-30
Posts: 371
Website

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

graysky wrote:
anatolik wrote:

At the time of positing it openssh 6.7p1 was in [testing]. I've decided to share my finding to make other people's life a bit easier.

My comment was direct at jskier.  Not too sure why he/she posted to be honest.  Might serve to confuse some folks.

Yes, I stated this was out of testing right away, but was reporting another issue with the new version. Sorry for the confusion, I'll start another thread later.

Last edited by jskier (2014-10-27 23:44:18)


--
JSkier

Offline

#8 2014-10-30 13:32:22

spychalski
Member
Registered: 2012-03-11
Posts: 7

Re: [SOLVED] openssh 6.7p1 warning "key_load_public: invalid format"

Having this issue with my id_rsa key, I attempted to remove the ----- BEGIN/END ----- from the file but it still gives me issues when I try to run ssh-copy-id.

edit: nevermind... just had to convert my key from ssh.com to openssh.

Last edited by spychalski (2014-10-30 14:28:59)

Offline

Board footer

Powered by FluxBB