You are not logged in.

#1 2014-12-15 21:03:08

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Wifi incredibly slow using netctl and rtl8192cu

Hello. I've only just Arch today after mostly being a Windows user for the past 10 years and Ubuntu (essentially GUI only) for the last 3, and so far it's working mostly fine; I've gotten everything set up OK, including dwm, general setup and the lot. However I'm having trouble with my wifi connection. It will work fine for the first few minutes after boot. After 5 or 10 minutes (seemingly made shorter by downloading stuff), it will drop out completely. After this, I can do a netctl restart VM2G to get it working again, but it will be very slow (50kB/s versus the usual 4MB/s; my profile name in netctl is VM2G) and drop out after about 30 seconds of usage.
I have confirmed that this is not an issue with the router:

  • I have restarted the router to no effect. It is a Virgin Media SuperHub 2ac.

  • I have restarted the computer to no effect, other than the temporary fix for a few minutes.

  • It works fine if I boot into Windows 8.1.

  • It works fine if I use another computer (running Windows 10 preview or Xubuntu 14.04)

I'm not too sure what the issue actually is, and I'm not too acquainted with Arch yet, so I've gotten some information which seems appropriate.

dmesg | tail -n 27

[ 7382.685388] wlp0s4f1u6: disassociated from 80:37:73:11:05:80 (Reason: 2)
[ 7382.725767] cfg80211: Calling CRDA to update world regulatory domain
[ 7383.596290] wlp0s4f1u6: authenticate with 80:37:73:11:05:80
[ 7383.620553] wlp0s4f1u6: send auth to 80:37:73:11:05:80 (try 1/3)
[ 7383.643254] wlp0s4f1u6: authenticated
[ 7383.645958] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 1/3)
[ 7383.749272] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 2/3)
[ 7383.803871] wlp0s4f1u6: RX AssocResp from 80:37:73:11:05:80 (capab=0x411 status=0 aid=3)
[ 7383.803899] wlp0s4f1u6: associated
[ 7383.803957] cfg80211: Calling CRDA to update world regulatory domain
[ 7385.824746] wlp0s4f1u6: disassociated from 80:37:73:11:05:80 (Reason: 2)
[ 7385.851277] cfg80211: Calling CRDA for country: GB
[ 7398.262875] wlp0s4f1u6: authenticate with 80:37:73:11:05:80
[ 7398.287564] wlp0s4f1u6: send auth to 80:37:73:11:05:80 (try 1/3)
[ 7398.299153] wlp0s4f1u6: authenticated
[ 7398.302620] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 1/3)
[ 7398.405880] wlp0s4f1u6: RX AssocResp from 80:37:73:11:05:80 (capab=0x411 status=0 aid=3)
[ 7398.406071] wlp0s4f1u6: associated
[ 7402.405393] wlp0s4f1u6: disassociated from 80:37:73:11:05:80 (Reason: 2)
[ 7402.438295] cfg80211: Calling CRDA to update world regulatory domain
[ 7437.936152] wlp0s4f1u6: authenticate with 80:37:73:11:05:80
[ 7437.960575] wlp0s4f1u6: send auth to 80:37:73:11:05:80 (try 1/3)
[ 7438.013012] wlp0s4f1u6: authenticated
[ 7438.015945] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 1/3)
[ 7438.056015] wlp0s4f1u6: RX AssocResp from 80:37:73:11:05:80 (capab=0x411 status=0 aid=3)
[ 7438.056040] wlp0s4f1u6: associated
[ 7438.056097] cfg80211: Calling CRDA to update world regulatory domain

netctl status VM2G

netctl@VM2G.service - Automatically generated profile by wifi-menu
   Loaded: loaded (/etc/systemd/system/netctl@VM2G.service; enabled)
   Active: active (exited) since Mon 2014-12-15 20:19:00 GMT; 17min ago
     Docs: man:netctl.profile(5)
  Process: 3095 ExecStop=/usr/lib/network/network stop %I (code=exited, status=0/SUCCESS)
  Process: 3113 ExecStart=/usr/lib/network/network start %I (code=exited, status=0/SUCCESS)
 Main PID: 3113 (code=exited, status=0/SUCCESS)

Dec 15 20:23:11 archbox dhcpcd[3175]: wlp0s4f1u6: adding default route via 192.168.0.1
Dec 15 20:30:50 archbox dhcpcd[3175]: wlp0s4f1u6: carrier lost
Dec 15 20:30:50 archbox dhcpcd[3175]: wlp0s4f1u6: deleting route to 192.168.0.0/24
Dec 15 20:30:50 archbox dhcpcd[3175]: wlp0s4f1u6: deleting default route via 192.168.0.1
Dec 15 20:31:49 archbox dhcpcd[3175]: wlp0s4f1u6: carrier acquired
Dec 15 20:31:49 archbox dhcpcd[3175]: wlp0s4f1u6: IAID fc:f8:14:aa
Dec 15 20:31:49 archbox dhcpcd[3175]: wlp0s4f1u6: rebinding lease of 192.168.0.2
Dec 15 20:31:54 archbox dhcpcd[3175]: wlp0s4f1u6: leased 192.168.0.2 for 86400 seconds
Dec 15 20:31:54 archbox dhcpcd[3175]: wlp0s4f1u6: adding route to 192.168.0.0/24
Dec 15 20:31:54 archbox dhcpcd[3175]: wlp0s4f1u6: adding default route via 192.168.0.1

lsusb entry

Bus 001 Device 005: ID 0846:9021 NetGear, Inc. WNA3100M(v1) Wireless-N 300 [Realtek RTL8192CU]

lsmod | grep wi

rtlwifi                54662  2 rtl_usb,rtl8192cu
mac80211              604448  3 rtl_usb,rtlwifi,rtl8192cu
cfg80211              445286  2 mac80211,rtlwifi

Any suggestions? If you need any more log data or anything, I can provide it. This is a brand new installation of arch, so I don't think anything is outdated.

EDIT: Occasionally when dhcpcd was attempting to lease an IP address, it would time out. This hasn't happened since the last restart though and I can't seem to make it do so.

Last edited by Quackmatic (2014-12-16 11:42:14)


Tom.

Offline

#2 2014-12-15 23:31:49

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

It happened again; another excerpt from dmesg:

[ 3071.251809] wlp0s4f1u6: disassociated from 80:37:73:11:05:80 (Reason: 2)
[ 3071.356715] cfg80211: Calling CRDA for country: GB
[ 3072.226666] wlp0s4f1u6: authenticate with 80:37:73:11:05:80
[ 3072.251113] wlp0s4f1u6: send auth to 80:37:73:11:05:80 (try 1/3)
[ 3072.275319] wlp0s4f1u6: authenticated
[ 3072.276391] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 1/3)
[ 3072.296558] wlp0s4f1u6: RX AssocResp from 80:37:73:11:05:80 (capab=0x411 status=0 aid=3)
[ 3072.296606] wlp0s4f1u6: associated
[ 3076.301186] wlp0s4f1u6: disassociated from 80:37:73:11:05:80 (Reason: 2)
[ 3076.330852] cfg80211: Calling CRDA to update world regulatory domain
[ 3088.746594] wlp0s4f1u6: authenticate with 80:37:73:11:05:80
[ 3088.771125] wlp0s4f1u6: send auth to 80:37:73:11:05:80 (try 1/3)
[ 3088.821687] wlp0s4f1u6: authenticated
[ 3088.823045] wlp0s4f1u6: associate with 80:37:73:11:05:80 (try 1/3)
[ 3088.878191] wlp0s4f1u6: RX AssocResp from 80:37:73:11:05:80 (capab=0x411 status=0 aid=3)
[ 3088.878236] wlp0s4f1u6: associated
[ 3088.878353] cfg80211: Calling CRDA to update world regulatory domain

From netctl status:

● netctl@VM2G.service - Automatically generated profile by wifi-menu
   Loaded: loaded (/etc/systemd/system/netctl@VM2G.service; enabled)
   Active: active (exited) since Mon 2014-12-15 22:19:56 GMT; 1h 11min ago
     Docs: man:netctl.profile(5)
  Process: 234 ExecStart=/usr/lib/network/network start %I (code=exited, status=0/SUCCESS)
 Main PID: 234 (code=exited, status=0/SUCCESS)

Dec 15 22:19:56 archbox network[234]: Started network profile 'VM2G'
Dec 15 23:10:50 archbox dhcpcd[384]: wlp0s4f1u6: carrier lost
Dec 15 23:10:50 archbox dhcpcd[384]: wlp0s4f1u6: deleting route to 192.168.0.0/24
Dec 15 23:10:50 archbox dhcpcd[384]: wlp0s4f1u6: deleting default route via 192.168.0.1
Dec 15 23:11:08 archbox dhcpcd[384]: wlp0s4f1u6: carrier acquired
Dec 15 23:11:08 archbox dhcpcd[384]: wlp0s4f1u6: IAID fc:f8:14:aa
Dec 15 23:11:09 archbox dhcpcd[384]: wlp0s4f1u6: rebinding lease of 192.168.0.2
Dec 15 23:11:14 archbox dhcpcd[384]: wlp0s4f1u6: leased 192.168.0.2 for 86400 seconds
Dec 15 23:11:14 archbox dhcpcd[384]: wlp0s4f1u6: adding route to 192.168.0.0/24
Dec 15 23:11:14 archbox dhcpcd[384]: wlp0s4f1u6: adding default route via 192.168.0.1

Tom.

Offline

#3 2014-12-16 11:06:42

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Wifi incredibly slow using netctl and rtl8192cu

Welcome to the forums.
It is highly unlikely netctl causing this, more likely it is the wireless module for your card which still gets a lot of updates with each new kernel. You might want to edit the header of your thread to include your wireless module "rtl8192cu" to get attention of users of it (I am not) and search the forums for relevant threads (I have not). If you believe it is indeed netctl, post the profile you are using to connect (masking out the passphrase).

Something you can try: Enable software encryption

#modprobe -r rtl8192cu 
# modprobe rtl8192cu swenc=1

before starting the profile.

If that does not help, the wiki mentions an alternative module: https://wiki.archlinux.org/index.php/Wireless#rtl8192cu

edit: (correct module naming)
and another thing: The references to switch between "GB" and "world domain" in your dmesg are strange. Check you have the crda packages installed, mentioned here: https://wiki.archlinux.org/index.php/Wi … ory_domain

Last edited by Strike0 (2014-12-16 11:15:31)

Offline

#4 2014-12-17 18:23:19

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

Hi, thanks for the response!
Enabling software encryption seemed to have no effect. I synced the crda packages as it appeared I didn't have them but that also had no effect. Therefore I installed the 8192cu-dkms package (I've not used the AUR up to this point.) It seems to have worked to some degree as the 8192cu kernel module is present. However, the network interface isn't working and wifi-menu is throwing errors like 'ioctl[SIOCSISWAP]: Operation not permitted'. Previously the interface thing was called wlp0s4f1u6, now it is enp0s4f1u6 which suggests to me that it is being misidentified as an ethernet device. Looking at dmesg it says 'Link is not ready'. It also seems that  rtl8192cu is maintaining some presence, as early in dmesg is a line saying 'registered new interface driver rtl8192cu' and 'rtl8192cu: wlp0s4f1u6: renamed from wlan0'.

I suspect I may have missed a step in the installation, but the package comes with no readme or anything (as it probably shouldn't.) Do I need to do anything with dkms after running makepkg?

Last edited by Quackmatic (2014-12-17 18:24:54)


Tom.

Offline

#5 2014-12-19 20:01:43

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Wifi incredibly slow using netctl and rtl8192cu

You cannot run both at the same time, probably the "operation not permitted" results from that. To try the module from AUR you must unload the generic rtl8192cu first, which you can only do after you bring the interface down.
To let the AUR module load on boot, you should blacklist the rtl8192cu to prevent it getting loaded: https://wiki.archlinux.org/index.php/Kernel_modules

Offline

#6 2014-12-19 23:50:50

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

I think I've worked out part of the problem. I have already blacklisted the rtl8192cu driver from being loaded (both by putting it into a .conf file in /etc/modprobe.d and by referring to that file in the FILES variable of the mkinitcpio config and recreating it), but rtl8192cu is still being loaded at some point as it pops up in my dmesg, even though it's absent from lsmod.  I've tried every method I've found so far to try and stop rtl8192cu from being loaded but it's still sticking around... hence I get the 'dependency failed' messages in the netctl logs. I suspect the presence of rtl8192cu is stopping something else from loading.

Your help so far has been great by the way, thanks for helping me to sort this out. Besides this wifi issue, literally everything else is working great!


Tom.

Offline

#7 2014-12-20 10:27:52

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Wifi incredibly slow using netctl and rtl8192cu

You're welcome, sounds you are getting the grips with Arch which is great. Have a look at the last two comments of the AUR package page: https://aur.archlinux.org/packages/8192cu-dkms/
The user seemed to have the same problem. To test whether the AUR package works better, maybe just do what he has done (move the original module directory out the way, reinstall the package from Aur).

Offline

#8 2014-12-21 10:43:24

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

Still not working I'm afraid. I think the still-present rtl8192cu is just the device firmware, as on my Raspberry Pi (which works fine with the 8192cu module and the same dongle) shows the same thing in dmesg. However I'm still getting the link is not ready messages in dmesg and inability to connect to any networks.
I think the problem may have more to do with the dependency failed messages in systemctl status logs. What could be causing that? It appears any time I try to use the network.


Tom.

Offline

#9 2014-12-21 14:20:26

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: Wifi incredibly slow using netctl and rtl8192cu

Well, it should be very evident from dmesg if it is the firmware loading. You should revert to pasting the error output in case someone can help you with interpretation. What's the kernel release on your Rasp Pi?

Offline

#10 2014-12-22 14:12:28

mk_arch
Member
Registered: 2014-10-21
Posts: 3

Re: Wifi incredibly slow using netctl and rtl8192cu

I had similar problems after update.

Look at this post.

Offline

#11 2015-03-21 09:26:06

Quackmatic
Member
Registered: 2014-12-15
Posts: 8
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

To add some closure to this topic: I stopped using the wireless USB adapter causing the problem as I couldn't fix the issue at all. I've reverted to using a slower but functional Linksys adapter which has worked perfectly so far. Sorry to any google-ers looking for a solution - I've been looking for three months and found none. It's probably cheaper for you to just use another device (I'm now using the Linksys WUSB54GC v1 802.11g adapter instead which worked out-of-the-box with no setup).

Last edited by Quackmatic (2015-03-21 09:28:36)


Tom.

Offline

#12 2015-03-21 16:22:34

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 4,940
Website

Re: Wifi incredibly slow using netctl and rtl8192cu

Offline

Board footer

Powered by FluxBB