You are not logged in.

#1 2015-02-09 17:46:00

Pitou
Member
Registered: 2011-02-13
Posts: 62

[SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Hello,

I have an issue since I've updated my system a couple of days ago.

NFS and autofs doesn't automount my nfs share.

[manager@univers ~]$ sudo systemctl start rpc-statd.service
Job for rpc-statd.service failed. See "systemctl status rpc-statd.service" and "journalctl -xe" for details.
[manager@univers ~]$ sudo systemctl status rpc-statd.service
● rpc-statd.service - NFS status monitor for NFSv2/3 locking.
   Loaded: loaded (/usr/lib/systemd/system/rpc-statd.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since lun 2015-02-09 12:42:35 EST; 1min 45s ago
  Process: 4407 ExecStart=/usr/sbin/rpc.statd --no-notify $STATDARGS (code=exited, status=1/FAILURE)

fév 09 12:42:35 univers rpc.statd[4408]: Version 1.3.2 starting
fév 09 12:42:35 univers rpc.statd[4408]: Flags: TI-RPC
fév 09 12:42:35 univers rpc.statd[4408]: Running as root.  chown /var/lib/nfs to choose different user
fév 09 12:42:35 univers rpc.statd[4408]: failed to create RPC listeners, exiting
fév 09 12:42:35 univers systemd[1]: rpc-statd.service: control process exited, code=exited status=1
fév 09 12:42:35 univers systemd[1]: Failed to start NFS status monitor for NFSv2/3 locking..
fév 09 12:42:35 univers systemd[1]: Unit rpc-statd.service entered failed state.
fév 09 12:42:35 univers systemd[1]: rpc-statd.service failed.
[manager@univers ~]$ 

Any idea?

Thank you.

Pitou!

Last edited by Pitou (2015-02-10 17:37:20)

Offline

#2 2015-02-09 19:07:16

samla
Member
Registered: 2013-06-08
Posts: 1

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Would also like help with this, getting the same error as above.

Thanks

Sam

Offline

#3 2015-02-09 21:12:31

Dieter@be
Forum Fellow
From: Belgium
Registered: 2006-11-05
Posts: 1,960
Website

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

exact same problem here.
FWIW when i try to mount, I get:

```
~ ❯❯❯ sudo mount readynas:/c/shared-storage ~/nas-direct                                           
[sudo] password for dieter:
Job for rpc-statd.service failed. See "systemctl status rpc-statd.service" and "journalctl -xe" for details.
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified
```


< Daenyth> and he works prolifically
4 8 15 16 23 42

Offline

#4 2015-02-09 23:38:29

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,329

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Exactly the same problem here.  I ended up reverting nfs-utils to 1.3.1-1 so I could continue connecting to nfsv3

Offline

#5 2015-02-10 00:23:33

Pitou
Member
Registered: 2011-02-13
Posts: 62

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

@skunktrader,

Could you tell me how you proceeded to revert back to nfs-utils 1.3.1-1. I never did that before.

Any procedure, tutorial you can point me out?

Thank you very much.

Pitou!

Offline

#6 2015-02-10 08:41:56

runical
Member
From: The Netherlands
Registered: 2012-03-03
Posts: 874

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

@Pitou: Search the wiki

https://wiki.archlinux.org/index.php/Do … g_packages

Last edited by runical (2015-02-10 08:42:13)

Offline

#7 2015-02-10 10:27:39

SubS0
Member
Registered: 2015-02-10
Posts: 28

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Hi,

got the same problem this morning. Errors at boot and impossibility to load nfs-server.
I didn't need to downgrade nfs-utils, just to re-enable rpcbind and reboot. Don't know why it has been disabled !
Everything works fine now.

Offline

#8 2015-02-10 14:11:22

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,361

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

What you need is to start rpcbind, I have also stumbled upon this problem and I suppose the service files should include a dependency on rpcbind.

The wiki says to start rpcbind manually (and on every boot) but I suppose this might get fixed upstream eventually.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#9 2015-02-10 17:36:27

Pitou
Member
Registered: 2011-02-13
Posts: 62

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Thanks SubS0, re-enabling the rpcbind service and rebooting did solve the problem for me as well.

Pitou!

Offline

#10 2015-02-26 05:50:53

Ohkeenan
Member
Registered: 2015-01-28
Posts: 1

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Pitou wrote:

Thanks SubS0, re-enabling the rpcbind service and rebooting did solve the problem for me as well.

Pitou!

Worked here too. Specifically:

sudo systemctl enable rpcbind.socket
sudo systemctl restart rpcbind.service
sudo mount -a

Thanks

Offline

#11 2015-05-03 21:04:45

TheAmigo
Member
Registered: 2008-04-08
Posts: 62

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Just updated my system and encountered this problem too, so it's not been fixed yet.

Had to run:

systemctl enable rpcbind
systemctl start rpcbind
systemctl start nfs-server

Although, that middle step may not be necessary.

Offline

#12 2015-08-20 08:45:42

Lindhe
Member
Registered: 2015-05-13
Posts: 14

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Fantastic! Do anyone know why this happens?

Offline

#13 2016-02-14 18:51:42

spychodelics
Member
Registered: 2009-06-08
Posts: 22

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

is it fixed for you guys? i encounter the same problem

Offline

#14 2016-02-16 13:08:23

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 4,181
Website

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

@spychodelics,

Did you try the solutions mentioned in this thread? Since this is a solved thread, I would ask you to open a new one.

Offline

#15 2016-02-16 20:14:36

spychodelics
Member
Registered: 2009-06-08
Posts: 22

Re: [SOLVED] AutoFS NFS doesn't mount on startup, failed to create rpc

Yes, i tried the solutions but it didnt work. I moved to SMB for now since i needed that too. Thank you.

Offline

Board footer

Powered by FluxBB