You are not logged in.

#1 2015-02-28 22:21:15

frank604
Member
From: BC, Canada
Registered: 2011-04-20
Posts: 1,196

[SOLVED]Suspend works on laptop lid close but not w/ systemctl suspend

** Realized it was due to sd card, see edit below **

I do have TLP installed.  Laptop lid close works:

● systemd-logind.service - Login Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-logind.service; static; vendor preset: disabled)
   Active: active (running) since Sat 2015-02-28 11:31:43 PST; 2h 36min ago
     Docs: man:systemd-logind.service(8)
           man:logind.conf(5)
           http://www.freedesktop.org/wiki/Software/systemd/logind
           http://www.freedesktop.org/wiki/Software/systemd/multiseat
 Main PID: 383 (systemd-logind)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-logind.service
           └─383 /usr/lib/systemd/systemd-logind

Feb 28 11:37:48 AetherX systemd-logind[383]: Suspending...
Feb 28 13:48:18 AetherX systemd-logind[383]: Lid opened.
Feb 28 13:48:18 AetherX systemd-logind[383]: Operation finished.
Feb 28 13:48:37 AetherX systemd-logind[383]: Lid closed.
Feb 28 13:48:47 AetherX systemd-logind[383]: Suspending...
Feb 28 13:48:51 AetherX systemd-logind[383]: Operation finished.
Feb 28 13:49:20 AetherX systemd-logind[383]: Suspending...
Feb 28 13:49:54 AetherX systemd-logind[383]: Lid opened.
Feb 28 13:49:54 AetherX systemd-logind[383]: Operation finished.
Feb 28 14:02:05 AetherX systemd-logind[383]: Operation finished.

Dmesg for wakeup:

xhci_hcd 0000:00:14.0: System wakeup enabled by ACPI

acpi wakeup:

cat /proc/acpi/wakeup                                                                                                                                      
Device	S-state	  Status   Sysfs node
P0P2	  S3	*disabled
EC	  S4	*disabled  platform:PNP0C09:00
HDEF	  S3	*disabled  pci:0000:00:1b.0
RP01	  S3	*disabled  pci:0000:00:1c.0
RP02	  S3	*disabled  pci:0000:00:1c.1
RP03	  S3	*disabled  pci:0000:00:1c.2
ARPT	  S4	*disabled  pci:0000:03:00.0
RP05	  S3	*disabled  pci:0000:00:1c.4
RP06	  S3	*disabled  pci:0000:00:1c.5
SPIT	  S3	*disabled  platform:APP000D:00
XHC1	  S3	*enabled   pci:0000:00:14.0
ADP1	  S4	*disabled  platform:ACPI0003:00
LID0	  S4	*enabled   platform:PNP0C0D:00

lspci -k

00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
	Subsystem: Intel Corporation Device 7270
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci

So what I did was disable xhc1 in acpi's wakeup and tried to systemctl suspend again.  This time the dmesg wakeup shows

ACPI: Waking up from system sleep state S3

I did see this thread
Since xhci_hcd is used by xhci_pci I wasn't sure how to test this.  rmmod xhci_pci disables keyboard.

EDIT:

There is an sd card mounted (transcend jetdrive lite) which was preventing the suspend.  I have mounted it via fstab (since I never remove it) and by udiskie but both don't seem to unmount/poweroff the sdcard when I do systemctl suspend.  How would I go about this?  I just found autofs and will give that a go but if anyone has some feedback let me know!

EDIT 2:

Strange.  This time I tried to mount manually with

udisks --mount /dev/sdb1

and tried to manually suspend and it worked.  I'm glad I wrote this post as it helped write down my thoughts.  Hope it helps others.

Last edited by frank604 (2015-02-28 23:08:14)

Offline

#2 2015-06-25 23:28:59

rembo10
Member
Registered: 2011-10-11
Posts: 8

Re: [SOLVED]Suspend works on laptop lid close but not w/ systemctl suspend

How did you find out it was the SD card? I'm having the same problem but nothing is plugged in

Offline

Board footer

Powered by FluxBB