You are not logged in.

#1 2015-04-28 03:47:16

ephreal
Member
Registered: 2014-03-29
Posts: 22

Xl create fails with libxl errors [SOLVED]

I have recently reinstalled my xen w/Archlinux as Dom0 due to hardware changes. Seeing as I was curious about the more recent version of xen as opposed to 4.3, I went ahead and installed the 4.5-git version from the AUR. Post installation, I attempted to start my VM with

 xl create <config file>

I was returned an error, and after some time, I checked the output from

 xl list 

and noticed that my Dom0 was labeled (null). After a bit of fiddling, I found that running

 xenstore-write "local/domain/0/domid" 0

would get me back in business. Recently, however, I have started having trouble starting anything at all. Now when attempting to start my VM's, I am getting errors related to libxl. The output is as follows:

 
Parsing config from /root/xen/Server2012.cfg
libxl: error: libxl_create.c:1153:domcreate_launch_dm: unable to add disk devices
libxl: error: libxl_dm.c:1595:kill_device_model: unable to find device model pid in /local/domain/3/image/device-model-pid
libxl: error: libxl.c:1603:libxl__destroy_domid: libxl__destroy_device_model failed for 3
libxl: error: libxl_device.c:797:libxl__initiate_device_remove: unable to get my domid
libxl: error: libxl_device.c:797:libxl__initiate_device_remove: unable to get my domid
libxl: error: libxl.c:1640:devices_destroy_cb: libxl__devices_destroy failed for 3

While I have no doubt that the errors are telling me exactly what my problem is, I'm not sure how to go about fixing it. Would anyone have any ideas on things to try?

Last edited by ephreal (2015-05-16 00:12:01)

Offline

#2 2015-05-15 12:52:17

ephreal
Member
Registered: 2014-03-29
Posts: 22

Re: Xl create fails with libxl errors [SOLVED]

The xen packages in the aur have been recently updated. I'll try those and see if upgrading/downgrading will solve the problem.

Offline

#3 2015-05-16 00:11:42

ephreal
Member
Registered: 2014-03-29
Posts: 22

Re: Xl create fails with libxl errors [SOLVED]

Downgrading from the 4.5-git version solved the problem.

Offline

#4 2018-11-28 15:33:16

ephreal
Member
Registered: 2014-03-29
Posts: 22

Re: Xl create fails with libxl errors [SOLVED]

I had this happen again, and I believe I have found the true source of the problem this time. It appears that after an update and restart, if certain packages are upgraded, the package must be rebuilt and reinstalled. I'm not sure which package it is, but I suspect it to be the linux kernel. If you are having this same problem, try rebuilding your xen package and reinstalling it. Downgrading your xen package should not be necessary.

Offline

Board footer

Powered by FluxBB