You are not logged in.

#1 2015-04-28 15:51:02

acottrell
Member
Registered: 2013-12-17
Posts: 18

problem with gnuplot and wxwidgets

Fully updated arch x86_64 system as of today. I think this is new since
the pacman update for wxwidgets on April 24.

When I run gnuplot 5.0 and invoke the wxt terminal, I'm seeing

Warning: Mismatch between the program and library build versions detected.
The library used
  3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used
  3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8).

I've tried googling the C++ ABI version issue but haven't found anything
directly relevant to this case.

Offline

#2 2015-04-29 04:54:40

foutrelis
Developer/TU
From: Athens, Greece
Registered: 2008-07-28
Posts: 677
Website

Re: problem with gnuplot and wxwidgets

That's a harmless warning that will go away once more stuff gets built with GCC >= 5.1.

It's caused by an overly strict C++ ABI check in wxGTK; that check used to trigger a fatal error but we've changed it to print a warning instead.

For more details see the following links:

https://bugzilla.redhat.com/show_bug.cgi?id=1200611
https://lists.fedoraproject.org/piperma … 08976.html

Offline

#3 2015-08-16 15:56:38

firewalker
Member
From: Hellas (Greece).
Registered: 2006-06-05
Posts: 462

Re: problem with gnuplot and wxwidgets

Is it still normal to receive those warnings?


Γίνε ρεαλιστής, μείνε ονειροπόλος ...

Offline

Board footer

Powered by FluxBB