You are not logged in.

#1 2015-04-28 15:51:02

Registered: 2013-12-17
Posts: 23

problem with gnuplot and wxwidgets

Fully updated arch x86_64 system as of today. I think this is new since
the pacman update for wxwidgets on April 24.

When I run gnuplot 5.0 and invoke the wxt terminal, I'm seeing

Warning: Mismatch between the program and library build versions detected.
The library used
  3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used
  3.0 (wchar_t,compiler with C++ ABI 1002,wx containers,compatible with 2.8).

I've tried googling the C++ ABI version issue but haven't found anything
directly relevant to this case.


#2 2015-04-29 04:54:40

From: Athens, Greece
Registered: 2008-07-28
Posts: 699

Re: problem with gnuplot and wxwidgets

That's a harmless warning that will go away once more stuff gets built with GCC >= 5.1.

It's caused by an overly strict C++ ABI check in wxGTK; that check used to trigger a fatal error but we've changed it to print a warning instead.

For more details see the following links: … 08976.html


#3 2015-08-16 15:56:38

From: Hellas (Greece).
Registered: 2006-06-05
Posts: 509

Re: problem with gnuplot and wxwidgets

Is it still normal to receive those warnings?

Γίνε ρεαλιστής, μείνε ονειροπόλος ...


Board footer

Powered by FluxBB