You are not logged in.

#1 2015-05-31 22:37:51

druuu
Member
Registered: 2015-05-29
Posts: 3

[SOLVED]Silent boot remove autologin message.

Hi,
I tried booting directly to X with silent boot, autologin and startx at login, everything was fine but the only thing that appears on screen before getting into X is "Arch linux version and autologin message" and then startx is executed automatically and its output is redirected to /dev/null so no woories about startx output.

So I want to remove displaying arch linux version (tty1), autologin message.

Last edited by druuu (2015-06-02 06:08:15)

Offline

#2 2015-05-31 23:13:06

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED]Silent boot remove autologin message.

Offline

#3 2015-06-01 05:46:55

druuu
Member
Registered: 2015-05-29
Posts: 3

Re: [SOLVED]Silent boot remove autologin message.

I am not getting systemd version message as I have already got rid of that, the message that I get is:
"Arch Linux 4.0.4-2-ARCH (tty1)

<username> login: root (automatic login)"

Then startx is executed. So I want to remove the above message from displaying. Thank you for reply:P

Offline

#4 2015-06-01 12:15:43

KairiTech
Member
From: Toronto, Canada
Registered: 2011-06-04
Posts: 240

Re: [SOLVED]Silent boot remove autologin message.

You are not alone. I have been searching for a solution to this for a while now with no luck.


-=[ LIVE enabled UEFI with redundant syslinux pure systemd detached LUKS header partitionless encrypted GPT SSDx3 RAID0 because I can.  ]=-

Backward compatibility is for the masses. There's no dual-boot here...

Offline

#5 2015-06-01 12:40:58

Raynman
Member
Registered: 2011-10-22
Posts: 1,250

Re: [SOLVED]Silent boot remove autologin message.

For autologin, you had to modify agetty's command line. Reading its man page is a good start. It tells you how to stop it from displaying the contents of the /etc/issue file (that's the first line you see) and it tells you that it invokes /bin/login, but then the "login:" part is also a good hint. So, check login's man page; there's some stuff about hushlogin that seems like a good bet. See how quiet you can get it with that.

Offline

#6 2015-06-02 06:04:10

druuu
Member
Registered: 2015-05-29
Posts: 3

Re: [SOLVED]Silent boot remove autologin message.

Ok Archians..After procrastinating with this for 2nights I figured that only hostname can be removed through agetty options, so I had to do it the hard-way!
Compile util-linux by commenting out "printf(_("%s%s (automatic login)"), LOGIN, options.autolog);" from src/util-linux/term-utils/agetty.c file.


And now I am quiet..The quieter I become the more I listen

Offline

#7 2015-11-17 09:09:42

lfairy
Member
Registered: 2015-11-16
Posts: 3

Re: [SOLVED]Silent boot remove autologin message.

I solved this without recompiling agetty.

Run systemctl edit getty@tty1 and replace the contents with:

[Service]
ExecStart=
ExecStart=-/usr/bin/agetty --skip-login --login-options "-f usernamehere" %I 38400 linux

This configuration emulates the behavior of --auto-login without triggering the extra output.

Last edited by lfairy (2015-11-17 09:17:04)

Offline

Board footer

Powered by FluxBB