You are not logged in.

#1 2006-04-08 20:35:46

Registered: 2006-01-05
Posts: 84

[SOLVED] Samba: Arch Server to dualboot Arch/XP Desktop

Where to begin....the problem I suppose.

The Problem: I set up samba as best I could figure out from arch's wiki and's offical how to. Done. Go to My Network Places in XP (after a reboot of course) and don't see anything. Click on View Workgroup Computers and I get "workgroup" is not accessible. I head on over to's "The Samba Checklist" and start running through some troubleshooting. First failure of troubleshooting is:
ping BOA-S0 (server) from XP returns correct class c ip address (staticly assigned)
ping BOA-D0 (XP box) from server returns
(Odd, as the XP box's tcp/ip settings are assigned staicly by me in the same class c framework set up on the server. Only thing different is last octet of ip address.)
ping x.x.x.(x+1) (the correct class c ip address of XP box instead of pinging the hostname) from server doesn't resolve.

Machines are connected via a router. Router is set up for static ip addressing. IP scheme is as follows:
Router=x.x.x.x     BOA-S0=x.x.x.(x+1)     BOA-D0=x.x.x.(x+2)
Gateway=router's ip address     DNS=dns ip's of isp

I believe I have my smb.conf set up properly and some further troubleshooting from the checklist narrows it down to nmbd problems. But before I get into that, I wanted to see if anyone has any thoughts on the ping issue.

Thanks to cactus' help on irc we figured out the pinging issue (my fault, zonealarm was dorking it up) so at least now I can ping both ways and have each box resolve the correct ip address. Unfortunately, I still receive the same error message when trying to click on View Workgroup Computers. Now that i know the machines are seeing eachother properly from a tcp/ip standpoint, any thoughts on the error message and why I can't connect to the server's share?

I know it's not the way it should be done, but I installed ubuntu and set up samba, got it working, saved the smb.conf reinstalled arch and used the working smb.conf. I don't know what was wrong, must have been some of the syntax.


Board footer

Powered by FluxBB