You are not logged in.

#1 2006-04-10 19:58:48

riwa
Member
From: Lund, Sweden
Registered: 2006-04-04
Posts: 214

Suddenly get "connection refused" by ssh?

It's been working for long now. Always fine. now I get connection refused even on localhost. I haven't really tried it since I (yesterday) updated the kernel to -8. How come?

/Richard

[EDIT]
It would be nice with a "checklist" for a working ssh.
[/EDIT]


If you must have must. Have must.
- DKE supporters about this wonderful swedish soda.

Offline

#2 2006-04-11 07:25:19

FUBAR
Member
From: Belgium
Registered: 2004-12-08
Posts: 1,029
Website

Re: Suddenly get "connection refused" by ssh?

I your sshd running? Is your /etc/hosts.allow still the same? Are you using a firewall?


A bus station is where a bus stops.
A train station is where a train stops.
On my desk I have a workstation.

Offline

#3 2006-04-11 14:20:20

riwa
Member
From: Lund, Sweden
Registered: 2006-04-04
Posts: 214

Re: Suddenly get "connection refused" by ssh?

I've never been using a firewall. top tells me I have ssh agent running. I removed some probably unnecassary setting from hosts.allow after it stopped working. One (which I tried just to se if telnet worked) ALL: ALL, and something else that didn't matter. I still have sshd: ALL set so I don't understand what it could be. Should I maybie launch the ssh daemon at startup?


If you must have must. Have must.
- DKE supporters about this wonderful swedish soda.

Offline

#4 2006-04-12 01:22:07

iphitus
Forum Fellow
From: Melbourne, Australia
Registered: 2004-10-09
Posts: 4,927

Re: Suddenly get "connection refused" by ssh?

you need sshd running. /etc/rc.d/sshd restart

Offline

Board footer

Powered by FluxBB