You are not logged in.

#1 2016-01-10 20:48:23

johanli
Member
Registered: 2016-01-10
Posts: 12

[SOLVED]a stop job is running for login service

I face a problem confuse me.

the arch linux  was installed yesterday. when I want to reboot it, I have to wait. so I test it on the text mode (ctr+alt+F4), it shows the information

a stop job is running for login service

the initial time is 90 seconds, however,  when it close to 90 seconds, it will increase the time.  so I have to wait for ever.

Last edited by johanli (2016-02-02 12:24:22)

Offline

#2 2016-01-10 20:55:13

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 4,101
Website

Re: [SOLVED]a stop job is running for login service

Possibly related:
https://bbs.archlinux.org/viewtopic.php?id=203112

How are you attempting to reboot?

How are you logging in?

What is the output of:

loginctl session-status

EDIT: Please also describe your installation procedure in more detail.

Last edited by Head_on_a_Stick (2016-01-10 20:55:52)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." - Antoine de Saint Exupéry

How to report a problem

Offline

#3 2016-01-10 21:02:29

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

reboot:

1. enter a text mode by hiting ctrl+alt+F4
2. reboot

then

a stop job is running for login service


login

so I have to force poweroff by pressing power button

and boot it again

actually I am not clear what you want to know.


Head_on_a_Stick wrote:

Possibly related:
https://bbs.archlinux.org/viewtopic.php?id=203112

How are you attempting to reboot?

How are you logging in?

What is the output of:

loginctl session-status

EDIT: Please also describe your installation procedure in more detail.

Last edited by johanli (2016-01-10 21:03:09)

Offline

#4 2016-01-10 21:05:17

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

login session-status

c2 - li (1000)
           Since: Sun 2016-01-10 21:27:16 CET; 36min ago
          Leader: 688 (gdm-session-wor)
            Seat: seat0; vc2
             TTY: /dev/tty2
         Service: gdm-password; type x11; class user
           State: active
            Unit: session-c2.scope
                  ├─ 688 gdm-session-worker [pam/gdm-password]
                  ├─ 701 /usr/bin/gnome-keyring-daemon --daemonize --login
                  ├─ 704 /usr/lib/gdm/gdm-x-session --run-script gnome-session
                  ├─ 706 /usr/lib/xorg-server/Xorg vt2 -displayfd 3 -auth /run/user/1000/gdm/Xauthority -nolisten tcp -background none -noreset -keeptty -verbose 3
                  ├─ 709 /usr/lib/gnome-session/gnome-session-binary
                  ├─ 740 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
                  ├─ 781 /usr/bin/gnome-shell
                  ├─ 783 syndaemon -i 1.0 -t -K -R
                  ├─ 789 /usr/lib/gnome-settings-daemon/gsd-printer
                  ├─ 801 ibus-daemon --xim --panel disable
                  ├─ 806 /usr/lib/ibus/ibus-dconf
                  ├─ 808 /usr/lib/ibus/ibus-x11 --kill-daemon
                  ├─ 844 /usr/lib/evolution/evolution-alarm-notify
                  ├─ 850 /usr/lib/ibus-libpinyin/ibus-engine-libpinyin --ibus
                  ├─ 863 zeitgeist-datahub
                  ├─1110 /home/li/.dropbox-dist/dropbox-lnx.x86_64-3.12.5/dropbox /newerversion
                  ├─1201 firefox
                  ├─1645 xterm
                  ├─1649 bash
                  ├─1805 /usr/lib/firefox/plugin-container /usr/lib/mozilla/plugins/libflashplayer.so -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 1201 plugin
                  ├─1920 loginctl session-status
                  └─1921 less

Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) AIGLX: Resuming AIGLX clients after VT switch
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) modeset(0): EDID vendor "LGD", prod id 826
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) modeset(0): Printing DDC gathered Modelines:
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) modeset(0): Modeline "1366x768"x0.0   76.50  1366 1402 1450 1546  768 771 776 824 -hsync -vsync (49.5 kHz eP)
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) modeset(0): Modeline "1366x768"x0.0   51.00  1366 1402 1450 1564  768 771 776 814 -hsync -vsync (32.6 kHz e)
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) systemd-logind: got resume for 13:68
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) systemd-logind: got resume for 13:71
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) systemd-logind: got resume for 13:79
Jan 10 21:59:16 localhost /usr/lib/gdm/gdm-x-session[704]: (II) systemd-logind: got resume for 13:73

Head_on_a_Stick wrote:

Possibly related:
https://bbs.archlinux.org/viewtopic.php?id=203112

How are you attempting to reboot?

How are you logging in?

What is the output of:

loginctl session-status

EDIT: Please also describe your installation procedure in more detail.

Offline

#5 2016-01-10 21:10:46

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 4,101
Website

Re: [SOLVED]a stop job is running for login service

johanli wrote:

actually I am not clear what you want to know

Yeah, that's fine, you enter `reboot` in the console and press return, right?

Open a terminal window and run this command:

journalctl -xf

Then attempt to reboot from the GNOME panel and post any terminal output that appears.
EDIT: Actually, are you using GNOME?

Please use code tags when posting terminal output.

Which guide did you follow when installing Arch?

Last edited by Head_on_a_Stick (2016-01-10 21:12:10)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." - Antoine de Saint Exupéry

How to report a problem

Offline

#6 2016-01-10 21:18:09

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

well, I installed arch linux in the virtualbox before.
this time, I installed it directly on my laptop.

I mainly followed the tutorial from the video.

https://www.youtube.com/watch?v=METZCp_JCec

the output of "journalctl -xf"

-- Logs begin at Fri 2016-01-08 19:27:10 CET. --
Jan 10 22:10:32 localhost systemd[1]: Starting Network Service...
-- Subject: Unit systemd-networkd.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit systemd-networkd.service has begun starting up.
Jan 10 22:10:32 localhost systemd-networkd[1984]: Enumeration completed
Jan 10 22:10:32 localhost systemd[1]: Started Network Service.
-- Subject: Unit systemd-networkd.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit systemd-networkd.service has finished starting up.
-- 
-- The start-up result is done.
Head_on_a_Stick wrote:
johanli wrote:

actually I am not clear what you want to know

Yeah, that's fine, you enter `reboot` in the console and press return, right?

Open a terminal window and run this command:

journalctl -xf

Then attempt to reboot from the GNOME panel and post any terminal output that appears.
EDIT: Actually, are you using GNOME?

Please use code tags when posting terminal output.

Which guide did you follow when installing Arch?

Offline

#7 2016-01-10 21:25:26

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 4,101
Website

Re: [SOLVED]a stop job is running for login service

johanli wrote:

I mainly followed the tutorial from the video.

https://www.youtube.com/watch?v=METZCp_JCec

That guide is nonsense and over a year old.

Go through the Beginner's Guide step by step and see what you have missed.

https://wiki.archlinux.org/index.php/Beginners'_guide

The `journalctl` output you have posted looks like you did not attempt to reboot after running the command -- why not?

EDIT: Please stop full-quoting my posts at the end of your replies, it is utterly pointless and makes the thread more difficult to read.

Last edited by Head_on_a_Stick (2016-01-10 21:26:18)


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." - Antoine de Saint Exupéry

How to report a problem

Offline

#8 2016-01-10 22:07:24

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

That guide is nonsense and over a year old.
Go through the Beginner's Guide step by step and see what you have missed.

https://wiki.archlinux.org/index.php/Beginners'_guide


I tried to force to poweroff by ctr+alt+del (press them more than 7 times in 2 seconds)
it shows

failed to finalize file system, ignoring

when I check the Beginner's guide, I find a problem in the installation.
  I did not creat a new EFI system  and format it as fat32

Offline

#9 2016-01-10 22:28:55

lokoum
Member
Registered: 2014-07-22
Posts: 18

Re: [SOLVED]a stop job is running for login service

Hello guys,

I am facing with the same problem since few days: "A stop job is running for Login Service" when I try to poweroff or reboot (from command line, I do not use any GUI to poweroff/reboot)
here is the output for loginctl session-status

c1 - troncy_l (1000)
           Since: Sun 2016-01-10 23:15:57 UTC; 8min ago
          Leader: 289 (login)
            Seat: seat0; vc1
             TTY: tty1
         Service: login; type tty; class user
           State: active
            Unit: session-c1.scope
                  ├─ 289 login -- troncy_l
                  ├─ 507 /bin/sh /usr/bin/startx
                  ├─ 545 xinit /home/troncy_l/.xinitrc -- /etc/X11/xinit/xserverrc :0 vt1 -auth /tmp/serverauth.qkxuqjMFCH
                  ├─ 546 /usr/lib/xorg-server/Xorg -nolisten tcp :0 vt1 -auth /tmp/serverauth.qkxuqjMFCH
                  ├─ 552 i3
                  ├─ 561 i3bar --bar_id=bar-0 --socket=/run/user/1000/i3/ipc-socket.552
                  ├─ 562 i3status
                  ├─ 577 urxvt
                  ├─ 578 zsh
                  ├─ 602 /usr/bin/zsh
                  ├─ 605 /opt/google/chrome/chrome
                  ├─ 612 cat
                  ├─ 613 cat
                  ├─ 618 /opt/google/chrome/chrome-sandbox /opt/google/chrome/chrome --type=zygote
                  ├─ 619 /opt/google/chrome/chrome --type=zygote
                  ├─ 621 /opt/google/chrome/chrome-sandbox /opt/google/chrome/nacl_helper
                  ├─ 622 /opt/google/chrome/nacl_helper
                  ├─ 624 /opt/google/chrome/chrome --type=zygote
                  ├─ 748 /opt/google/chrome/chrome --type=renderer --lang=en-US --force-fieldtrials=AffiliationBasedMatching/EnabledThroughFieldTrial/AppBannerTriggering/Aggressive/CaptiveP$
                  ├─ 753 /proc/self/exe --type=gpu-process --channel=605.2.1035391618 --supports-dual-gpus=false --gpu-driver-bug-workarounds=2,3,18,25,33,47,51,63 --disable-accelerated-vid$
                  ├─ 756 /opt/google/chrome/chrome --type=renderer --lang=en-US --force-fieldtrials=AffiliationBasedMatching/EnabledThroughFieldTrial/AppBannerTriggering/Aggressive/CaptiveP$
                  ├─ 808 /proc/self/exe --type=gpu-process --channel=605.2.1035391618 --supports-dual-gpus=false --gpu-driver-bug-workarounds=2,3,18,25,33,47,51,63 --disable-accelerated-vid$
                  ├─ 972 /opt/google/chrome/chrome --type=renderer --lang=en-US --force-fieldtrials=AffiliationBasedMatching/EnabledThroughFieldTrial/AppBannerTriggering/Aggressive/CaptiveP$
                  ├─1000 /opt/google/chrome/chrome --type=renderer --lang=en-US --force-fieldtrials=AffiliationBasedMatching/EnabledThroughFieldTrial/AppBannerTriggering/Aggressive/CaptiveP$
                  ├─1235 /opt/google/chrome/chrome --type=renderer --lang=en-US --force-fieldtrials=AffiliationBasedMatching/EnabledThroughFieldTrial/AppBannerTriggering/Aggressive/CaptiveP$
                  ├─1489 loginctl session-status
                  └─1490 most

I use i3wm.
Thank you.

Offline

#10 2016-01-11 01:37:15

dviktor
Member
Registered: 2015-10-18
Posts: 52

Re: [SOLVED]a stop job is running for login service

seems like I'm experiencing the same problem!

Offline

#11 2016-01-11 08:12:10

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

dviktor wrote:

seems like I'm experiencing the same problem!

you are right, so what is the solution?

Offline

#12 2016-01-11 08:15:58

dviktor
Member
Registered: 2015-10-18
Posts: 52

Re: [SOLVED]a stop job is running for login service

The dirty work-around is to log out from DE, log in to the tty2 (or anything else without starting X again) and then manually

shutdown now

or

reboot

Offline

#13 2016-01-11 09:20:06

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

dviktor wrote:

The dirty work-around is to log out from DE, log in to the tty2 (or anything else without starting X again) and then manually

shutdown now

or

reboot

thank you very much!

it is working.

systemctl isolate multi-users.target

reboot

then this problem was gone.

I still have a question, why it works?

Offline

#14 2016-01-11 09:30:20

dviktor
Member
Registered: 2015-10-18
Posts: 52

Re: [SOLVED]a stop job is running for login service

Has the problem gone permanently after this combination or only for single reboot?

Offline

#15 2016-01-11 12:32:52

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

dviktor wrote:

Has the problem gone permanently after this combination or only for single reboot?

this problem gone permanently.

Offline

#16 2016-01-11 13:08:01

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

johanli wrote:
dviktor wrote:

Has the problem gone permanently after this combination or only for single reboot?

this problem gone permanently.


acutally it is not really solve it.
I mean it works this moring, I reboot 3 times.

however, it does not work now, laptop still canot be rebooted

Offline

#17 2016-01-11 13:24:30

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 4,101
Website

Re: [SOLVED]a stop job is running for login service

Do these commands work:

sync && reboot -f
sync && poweroff -f

http://freedesktop.org/wiki/Software/sy … wnproblems


"Il semble que la perfection soit atteinte non quand il n'y a plus rien à ajouter, mais quand il n'y a plus rien à retrancher." - Antoine de Saint Exupéry

How to report a problem

Offline

#18 2016-01-11 14:39:27

dviktor
Member
Registered: 2015-10-18
Posts: 52

Re: [SOLVED]a stop job is running for login service

If shutdown (whether it be to reboot or power-off) of your system gets stuck, first test if the kernel itself is able to reboot or power-off the machine forcedly using one of these commands

sync && reboot -f
sync && poweroff -f

If either one of the commands does not work, it is a kernel bug, not systemd.

But we are mentioned already that shutdown/reboot works fine when launched from tty2 or another tty and only fails when run somehow via desktop environment. So it's not a kernel bug...

PS: commands work but after boot I've met unclean disk partitions and fsck...

PPS: filed a bug

EDIT: the problem is solved with the 4.1.16-1-lts kernel

Last edited by dviktor (2016-02-02 08:49:05)

Offline

#19 2016-02-02 12:23:49

johanli
Member
Registered: 2016-01-10
Posts: 12

Re: [SOLVED]a stop job is running for login service

Thank you very much.

dviktor wrote:

If shutdown (whether it be to reboot or power-off) of your system gets stuck, first test if the kernel itself is able to reboot or power-off the machine forcedly using one of these commands

sync && reboot -f
sync && poweroff -f

If either one of the commands does not work, it is a kernel bug, not systemd.

But we are mentioned already that shutdown/reboot works fine when launched from tty2 or another tty and only fails when run somehow via desktop environment. So it's not a kernel bug...

PS: commands work but after boot I've met unclean disk partitions and fsck...

PPS: filed a bug

EDIT: the problem is solved with the 4.1.16-1-lts kernel

Offline

#20 2016-02-03 10:14:39

dviktor
Member
Registered: 2015-10-18
Posts: 52

Re: [SOLVED]a stop job is running for login service

New kernel 4.4.1-1 solves the issue!

Offline

#21 2016-02-03 16:07:33

kiotoze
Member
Registered: 2014-08-20
Posts: 3

Re: [SOLVED]a stop job is running for login service

dviktor wrote:

New kernel 4.4.1-1 solves the issue!

for me the problem still exists and I continue using linux-lts 4.1.17-1

Offline

#22 2016-02-29 13:20:28

iambig
Member
Registered: 2012-08-21
Posts: 25

Re: [SOLVED]a stop job is running for login service

I have this problem too, it's very annoing.


Carthago delenda est

Offline

#23 2016-02-29 13:25:03

x33a
Forum Moderator
Registered: 2009-08-15
Posts: 3,710
Website

Re: [SOLVED]a stop job is running for login service

Please stop bumping a solved thread. Open new ones if you want. Since the problem is solved for the OP, I am going to close this thread.

Offline

Board footer

Powered by FluxBB