You are not logged in.

#1 2016-02-03 22:13:49

devil_kc
Member
Registered: 2008-09-14
Posts: 91

[WORKAROUND] monitor issues after upgrade to 4.4

Hello,

After upgrade to 4.4 i'm seeing strange issues on my third monitor.
I have laptop(eDP1) with 2 additional monitors(HDMI1 and DP1) and after upgrade to 4.4 i'm seeing stupiid issued where DP1(vga) monitor is shut down every so often for a second.
Graphics card i use is some intel from intel cpu i5 5200U. Monitor has additional nvidia card which is not in use at all.
When screen goes off i get

kernel: [drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe C FIFO underrun

in journal

I added

# cat /etc/X11/xorg.conf.d/20-intel.conf
  Section "Device"
    Identifier  "Intel Graphics"
    Driver      "intel"
    Option      "AccelMethod"  "uxa"
    #Option      "AccelMethod"  "sna"
  EndSection

but no luck
there are no errors in Xorg.0.log

I tested and got same result in KDE and i3. i switched to i3 from kde yesterday and was super hyped about it. Then i upgraded kernel and issues started i though it was i3s fault but nope, same issues affects kde.

I can reproduce it by opening one or more windows on every screen and moving mouse over monitors. after minute or 2 it just breaks DP1 monitor.

Do you have any suggestions?
I'll revert to 4.3.3 for now

Last edited by devil_kc (2016-02-04 11:08:04)

Offline

#2 2016-02-03 22:17:37

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,428

Re: [WORKAROUND] monitor issues after upgrade to 4.4

Try the LTS kernel (linux-lts).

Offline

#3 2016-02-03 22:19:17

devil_kc
Member
Registered: 2008-09-14
Posts: 91

Re: [WORKAROUND] monitor issues after upgrade to 4.4

after downgrade to 4.3.3 i get

kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=7161 end=7162)
kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=8091 end=8092)
kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=7407 end=7408)
kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe B (start=7823 end=7824)
kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=8716 end=8717)

but screen is ok. i can live with this errors.
installing lts now

Offline

#4 2016-02-03 22:28:08

devil_kc
Member
Registered: 2008-09-14
Posts: 91

Re: [WORKAROUND] monitor issues after upgrade to 4.4

LTS has same error in journal as 4.3.3 but less frequent.

looks like LTS it is.

Anyone had/has similar issues?

Offline

#5 2016-02-07 02:33:08

johnnynyquist
Member
Registered: 2016-01-25
Posts: 22

Re: [WORKAROUND] monitor issues after upgrade to 4.4

I have this same issue on a Thinkpad T450s with an external monitor on the VGA port. I get monitor flickers every few minutes where the monitor will go black for a second before switching back on. At first I thought it was confined to the external monitor, but then I realized it was occurring to whatever monitor had focus, and the laptop screen just recovered much more quickly.

The problem happened on upgrade to 4.4.1-2 and I am still looking for a fix. I will investigate downgrading to linux-lts.

I also have a separate i915-related error in my boot journal:

Feb 06 18:23:23 ember kernel: [drm] Initialized i915 1.6.0 20151010 for 0000:00:02.0 on minor 0
Feb 06 18:23:23 ember kernel: [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
Feb 06 18:23:23 ember kernel: [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
Feb 06 18:23:23 ember kernel: [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
Feb 06 18:23:23 ember kernel: [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
Feb 06 18:23:23 ember kernel: [drm:gen8_irq_handler [i915]] *ERROR* The master control interrupt lied (SDE)!
... (repeated ~50x)

Searching on that turns up other issues that seem to be unrelated. Shocking that the i915 module, as long-established as it is, has so many issues.

Last edited by johnnynyquist (2016-02-07 02:36:59)

Offline

#6 2016-02-07 16:01:28

assliq
Member
Registered: 2016-02-07
Posts: 1

Re: [WORKAROUND] monitor issues after upgrade to 4.4

Yeah, I had to downgrade to 4.3.3 as well. Using integrated graphics on an i5 4570. Monitor went blank completely instead of intermittently shutting off.

Offline

#7 2016-02-08 06:42:04

sweisman
Member
Registered: 2008-05-20
Posts: 42

Re: [WORKAROUND] monitor issues after upgrade to 4.4

I am having similar problems.

I have a 3rd generation Core i7 notebook with a dual monitor setup.

Before the recent kernel update, with a VGA monitor plugged in (with or without a second HDMI monitor), the system would boot and output the console display to both the VGA and LCD. Default X startup was to display at full screen resolution and also output to VGA and LCD. Now, no matter what, it only outputs to LCD.

The xrandr command to go to dual monitor used to switch within a few seconds at most. Now, it FAILS the first time. All screens are blank. I then do a second xrandr to output only to external VGA, which succeeds.

I see this output from the previous command:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Serial number of failed request:  39
  Current serial number in output stream:  39

A third xrandr command to once again go to dual then works.

However, the transition takes MUCH longer.

And there are further problems. I have seen the HDMI screen occasionally blank (the VGA screen is unaffected) for many seconds, then just go back on. When the screens blank from lack of activity, the time to turn on is also much longer than the previous 1 or 2 seconds.

The HDMI screen has a great deal of "flicker" (it's not actual flicker, it's horizontal lines flashing) that just doesn't stop.

I had zero problems before. I have downgraded. But hopefully this will be fixed soon or there is some sort of boot param that can prevent this from happening in the future. This is not the first time I've had display problems that forced me to downgrade for a time.

Offline

#8 2016-02-08 14:59:29

liara
Member
Registered: 2013-04-10
Posts: 26

Re: [WORKAROUND] monitor issues after upgrade to 4.4

Similar issues here,  with external monitors attached. My logs are filled with this since kernel 4.4:

[drm:intel_set_pch_fifo_underrun_reporting [i915]] *ERROR* uncleared pch fifo underrun on pch transcoder A
[drm:intel_pch_fifo_underrun_irq_handler [i915]] *ERROR* PCH transcoder A FIFO underrun
[drm:intel_set_cpu_fifo_underrun_reporting [i915]] *ERROR* uncleared fifo underrun on pipe B
[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

Offline

#9 2016-02-25 10:30:45

miku84
Member
Registered: 2015-03-31
Posts: 45

Re: [WORKAROUND] monitor issues after upgrade to 4.4

As this is working with 4.3 but not with 4.4 I think the DRM may causes the problem.
https://bbs.archlinux.org/viewtopic.php?id=209143

Offline

#10 2016-02-25 11:02:00

sweisman
Member
Registered: 2008-05-20
Posts: 42

Re: [WORKAROUND] monitor issues after upgrade to 4.4

That won't help me since it seems Radeon-specific. However, in general it makes sense. I am hoping that the next kernel package will solve the problem.

Offline

#11 2016-03-10 17:19:31

SigmaDraconis
Member
Registered: 2015-08-17
Posts: 3

Re: [WORKAROUND] monitor issues after upgrade to 4.4

This happens to me with an Intel graphics card and a dual monitor, the external monitor keeps shutting down for a couple of 2 seconds when switching the mouse from one monitor to another or simply randomly while doing work on the external monitor.

When I try to replicate the error for the first time, after a reboot, I keep changing the mouse from one monitor to another very fast and I get this error only on that first time:

[drm:intel_cpu_fifo_underrun_irq_handler [i915]] *ERROR* CPU pipe B FIFO underrun

All subsequent monitor failures don't seem to fire this error.

Since I installed 4.4, it keeps doing this, it's the most annoying bug I've ever seen while using KDE and the dual monitor, even more than the QT bug that makes the  taskbar not staying on the laptop monitor whenever I switch on or off the external monitor sad

I guess I'll have to wait for 4.5 to see if this is fixed, some people seem to have their problem fixed with the recent 4.5 RC6 here: https://bugs.launchpad.net/ubuntu/+sour … ug/1488719

Also, my monitor is linked with a mDP->DP cable and the monitor is a Dell P2416D.

Last edited by SigmaDraconis (2016-03-10 17:25:46)

Offline

#12 2016-03-16 16:36:19

srglbnv
Member
Registered: 2016-03-16
Posts: 2

Re: [WORKAROUND] monitor issues after upgrade to 4.4

I have the same issue with Thinkpad T450s i7 5600u, intel HD graphics 5500, FHD screen and external VGA monitor, FHD too, linux-4.4.5-1. Monitor shuts down for 1-2 sec randomly when I watch youtube and cross screens border with mouse pointer. Sometimes it outputs "CPU pipe C FIFO underrun" in the journal.
Moreover, when I share my screen in skype inside VirtualBox windows guest, the shutdowns become more frequent and also sometimes I get terrible artefacts on the laptop's screen.
I tried using different workarounds from the wiki like using uxa, glamor, disabling acceleration, nothing works.
Fortunately found this thread and with the lts kernel problems seem to be gone.

Last edited by srglbnv (2016-03-16 16:38:01)

Offline

Board footer

Powered by FluxBB