You are not logged in.

#1 2016-05-21 16:25:40

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,973
Website

Cannot boot to NVMe SSD with grub-git/stuck on 'systemd 229' [SOLVED]

I partitioned a new NVMe SSD, rsync'ed over the data to the correct partitions, and installed grub-git from the AUR (recommendation from this thread) from a chroot as I should.  I can boot into the grub screen just fine and seemingly load the NVMe based Arch from there, but systemd fails to find the root partition:

start version 229
ERROR: device 'UUID='6374779b-7d53-4caa-b17e-c54c98195eaa not found. Skipping
Error Unable to find root device 'UUID=6472779b-7d53-4cca-b17e-c54c98195eaa'
You are dropped to a recover shell
Type exit to try and contine booting
sh: can't access tty: job control turned off

EDIT: The problem was not including the nvme module in /etc/mkinitcpio.conf ... upon doing so, everything worked as expected.
EDIT2: Multiple wiki pages updated.

https://wiki.archlinux.org/index.php?ti … did=435343
https://wiki.archlinux.org/index.php?ti … did=431294

Last edited by graysky (2016-05-21 19:17:06)


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB