You are not logged in.

#1 2006-05-21 01:46:35

syan
Member
Registered: 2006-05-20
Posts: 20

SOLVED Setting up a wireless connection with Madwifi drivers

Hi all,

I've installed the base Arch system using the 0.7.2 disc.  Before I install anything else I want to get my wireless connection setup, otherwise there's no point in continuing.

Hopefully you guys can help me out.

My card is a Netgear WG311T.  It uses the Atheros chipset, so I need to install the Madwifi drivers.  madwifi-ng 1497-1 is dependent on madwifi-ng-utils 1497-1 and sharutils 4.3.80-1.

This is what I've done so far:

I downloaded the three packages mentioned above.  I then installed them in this order:

pacman -A sharutils 4.3.80-1.pkg.tar.gz
pacman -A madwifi-ng-utils 1497-1.pkg.tar.gz
pacman -A madwifi-ng 1497.pkg.tar.gz

After this I ran depmod and modprobe:

depmod -a
modprobe ath_pci

I had to run depmod, otherwise modprobe couldn't see the ath_pci module.

After this I ran wlanconfig:

wlanconfig ath0 create wlandev wifo0 wlanmode sta

This returned this message:

         

wlanconfig: ioctl: No such device

From reading other posts, I found that this is not a serious problem.  In fact, according to the ArchWiki Wireless Setup page, if you are installing madwifi drivers created after January 23, 2006 you don't even have to give that command.  So I continued on with:

iwconfig ath0 essid skynet
ifconfig ath0 up
dhcpcd ath0

However, the dhcpd command doesn't work.  It doesn't give me an IP address and it seems drop the interface on me as well.

In this post http://bbs.archlinux.org/viewtopic.php? … ht=madwifi, which has been very helpful to me, Fractured Singleton experienced a simlar situation, but was able to get an IP by opening the KWifiManager, entering his ESSID and selecting the "Activate" button.  I don't want to use KDE though.  Anyone have any ideas on how to get an IP from my router?  I would be interested in knowing why KWifiManager works and dhcpcd doesn't.

In an attempt to get somewhere despite the lack of DHCP, I set my IP Address manually with:

ifconfig ath0 192.168.1.47 netmask 255.255.255.0 up

And then added these lines to /etc/resolv.conf:

nameserver 151.202.0.84
nameserver 151.203.0.84

I have gathered together the results from running ifconfig and iwconfig.  They are posted below.  I really hope someone will tell me just what I have accomplished so far, like whether I am really connected to my router and what I need to do to achieve a working connection.

Thanks in advance.

iwconfig:

lo        no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"skynet"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:12:0E:10:31:43   
          Bit Rate:36 Mb/s   Tx-Power:15 dBm   Sensitivity=0/3  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=12/94  Signal level=-83 dBm  Noise level=-95 dBm
          Rx invalid nwid:285  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

ifconfig

ath0      Link encap:Ethernet  HWaddr 00:09:5B:E7:1E:20
          inet addr:192.168.1.47  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:45 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:5048 (4.9 Kb)  TX bytes:318 (318.0 b)

eth0      Link encap:UNSPEC  HWaddr 00-02-3C-00-21-01-05-F7-00-00-00-00-00-00-00-00
          inet addr:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:496 (496.0 b)  TX bytes:496 (496.0 b)

wifi0     Link encap:UNSPEC  HWaddr 00-09-5B-E7-1E-20-00-00-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5782 errors:0 dropped:0 overruns:0 frame:409
          TX packets:109 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:447632 (437.1 Kb)  TX bytes:5395 (5.2 Kb)
          Interrupt:10 Memory:e10e0000-e10f0000

Offline

#2 2006-05-21 02:44:13

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: SOLVED Setting up a wireless connection with Madwifi drivers

have you tried looking here
http://wiki.archlinux.org/index.php/Wireless_Setup

i believe all you need will be there
on my card the modules are built into kernel (airo & airo_cs)
then i use the example for /etc/rc.conf

ath0="ath0 192.168.100.1 netmask 255.255.255.0 broadcast 192.168.100.255" | ath0="dhcp"
wlan_ath0="ath0 essid <your_essid> key <your_wep_key>"
WLAN_INTERFACES=(ath0)

although my interface is eth1

Offline

#3 2006-05-21 20:37:10

syan
Member
Registered: 2006-05-20
Posts: 20

Re: SOLVED Setting up a wireless connection with Madwifi drivers

Well, I got it.

I took a look at the information rayjgu3 gave me.  I tried most of the things it said, and I found that putting the following code into rc.conf did not work for me.

ath0="ath0 192.168.1.47 netmask 255.255.255.0 broadcast 192.168.1.255"
wlan_ath0="ath0 essid skynet"
WLAN_INTERFACES=(ath0)

Calling ifconfig and iwconfig showed that an IP was assigned, but there was no network traffic.  When I typed the following commands:

ifconfig ath0 up
iwconfig ath0 essid skynet

ifconfig and iwconfig showed network traffic on some of the connections.  I was able to ping my router, so my wireless connection was established.  I didn't feel like configuring ath0 manually every time I rebooted, so I opened /etc/rc.local and entered:

ifconfig ath0 up
iwconfig ath0 essid skynet

I didn't use

dhcpcd ath0

because, as I said in my earlier post, it does not work for me.  It seems that it doesn't work for anyone using madwifi?

Anyway, this caused no problems for me.  I rebooted and I could still ping my router.

For my ISP I have to give an Account name and a Password, so I ran pppoe-setup.  This is pretty straight-foward, I gave it my account name, password and DNS IP Addresses.  If you configure your network the way I did it you need to enter ath0 when it asks for your interface.  I didn't use a firewall and I used the default of no when it asked me if I wanted the link to come up on demand.

After I finished pppoe-setup I ran pppoe-start and was able to connect to the Internet.

So if you have a similar setup to mine and you follow my first post and this one, you should probably have some success.

Thanks for the help rayjgu3.

I have to say - perhaps the Wireless Setup page in ArchWiki needs to be updated a little?  Because somethings didn't work at all.  I think it'd be good if we could figure out why dhcpcd didn't work, for example.  And some of the methods that were supposed to work didn't work at all.  Which wouldn't be such a big deal except that it was presented in such a way that it looked like "you can do it this way, or this other way, it's up to you, both will work."  As if they were the same thing, but they must not be or they would both have worked.[/b]

Offline

Board footer

Powered by FluxBB