You are not logged in.

#1 2016-08-30 17:16:15

Registered: 2012-01-29
Posts: 45

Slow connection with RTL8111H

I'm struggling to get my network card working properly.

It's an MSI B150 Pro VDH board, with the RTL8111H network card; lscpi -v:

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7982
	Flags: bus master, fast devsel, latency 0, IRQ 315
	I/O ports at e000 [size=256]
	Memory at df004000 (64-bit, non-prefetchable) [size=4K]
	Memory at df000000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 01-00-00-00-68-4c-e0-00
	Capabilities: [170] Latency Tolerance Reporting
	Capabilities: [178] L1 PM Substates
	Kernel driver in use: r8168
	Kernel modules: r8169, r8168

As you can see, I'm already using the r8168 module from the repos. This enabled me to use dhcpd for a permanent static ip; with r8169 it would only connect manually.

Now, the network connection is still slow, and I have some package loss (around 8%).

I've tried all sorts of suggestion that I've found on the wiki and forums, including disabling ipv6 and adding


as a kernel parameter, but no dice.

uname -a

Linux psirus-desktop 4.7.2-1-ARCH #1 SMP PREEMPT Sat Aug 20 23:02:56 CEST 2016 x86_64 GNU/Linux

ip addr show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 4c:cc:6a:45:eb:ec brd ff:ff:ff:ff:ff:ff
    inet brd scope global enp1s0
       valid_lft forever preferred_lft forever

The router is a fairly ancient FritzBox 3050. But the laptop connected via wireless to it is fine, so...


Board footer

Powered by FluxBB