You are not logged in.

#1 2016-08-31 05:57:43

redstar
Member
Registered: 2013-06-20
Posts: 28

[solved] wpa_supplicant unable to read interface

On a fresh Arch install after a couple years away. I was able to connect to the internet and use wifi during the live disc install, but once I booted into the newly installed system, wpa_supplicant hasn't been working properly. I can't post full logs since I'm just copying them down onto another system, but I tried to type up the things I found relevant.

Some basic info:

Running on HP Envy 750-167c

uname -a
Linux qtip 4.7.2-1-ARCH #1 SMP PREEMPT Sat Aug 20 23:02:56 CEST 2016 x86_64 GNU/Linux
lspci -k
01:00.0 Network controller: Intel Corporation Wireless 3165 (rev 81)
Subsystem: Intel Corporation Dual Band Wireless AC 3165
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi
Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
Subsystem: Hewlett-Packard Company Device 2b47
Kerne driver in use: r8169
Kernel modules: r8169

The commands and a few selected errors:

ip link set wlp1s0 up
ip link
3: wlp1s0: <NO CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN mode DORMANT group default qlen 1000

wpa_supplicant -B -c /etc/wpa_supplicant/pluto.conf -i wlp1s0 -D nl80211,wext -d
Could not read interface p2p-dev-wlp1s0 flags: no such device 
p2p-dev-wlp1s0: Failed to Initialize driver interface
P2P: Failed to add P2P device interface
P2P Failed to enable P2P Device Interface

There must be some difference between the packages on the barebones fresh install versus the live disc. I'm confused because the wireless interface is functioning and it's up, lspci and ip link show it, but wpa_supplicant can't use it for some reason.

Any help is appreciated. I can always put the live disc back in to install packages if that is needed. Thanks!

Last edited by redstar (2016-08-31 20:22:15)

Offline

#2 2016-08-31 14:49:34

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,712

Re: [solved] wpa_supplicant unable to read interface

Could you please post your /etc/wpa_supplicant/pluto.conf file?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Online

#3 2016-08-31 17:42:54

redstar
Member
Registered: 2013-06-20
Posts: 28

Re: [solved] wpa_supplicant unable to read interface

/etc/wpa_supplicant/pluto.conf:

network={
        ssid="Pluto"
        #psk="$password"
        psk=longalphanumericstring
}

I've also tried connecting using the following to see if it's my config file but got the same errors.

wpa_supplicant  -D nl80211,wext -i wlp1s0 -c <(wpa_passphrase "Pluto" "$password") -B

Offline

#4 2016-08-31 17:55:23

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,042
Website

Re: [solved] wpa_supplicant unable to read interface

Get rid of the -D flag and it's parameters.  That is almost never needed and frequently causes problems.

EDIT: and you are running wpa_supplicant as root, right?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#5 2016-08-31 18:05:44

redstar
Member
Registered: 2013-06-20
Posts: 28

Re: [solved] wpa_supplicant unable to read interface

Yeah, running as root. Still haven't set up any user accounts. Removing the -D flag still puts up the same errors. Also, when I run the command a second time, I get an additional odd line of error:

nl80211: Could not set interface 'p2p-dev-wlp1s0' UP

ip link shows the interface as UP.

Edit:

So some more interesting logs.

wpa_supplicant -i wlp1s0 -c <(wpa_passphrase "Pluto" "$password")
Successfully initialized wpa_supplicant
Could not read interface p2p-dev-wlp1s0: No such device
p2p-dev-wlp1s0: Failed to initialize driver interface
P2P: Failed to enable P2P device interface
wlp1s0: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1
wlp1s0: SME: Trying to authenticate with $bssid (SSID='Pluto' freq=2437 Mhz)
wlp1s0: SME: Authentication request to the driver failed
wlp1s0: No network configuration found for the current AP
wlp1s0: CTRL-EVENT-DISCONNECTED bssid:$bssid reason=3 locally_generated=1
wlp1s0: SME: Trying to authenticate with $bssid
wlp1s0: Trying to associate with $bssid
wlp1s0: Associated with $bssid
wlp1s0: CTRL-EVENT-DISCONNECTED bssid=$bssid reason=3 locally_generated=1
wlp1s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Pluto" auth_failures=2 duration=23 reason=CONN_FAILED
nl80211: deinit ifname=wlp1s0 disabled_11b_rates=0
wlp1s0: CTRL-EVENT-TERMINATING

Last edited by redstar (2016-08-31 18:16:09)

Offline

#6 2016-08-31 18:46:54

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,042
Website

Re: [solved] wpa_supplicant unable to read interface

The p2p errors are normal.  I don't really know what they mean, but I see them all the time and wpa_supplicant works fine for me.

That log shows a successful connection - then a disconnect.  Did you Ctrl-C it?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2016-08-31 20:11:26

redstar
Member
Registered: 2013-06-20
Posts: 28

Re: [solved] wpa_supplicant unable to read interface

I did kill wpa_supplicant using Ctrl-C in that last example but only because it wasn't connecting after multiple attempts and I hadn't used -B to background it.

Offline

#8 2016-08-31 20:21:29

redstar
Member
Registered: 2013-06-20
Posts: 28

Re: [solved] wpa_supplicant unable to read interface

Found the solution. Just booted up my system and ran the following.

wpa_supplicant -i wlp1s0 -c /etc/wpa_supplicant/pluto.conf -B
dhcpcd wlp1s0

Tested my internet with a quick ping and everything is working fine. I still got the could not read interface error but it works nonetheless. I guess by not running ip link set wlp1s0 up first and instead just entering the wpa_supplicant command it worked. Not sure why the two commands would conflict like that, but glad it works. Thanks for helping, y'all.

Offline

#9 2017-10-22 15:00:03

jones
Member
Registered: 2013-03-14
Posts: 142

Re: [solved] wpa_supplicant unable to read interface

This was the exact same problem I had. For whatever reason I did not experience this issue roughly 3 months when I had set up my laptop the last time. Was totally out of my depth, but thankfully this random thing helped.
Exactly the same procedure helped me (with setting the wpa_supplicant config file beforehand, of course).

redstar wrote:

Found the solution. Just booted up my system and ran the following.

wpa_supplicant -i wlp1s0 -c /etc/wpa_supplicant/pluto.conf -B
dhcpcd wlp1s0

Tested my internet with a quick ping and everything is working fine. I still got the could not read interface error but it works nonetheless. I guess by not running ip link set wlp1s0 up first and instead just entering the wpa_supplicant command it worked. Not sure why the two commands would conflict like that, but glad it works. Thanks for helping, y'all.

Offline

#10 2017-10-23 20:16:07

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 8,977
Website

Re: [solved] wpa_supplicant unable to read interface


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB