You are not logged in.

#1 2006-05-30 15:14:31

McQUack
Member
Registered: 2006-03-10
Posts: 10

Problems getting up Wireless connection on bootup

Hi,

I managed to install arch on my old laptop (celeron 500 128MB) and the most things work like they should. Only my wireless network doesn't start at boottime.

i have a Netgaer WG511T PCMCIA card with Atheros chipset, so i installed the madwifi drivers.

when I start manually with

ifconfig ath0 up
Iwconfig ath0 essid MYESSID
iwconfig ath0 key MYKEY
dhcpcd ath

everythig works fine, but when i try to do it on bootup networksetup fails.

so here are my files:
/etc/rc.conf

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime"
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/unimaps
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="de_DE.utf8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Berlin"
KEYMAP="de-latin1-nodeadkeys"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

#
# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# Scan hardware and load required modules at bootup
MOD_AUTOLOAD="yes"
# Module Blacklist - modules in this list will never be loaded by udev
MOD_BLACKLIST=()
#
# Modules to load at boot-up (in this order)
#   - prefix a module with a ! to blacklist it
#
MODULES=(ath_pci snd-intel8x0)
# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

#
# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
HOSTNAME="myhost"
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   - prefix an entry in INTERFACES with a ! to disable it
#   - no hyphens in your interface names - Bash doesn't like it
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
ath0="dhcp"
INTERFACES=(lo !eth0 ath0)
#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 192.168.0.1"
ROUTES=(!gateway)
#
# Enable these network profiles at boot-up.  These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
#   - set to 'menu' to present a menu during boot-up (dialog package required)
#   - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network-profiles
#
#NET_PROFILES=(WLAN-home-WEP)
#
# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
#   - prefix a daemon with a ! to disable it
#   - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng !hotplug hwd !pcmcia netfs crond network)


# End of file

/etc/conf.d/wireless

#
# Settings for wireless cards
#
# For each wireless interface declared in INTERFACES (in rc.conf), declare
# a wlan_${IF} variable that contains the arguments to be passed to
# iwconfig(8).  Then list the original interface name in the
# WLAN_INTERFACES array.
#

#wlan_eth0="eth0 mode managed essid default"
#WLAN_INTERFACES=(eth0)
wlan_ath0="ath0 mode managed essid MYESSID key MYKEY"
WLAN_INTERFACE=(ath0)

Where is the mistake?

what do i have to change?

thanks for your support

McQuack

Offline

#2 2006-05-30 21:04:34

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Problems getting up Wireless connection on bootup

on my setup which is not ath0 i have eth0 but heres what i would put
in /etc/rc.conf

HOSTNAME="myhost"
lo="lo 127.0.0.1"
ath0="dhcp"
INTERFACES=(lo !eth0 ath0)
wlan_ath0="ath0 mode managed essid MYESSID key MYKEY"

its what works for me i only connect at home almost always that is unless
im on vacation which i just go in manually do scan  then set  mode stuff

Offline

#3 2006-05-31 16:35:01

McQUack
Member
Registered: 2006-03-10
Posts: 10

Re: Problems getting up Wireless connection on bootup

tried this, but still doesn't Work.

don't have any ideas what I could try.  :?:

So does anyone have some advice for my how to set it up.

Thanks

McQuack

Offline

#4 2006-05-31 18:12:18

kingboxer
Member
Registered: 2006-05-19
Posts: 61

Re: Problems getting up Wireless connection on bootup

Is your gateway address 192.168.0.1???
gateway="default gw 192.168.0.1"
For exemple, mine is 192.168.1.1

Offline

#5 2006-05-31 19:32:20

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,432
Website

Re: Problems getting up Wireless connection on bootup

Erm, why not take a look at /etc/network-profiles - you might find that method less syntax error prone.  /etc/conf.d/wireless is hugely deprecated AFAIK...

Here is one of my profiles:

#
# Network Profile
#

DESCRIPTION="Bean Wifi"

# Network Settings
INTERFACE=wlan0
HOSTNAME=heaton

# Interface Settings (use IFOPTS="dhcp" for DHCP)
IFOPTS="dhcp"
#GATEWAY=192.168.0.1

# DNS Settings (optional)
#DOMAIN=localdomain
#DNS1=192.168.0.1
#DNS2=

# Wireless Settings (optional)
ESSID=anessid
CHANNEL=6
#KEY=awepkey
IWOPTS="mode managed essid $ESSID channel $CHANNEL"

#WIFI_INTERFACE=wlan0      # use this if you have a special wireless interface
                           # that is linked to the real $INTERFACE

I also use a udev rule to control what my interface is called:

[~]: cat /etc/udev/rules.d/Z0-custom.rules 
# network interface rules
KERNEL="eth*", SYSFS{address}="00:AA:b4:00:00:00", NAME="wlan0"

You can read more about that on the wiki: udev

Offline

#6 2006-05-31 19:41:56

kingboxer
Member
Registered: 2006-05-19
Posts: 61

Re: Problems getting up Wireless connection on bootup

How is it possible to use network-profiles when you use con.d/wireless???

Offline

#7 2006-05-31 20:13:18

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: Problems getting up Wireless connection on bootup

it just occured to me
i disabled
MOD_AUTOLOAD="yes"
in /etc/rc.conf
then added hwd in the
DAEMONS=(syslog-ng  hwd netfs crond network)
& rereading yours you have both i maybe wrong in this
for you but on mine hwd alone works , MOD_AUTOLOAD doesnt
just a thought

Offline

#8 2006-05-31 20:43:44

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,432
Website

Re: Problems getting up Wireless connection on bootup

kingboxer wrote:

How is it possible to use network-profiles when you use con.d/wireless???

Why would you use conf.d/wireless?  It's deprecated by the network profiles.  The relevant bits of my rc.conf are:

lo="lo 127.0.0.1"
INTERFACES=(lo)

gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

NET_PROFILES=(name_of_profile)

Simple.

Offline

#9 2006-05-31 20:51:16

kingboxer
Member
Registered: 2006-05-19
Posts: 61

Re: Problems getting up Wireless connection on bootup

I will try this, I keep you in touch

Offline

#10 2006-05-31 20:55:37

dtw
Forum Fellow
From: UK
Registered: 2004-08-03
Posts: 4,432
Website

Re: Problems getting up Wireless connection on bootup

OK, dude smile I have seen your other thread - you can post there about it.

Offline

Board footer

Powered by FluxBB