You are not logged in.

#1 2017-05-24 17:35:52

keibak
Member
Registered: 2017-05-24
Posts: 21

[SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Hi,

I just upgraded to kernel 4.11.2 from core/linux (4.11.2-1). But now Arch won't boot anymore. It's stuck at loading inital ramdisk. The fallback ramdisk also show the same behaviour.

Any hints how to solve this issue? Unfortunatelly I don't have any log messages which would error searching.

Btw, I managed to get the computer booting again by installing the lts-kernel.

Boot from https://www.archlinux.org/download:

mount /dev/sda1
arch-chroot /mnt
pacman -Sy linux-lts nvidia-lts
grub-mkconfig -o /boot/grub/grub.cfg

Update:
The issue is fixed with core/linux 4.11.5 for bios booting and will be fixed with core/linux 4.11.6 for EFI systems. See FS#54171 for further information.

Last edited by keibak (2017-06-17 12:44:57)

Offline

#2 2017-05-24 17:47:05

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Welcome to the forums.

Please post your full pacman log.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#3 2017-05-24 18:00:02

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

The kernel installs without any error. Nevertheless it won't boot.

[2017-05-24 18:20] [ALPM] reinstalled linux (4.11.2-1)
[2017-05-24 18:20] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2017-05-24 18:20] [ALPM] transaction completed
[2017-05-24 18:20] [ALPM] running '90-linux.hook'...
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Starting build: 4.11.2-1-ARCH
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Starting build: 4.11.2-1-ARCH
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2017-05-24 18:20] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2017-05-24 18:20] [ALPM-SCRIPTLET] ==> Image generation successful
[2017-05-24 18:20] [ALPM] running 'systemd-update.hook'..

Offline

#4 2017-05-24 18:17:18

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Can you also post your grub.cfg and your fstab.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#5 2017-05-24 18:47:22

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

The fstab is pretty short:

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# UUID=64f19c9a-2549-4ced-ad69-8f95d10c543d
/dev/sda1               /               ext4            rw,relatime,data=ordered,noatime                0 1

In grub, the same device is used for both linux and linux-lts:

        menuentry 'Arch Linux, mit Linux linux-lts' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-lts-advanced-64f19c9a-2549-4ced-ad69-8f95d10c543d' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_msdos
                insmod ext2
                set root='hd0,msdos1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  64f19c9a-2549-4ced-ad69-8f95d10c543d
                else
                  search --no-floppy --fs-uuid --set=root 64f19c9a-2549-4ced-ad69-8f95d10c543d
                fi
                echo    'Linux linux-lts wird geladen …'
                linux   /boot/vmlinuz-linux-lts root=UUID=64f19c9a-2549-4ced-ad69-8f95d10c543d rw  
                echo    'Initiale Ramdisk wird geladen …'
                initrd  /boot/initramfs-linux-lts.img
        }
        menuentry 'Arch Linux, mit Linux linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-64f19c9a-2549-4ced-ad69-8f95d10c543d' {
                load_video
                set gfxpayload=keep
                insmod gzio
                insmod part_msdos
                insmod ext2
                set root='hd0,msdos1'
                if [ x$feature_platform_search_hint = xy ]; then
                  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1  64f19c9a-2549-4ced-ad69-8f95d10c543d
                else
                  search --no-floppy --fs-uuid --set=root 64f19c9a-2549-4ced-ad69-8f95d10c543d
                fi
                echo    'Linux linux wird geladen …'
                linux   /boot/vmlinuz-linux root=UUID=64f19c9a-2549-4ced-ad69-8f95d10c543d rw  
                echo    'Initiale Ramdisk wird geladen …'
                initrd  /boot/initramfs-linux.img
        }

To me this looks like a problem with the linux package rather than a configuration issue.

I can't pin anything down as the computer is stuck at 'Loading initial ramdisk'.

Offline

#6 2017-05-24 18:53:30

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Please see https://bbs.archlinux.org/viewtopic.php … 6#p1713046 if it is the same issue then also appears to be the issue here https://bbs.archlinux.org/viewtopic.php?id=226520.

Offline

#7 2017-05-24 19:06:31

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

loqs wrote:

Please see https://bbs.archlinux.org/viewtopic.php … 6#p1713046 if it is the same issue then also appears to be the issue here https://bbs.archlinux.org/viewtopic.php?id=226520.

The last thread gave some hints: Setting parameter acpi=off will boot kernel 4.11.2.

Offline

#8 2017-05-24 19:15:41

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Can you produce the same Oops as Maniaxx?

Offline

#9 2017-05-24 19:37:57

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

No, I don't get any Oops. The kernel boots just fine.

Offline

#10 2017-05-24 19:45:43

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

loqs wrote:

For the second possibility add the earlyprintk=vga for bios booting systems or earlyprintk=efi for efi booting systems kernel parameter ( see https://www.kernel.org/doc/Documentatio … meters.txt for more details )

So I meant do not use the acpi=off parameter use earlyprintk=efi as your system appears to be efi booting and see if an Oops is displayed that matches the screenshots in https://bbs.archlinux.org/viewtopic.php … 7#p1713237

Offline

#11 2017-05-24 19:48:39

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

The only differences in dmesg I can see between 4.9.29 and 4.11.2 are the missing ACPI entries:

Linux version 4.9.29-1-lts (builduser@andyrtr) (gcc version 7.1.1 20170516 (GCC) ) #1 SMP Sat May 20 17:35:48 CEST 2017
Command line: BOOT_IMAGE=/boot/vmlinuz-linux-lts root=UUID=64f19c9a-2549-4ced-ad69-8f95d10c543d rw
(...)
RAMDISK: [mem 0x3748c000-0x37a3dfff]
ACPI: Early table checksum verification disabled
ACPI: RSDP 0x00000000000F0450 000024 (v02 ALASKA)
ACPI: XSDT 0x00000000CA27F078 000074 (v01 ALASKA A M I    01072009 AMI  00010013)
ACPI: FACP 0x00000000CA2895A8 0000F4 (v04 ALASKA A M I    01072009 AMI  00010013)
ACPI: DSDT 0x00000000CA27F188 00A41E (v02 ALASKA A M I    00000014 INTL 20051117)
ACPI: FACS 0x00000000CA298F80 000040
ACPI: APIC 0x00000000CA2896A0 000092 (v03 ALASKA A M I    01072009 AMI  00010013)
ACPI: ASF! 0x00000000CA289738 0000A5 (v32 INTEL   HCG     00000001 TFSM 000F4240)
ACPI: MCFG 0x00000000CA2897E0 00003C (v01 ALASKA A M I    01072009 MSFT 00000097)
ACPI: AAFT 0x00000000CA289820 0000C2 (v01 ALASKA OEMAAFT  01072009 MSFT 00000097)
ACPI: HPET 0x00000000CA2898E8 000038 (v01 ALASKA A M I    01072009 AMI. 00000005)
ACPI: SSDT 0x00000000CA289920 00036D (v01 SataRe SataTabl 00001000 INTL 20091112)
ACPI: SSDT 0x00000000CA289C90 0009AA (v01 PmRef  Cpu0Ist  00003000 INTL 20051117)
ACPI: SSDT 0x00000000CA28A640 000A92 (v01 PmRef  CpuPm    00003000 INTL 20051117)
ACPI: BGRT 0x00000000CA28B0D8 00003C (v00 ALASKA A M I    01072009 AMI  00010013)
ACPI: Local APIC address 0xfee00000
No NUMA configuration found
Linux version 4.11.2-1-ARCH (builduser@tobias) (gcc version 7.1.1 20170516 (GCC) ) #1 SMP PREEMPT Mon May 22 06:53:49 CEST 2017
Command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=64f19c9a-2549-4ced-ad69-8f95d10c543d rw acpi=off
(...)
RAMDISK: [mem 0x37486000-0x37a3afff]
No NUMA configuration found

Btw, CPU in this machine is a faithful i7-2600K.

Offline

#12 2017-05-24 19:55:02

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

loqs wrote:
loqs wrote:

For the second possibility add the earlyprintk=vga for bios booting systems or earlyprintk=efi for efi booting systems kernel parameter ( see https://www.kernel.org/doc/Documentatio … meters.txt for more details )

So I meant do not use the acpi=off parameter use earlyprintk=efi as your system appears to be efi booting and see if an Oops is displayed that matches the screenshots in https://bbs.archlinux.org/viewtopic.php … 7#p1713237

I don't boot EFI. So setting earlyprintk=efi has no effect for me.
Nevertheless I tried it and got stuck at Loading initial ramdisk. No Ooops was recorded.

earlyprintk=vga also has no effect. There the only message on screen is Loading initial ramdisk.

Last edited by keibak (2017-05-24 19:59:50)

Offline

#13 2017-05-24 20:10:14

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Try combining loglevel=7 with earlyprintk=vga it looks like the quiet parameter is not present but if it is please remove it as well.
If that fails you will probably have to bisect the kernel to find the bad commit.  So possibly not the same issue as Maniaxx.

Offline

#14 2017-05-24 20:18:49

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

loqs wrote:

Try combining loglevel=7 with earlyprintk=vga it looks like the quiet parameter is not present but if it is please remove it as well.
If that fails you will probably have to bisect the kernel to find the bad commit.  So possibly not the same issue as Maniaxx.

Booting with above parameter doesn't give me more information. The screen only shows 'Loading initial ramdisk'. The quiet parameter also isn't set.

Bisecting extends my abilities. That's not really doable for me.

For now what really matters is that sucessful booting can be done with parameter acpi=off

Offline

#15 2017-05-25 06:51:19

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

I managed to get some output using vga=1 earlyprintk=vga:

cameringo_20170525_08tksef.png

Seems different to Maniaxx's one?

Offline

#16 2017-05-25 10:51:17

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Yes seems different unfortunately https://abload.de/img/cameringo_20170525_08tksef.png contains less information than Maniaxx due to more lines wrapping.

Offline

#17 2017-05-27 18:59:44

erickwill
Member
Registered: 2013-11-05
Posts: 119

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

keibak wrote:
loqs wrote:

Try combining loglevel=7 with earlyprintk=vga it looks like the quiet parameter is not present but if it is please remove it as well.
If that fails you will probably have to bisect the kernel to find the bad commit.  So possibly not the same issue as Maniaxx.

Booting with above parameter doesn't give me more information. The screen only shows 'Loading initial ramdisk'. The quiet parameter also isn't set.

Bisecting extends my abilities. That's not really doable for me.

For now what really matters is that sucessful booting can be done with parameter acpi=off


I'm also with the same problem.. are you booting with parameter acpi=off using linux-lts or the current one?
Also.. does this bug was already reported?
Thanks

Last edited by erickwill (2017-05-27 19:00:19)

Offline

#18 2017-05-27 20:28:41

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

@erickwill what kernels have you tried?  Are you booting using efi or bios have you tried the kernel parameter acpi=off or earlyprintk=vga for bios booting systems or earlyprintk=efi to see if an Oops is displayed.
It is unclear how many bugs there actually are in this thread and the ones linked from it so it is difficult to say if any or all the the relevant upstream parties are aware of the issue reporting it to arch will not achieve a fix for an upstream issue.
Edit:
Spelling

Last edited by loqs (2017-05-27 20:29:01)

Offline

#19 2017-05-28 08:56:03

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

@erickwill: I'm booting linux (4.11.2) with acpi=off. linux-lts (4.9.29) starts up fine without the option.

In the bug tracker you can find FS#54171 - [Linux] freeze boot after "loading initial memory image" with 4.11.2. The issue is the same, but the whole thing is missing information like oopses and debug output.  loqs is right, for further processing, more details are necessary.

Offline

#20 2017-05-28 09:30:17

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

https://bugzilla.kernel.org/show_bug.cgi?id=195633#c2 This is for the efi bug with similar symptoms appears upstream is investigating it as an efi issue so will not help bios booting systems such as keibak uses.
Edit:
This might be releated to the issue on bios booting systems but needs someone to test https://lkml.org/lkml/2017/5/28/61

Last edited by loqs (2017-05-29 22:40:13)

Offline

#21 2017-05-30 15:00:04

hodasemi
Member
Registered: 2016-03-04
Posts: 14

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

I tested this fix on my bios system and it just worked!

Offline

#22 2017-05-30 15:01:58

keibak
Member
Registered: 2017-05-24
Posts: 21

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

I have to report, that the issue persists with linux 4.11.3-1-ARCH

hodasemi wrote:

I tested this fix on my bios system and it just worked!

That's great to hear!

Offline

#23 2017-05-30 15:35:13

erickwill
Member
Registered: 2013-11-05
Posts: 119

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

keibak wrote:

I have to report, that the issue persists with linux 4.11.3-1-ARCH

hodasemi wrote:

I tested this fix on my bios system and it just worked!

That's great to hear!

Yep, I can confirm that this bug persists on latest kernel.

Offline

#24 2017-05-30 16:25:32

loqs
Member
Registered: 2014-03-06
Posts: 7,665

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

Patch from post #20 rebased against 4.11.3 obviously needs an affected user to test.

diff --git a/arch/x86/platform/efi/efi-bgrt.c b/arch/x86/platform/efi/efi-bgrt.c
index 04ca8764f0c0..8bf27323f7a3 100644
--- a/arch/x86/platform/efi/efi-bgrt.c
+++ b/arch/x86/platform/efi/efi-bgrt.c
@@ -36,6 +36,9 @@ void __init efi_bgrt_init(struct acpi_table_header *table)
 	if (acpi_disabled)
 		return;
 
+	if (!efi_enabled(EFI_BOOT))
+		return;
+
 	if (table->length < sizeof(bgrt_tab)) {
 		pr_notice("Ignoring BGRT: invalid length %u (expected %zu)\n",
 		       table->length, sizeof(bgrt_tab));
keibak wrote:

I have to report, that the issue persists with linux 4.11.3-1-ARCH

Unless upstream is aware of the issue would you not expect that situation to continue?

Offline

#25 2017-05-30 17:03:36

erickwill
Member
Registered: 2013-11-05
Posts: 119

Re: [SOLVED] [Kernel 4.11.2] Stuck at loading inital ramdisk

loqs wrote:

Patch from post #20 rebased against 4.11.3 obviously needs an affected user to test.

diff --git a/arch/x86/platform/efi/efi-bgrt.c b/arch/x86/platform/efi/efi-bgrt.c
index 04ca8764f0c0..8bf27323f7a3 100644
--- a/arch/x86/platform/efi/efi-bgrt.c
+++ b/arch/x86/platform/efi/efi-bgrt.c
@@ -36,6 +36,9 @@ void __init efi_bgrt_init(struct acpi_table_header *table)
 	if (acpi_disabled)
 		return;
 
+	if (!efi_enabled(EFI_BOOT))
+		return;
+
 	if (table->length < sizeof(bgrt_tab)) {
 		pr_notice("Ignoring BGRT: invalid length %u (expected %zu)\n",
 		       table->length, sizeof(bgrt_tab));
keibak wrote:

I have to report, that the issue persists with linux 4.11.3-1-ARCH

Unless upstream is aware of the issue would you not expect that situation to continue?

Just to avoid duplicity, are you aware of a report, regarding this bug, for the subjected kernel? Otherwise, we could issue a bug report.

Last edited by erickwill (2017-05-30 17:03:57)

Offline

Board footer

Powered by FluxBB