You are not logged in.

#1 2017-05-24 13:46:23

jones
Member
Registered: 2013-03-14
Posts: 137

[SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Typing this up on my laptop. I am basically totally out of my depth on this one.
After months of working flawlessly, Arch won't boot up anymore as of today. I have no clue what happened.
When I select the AL entry in the systemd-menu, the screen basically goes black except for these blue lines at the top and bottom (which I'm somewhat sure are from the mainboard's UEFI menu itself). And... that is pretty much it.

Info on my setup:

  • Dual-boot system consists of W10 and AL

  • 64 bit -> I boot in UEFI mode

  • systemd-boot is the boot loader and the AL entry pretty much looks like this except for the PARTUUID obviously, and my entry has that intel microcode line in there

  • I did not start W10 yesterday or today, nor did I change a thing yesterday evening, it shut down perfectly from what I remember

Fortunately I have a Xubuntu thumb drive which I used to check out the loader entries and UUIDs/PARTUUIDs of the partitions, maybe something went wrong somehow? Nope, everything is still as it was.
So I noticed the Windows partition cannot be mounted in rw mode, it can only be mounted in ro-mode. So I did. It seems fine.
Even the arch.conf entry I created a couple of months ago is fine.
Started up and shut down Windows 10 for 2 times. It went fine. Checked these hibernation settings twice, hibernation is still off.

What now? :-(


edit 2017-05-25:

SOLUTION from post #16

Installed the lts-kernel and its headers.
Did this while (arch-)chrooted into the system:

pacman -S linux-lts linux-lts-headers
nano /boot/loader/entries/arch.conf
[changed the bits featuring the usual mainline phrase by basically appending just "-lts" - however one could create another entry in the bootloader, see next line [1]
pacman -R linux (this isn't really necessary, one can keep the mainline kernel installed, it's just necessary to add an entry in the bootloader to boot with the LTS kernel!)
[reboot]

Typed this post on my main machine btw. Life makes sense again. smile
Will mark this as solved as I am the OP, but this shouldnt stop anyone from posting tips/advice or questions. Thanks for the help anyone.

[1] NOTE: I AM USING SYSTEMD-BOOT, NOT GRUB! Everyone ought to google this and at least check out these resources:
https://wiki.archlinux.org/index.php/Ke … to_install
https://bbs.archlinux.org/viewtopic.php?id=204583
https://unix.stackexchange.com/question … lts-kernel

Last edited by jones (2017-06-06 09:06:43)

Offline

#2 2017-05-24 15:34:40

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I can chroot into the installation and update as usual via '-Syyu'.

This is frustrating and a bit over my head. Any further advice would be greatly appreciated...

Last edited by jones (2017-05-24 21:17:34)

Offline

#3 2017-05-24 15:41:31

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Please follow the suggestions / requests for information in this thread https://bbs.archlinux.org/viewtopic.php?id=226490

Offline

#4 2017-05-24 16:24:32

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Was literally just able to chroot into the install correctly and do "bootctl update". In any way, I have to go leave the PC for a couple of hours. Checked that link real quick and I am somewhat happy to not be the only one.
Can only provide photos of lsblk and blkid for now.

http://imgur.com/a/XIeLx

Offline

#5 2017-05-24 16:35:36

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

@loqs:
Here are the earlyprintk=efi pics that were removed in the other thread. I will try to disable ACPI.
earlyprintk1txjlw.png earlyprintk233jbp.png

Edit:
Setting 'acpi=off' continues booting but early KMS (nouveau) doesn't kick in (low res), X-Server doesn't start and keyboard doesn't work.

Something's wrong with handling BGRT table in kernel 4.11 i guess.

Edit2:
Maybe related to this upstream bug:
https://bugzilla.kernel.org/show_bug.cgi?id=195633

Last edited by Maniaxx (2017-05-24 18:39:14)


sys2064

Offline

#6 2017-05-24 19:36:42

seth
Member
Registered: 2012-09-03
Posts: 8,963

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Does "noapic" bail you out as well?

Offline

#7 2017-05-24 20:05:18

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

No, still freezing.


sys2064

Offline

#8 2017-05-24 21:02:16

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

$ git clone https://aur.archlinux.org/linux-git.git
$ cd linux-git
$ makepkg -o
$ cd src/linux
$ git checkout v4.11
$ git revert -n 7b0a911478c74ca02581d496f732c10e811e894f
cd ../..
$ makepkg -e

If it is just that one commit the linux-git package should then produce a working kernel.
Before building the kernel I recomend setting Makepkg#MAKEFLAGS

Offline

#9 2017-05-24 21:27:46

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Oh. Indeed a true kernel bug. (or a bug caused by the kernel change)

Well, here's to hoping for a relatively quick fix.

Last edited by jones (2017-05-24 21:28:15)

Offline

#10 2017-05-24 21:49:05

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

@jones just to confirm it is the same issue can you produce the same Oops as Maniaxx?
Edit:
manual transcription of Oops

[    0.000000] Bug: Unable to handle kernel paging request at ffffffffff280001
[    0.000000] IP: efi_bgrt_init+0xdc/0x135
[    0.000000] PGD 1a0c067
[    0.000000] PUD 1a0e067
[    0.000000] PMD 1c66067
[    0.000000] PTE 8a09001800000163
[    0.000000]
[    0.000000] Oops: 0009 [#1] PREEMPT SMP
[    0.000000] Modules linked in:
[    0.000000] CPU: 0 PID:0 Comm: swapper Not tainted 4.11.2-1-ARCH #1
[    0.000000] Hardware name: To be filled by O.E.M. To be filled by O.E.M./P67 PRO, BIOS P3.30 /10
01/2013
[    0.000000] task: ffffffff81a104c0 task.stask: ffffffff81a00000
[    0.000000] RIP: 0010:efi_bgrt_init+0xdc/0x135
[    0.000000] RSP: 0000:ffffffff81a03d58 EFLAGS: 00010082
[    0.000000] RAX: ffffffffff280001 RBX: 0000000000000000 RCX: 0a09001800000006
[    0.000000] RDX: 8000000000000163 RSI: 8a09001800000163 RDI: 000000000000057e
[    0.000000] RBP: ffffffff81a03d70 R08: 8a09001800000100 R09: 0000000000000002
[    0.000000] R10: 0000000000000000 R11: ffff88041efe7fc6 R12: ffffffff8192c76c
[    0.000000] R13: ffffffff81c7e2c0 R14: 0000000000000000 R15: 000000000000000f
[    0.000000] FS:  0000000000000000(0000) GS:ffffffff81b12000(0000) knlGS:0000000000000000
[    0.000000] CS: 0100 DS:0000 ES:0000 CR0:0000000080050033
[    0.000000] CR2: ffffffffff280001 CR3:0000000001a09000 CR4:00000000000406b0
[    0.000000] Call Trace:
[    0.000000] ? acpi_parse_ioapic+0x98/0x98
[    0.000000] acpi_parse_bgrt+0x9/0xd
[    0.000000] acpi_table_parse+0x84/0xb3
[    0.000000] acpi_boot_init+0x48f/0x4d4
[    0.000000] ? acpi_parse_x2apic+0x75/0x75
[    0.000000] ? dmi_ignore_irq0_timer_override+0x2e/0x2e
[    0.000000] setup_arch+0xbd3/0xce5
[    0.000000] ? printk+0x52/0x6e
[    0.000000] ? early_idt_handler_array+0x120/0x120
[    0.000000] start_kernel+0xb2/0x45f
[    0.000000] ? early_idt_handler_array+0x120/0x120
[    0.000000] x86_64_start_reservations+0x2a/0x2c
[    0.000000] x86_64_start_kernel+0x13b/0x15e
[    0.000000] start_cpu+0x14/0x14
[    0.000000] Code: 48 c7 c7 08 84 92 81 e8 40 0f 64 ff eb 62 be 06 00 00 00 e8 de 4b 01 00 48 85 c
0 75 0e 48 c7 c7 38 84 92 81 e8 23 0f 64 ff eb 45 <66> 44 8b 20 be 06 00 00 00 48 89 c7 8b 58 02 e8
57 4c 01 00 66
[    0.000000] RIP: efi_bgrt_init+0xdc/0x135 RSP: ffffffff81a03d58
[    0.000000] CR2: ffffffffff280001
[    0.000000] ---[ end_trace f68728a0d3053b52 ]---
[    0.000000] Kernel panic - not syncing properly: Attempted to kill the idle task!
[    0.000000] ---[ end Kernel panic - not syncing properly: Attempted to kill the idle task!

Last edited by loqs (2017-05-25 00:05:09)

Offline

#11 2017-05-25 00:27:09

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

loqs wrote:

If it is just that one commit the linux-git package should then produce a working kernel.

Confirmed. Revoking the commit boots the kernel properly. I'm on 4.11. Thanks!

Not sure if these dmesg errors are 4.11 specific. Possible that they also appeared on 4.10.

Mai 25 01:49:42 host kernel: ioremap: invalid physical address a09001800000001
Mai 25 01:49:42 host kernel: ------------[ cut here ]------------
Mai 25 01:49:42 host kernel: WARNING: CPU: 0 PID: 0 at arch/x86/mm/ioremap.c:103 __ioremap_caller+0x350/0x360
Mai 25 01:49:42 host kernel: Modules linked in:
Mai 25 01:49:42 host kernel: CPU: 0 PID: 0 Comm: swapper/0 Not tainted 4.11.0-g56fff1bb0f31 #1
Mai 25 01:49:42 host kernel: Hardware name: To Be Filled By O.E.M. To Be Filled By O.E.M./P67 Pro3, BIOS P3.30 10/01/2013
Mai 25 01:49:42 host kernel: Call Trace:
Mai 25 01:49:42 host kernel:  dump_stack+0x63/0x83
Mai 25 01:49:42 host kernel:  __warn+0xcb/0xf0
Mai 25 01:49:42 host kernel:  ? memremap+0xc2/0x180
Mai 25 01:49:42 host kernel:  warn_slowpath_null+0x1d/0x20
Mai 25 01:49:42 host kernel:  __ioremap_caller+0x350/0x360
Mai 25 01:49:42 host kernel:  ? acpi_os_map_memory+0xe/0x10
Mai 25 01:49:42 host kernel:  ? acpi_tb_acquire_table+0x3e/0x6b
Mai 25 01:49:42 host kernel:  ioremap_cache+0x14/0x20
Mai 25 01:49:42 host kernel:  memremap+0xc2/0x180
Mai 25 01:49:42 host kernel:  efi_bgrt_init+0xcf/0x16d
Mai 25 01:49:42 host kernel:  efi_late_init+0x9/0xb
Mai 25 01:49:42 host kernel:  start_kernel+0x434/0x464
Mai 25 01:49:42 host kernel:  ? early_idt_handler_array+0x120/0x120
Mai 25 01:49:42 host kernel:  x86_64_start_reservations+0x2a/0x2c
Mai 25 01:49:42 host kernel:  x86_64_start_kernel+0x14c/0x16f
Mai 25 01:49:42 host kernel:  start_cpu+0x14/0x14
Mai 25 01:49:42 host kernel: ---[ end trace 3fba7300b0fbc887 ]---
Mai 25 01:49:42 host kernel: efi_bgrt: Ignoring BGRT: failed to map image header memory
Mai 25 01:49:47 host kernel: i801_smbus 0000:00:1f.3: SMBus using PCI interrupt
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\GPR2) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\GPR2) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x000000000000057F (\GPR2) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20170119/utaddress-247)
Mai 25 01:49:47 host kernel: ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Mai 25 01:49:47 host kernel: lpc_ich: Resource conflict(s) found affecting gpio_ich

sys2064

Offline

#12 2017-05-25 06:31:20

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

loqs wrote:

@jones just to confirm it is the same issue can you produce the same Oops as Maniaxx?
Edit:
manual transcription of Oops

[    0.000000] Bug: Unable to handle kernel paging request at ffffffffff280001
[    0.000000] IP: efi_bgrt_init+0xdc/0x135
[    0.000000] PGD 1a0c067
[    0.000000] PUD 1a0e067
[    0.000000] PMD 1c66067
[    0.000000] PTE 8a09001800000163
[    0.000000]
[    0.000000] Oops: 0009 [#1] PREEMPT SMP
[    0.000000] Modules linked in:
[    0.000000] CPU: 0 PID:0 Comm: swapper Not tainted 4.11.2-1-ARCH #1
[    0.000000] Hardware name: To be filled by O.E.M. To be filled by O.E.M./P67 PRO, BIOS P3.30 /10
01/2013systemd
[    0.000000] task: ffffffff81a104c0 task.stask: ffffffff81a00000
[    0.000000] RIP: 0010:efi_bgrt_init+0xdc/0x135
[    0.000000] RSP: 0000:ffffffff81a03d58 EFLAGS: 00010082
[    0.000000] RAX: ffffffffff280001 RBX: 0000000000000000 RCX: 0a09001800000006
[    0.000000] RDX: 8000000000000163 RSI: 8a09001800000163 RDI: 000000000000057e
[    0.000000] RBP: ffffffff81a03d70 R08: 8a09001800000100 R09: 0000000000000002
[    0.000000] R10: 0000000000000000 R11: ffff88041efe7fc6 R12: ffffffff8192c76c
[    0.000000] R13: ffffffff81c7e2c0 R14: 0000000000000000 R15: 000000000000000f
[    0.000000] FS:  0000000000000000(0000) GS:ffffffff81b12000(0000) knlGS:0000000000000000
[    0.000000] CS: 0100 DS:0000 ES:0000 CR0:0000000080050033
[    0.000000] CR2: ffffffffff280001 CR3:0000000001a09000 CR4:00000000000406b0
[    0.000000] Call Trace:
[    0.000000] ? acpi_parse_ioapic+0x98/0x98
[    0.000000] acpi_parse_bgrt+0x9/0xd
[    0.000000] acpi_table_parse+0x84/0xb3
[    0.000000] acpi_boot_init+0x48f/0x4d4
[    0.000000] ? acpi_parse_x2apic+0x75/0x75
[    0.000000] ? dmi_ignore_irq0_timer_override+0x2e/0x2e
[    0.000000] setup_arch+0xbd3/0xce5
[    0.000000] ? printk+0x52/0x6e
[    0.000000] ? early_idt_handler_array+0x120/0x120
[    0.000000] start_kernel+0xb2/0x45f
[    0.000000] ? early_idt_handler_array+0x120/0x120
[    0.000000] x86_64_start_reservations+0x2a/0x2c
[    0.000000] x86_64_start_kernel+0x13b/0x15e
[    0.000000] start_cpu+0x14/0x14
[    0.000000] Code: 48 c7 c7 08 84 92 81 e8 40 0f 64 ff eb 62 be 06 00 00 00 e8 de 4b 01 00 48 85 c
0 75 0e 48 c7 c7 38 84 92 81 e8 23 0f 64 ff eb 45 <66> 44 8b 20 be 06 00 00 00 48 89 c7 8b 58 02 e8
57 4c 01 00 66
[    0.000000] RIP: efi_bgrt_init+0xdc/0x135 RSP: ffffffff81a03d58
[    0.000000] CR2: ffffffffff280001
[    0.000000] ---[ end_trace f68728a0d3053b52 ]---
[    0.000000] Kernel panic - not syncing properly: Attempted to kill the idle task!
[    0.000000] ---[ end Kernel panic - not syncing properly: Attempted to kill the idle task!

Yes! See for yourself. (actually just learned about how to use kernel parameters with systemd-boot https://wiki.archlinux.org/index.php/Ke … temd-boot)

http://imgur.com/a/7wOiw

And now... should I rather use the LTS Kernel?
Gitting around with the kernel, that I'd rather avoid. :-)

Last edited by jones (2017-05-25 06:34:43)

Offline

#13 2017-05-25 10:12:25

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

@Maniaxx you might want to try contacting the author of the commit https://git.kernel.org/pub/scm/linux/ke … 0e811e894f by plain text email
reporting-bugs not all subsystems use the kernel bug tracker the author should at least be able to point you in the correct direction.
Edit:
@Jones yes either use linux-lts or linux with the parameter acpi=off

Last edited by loqs (2017-05-25 10:51:44)

Offline

#14 2017-05-25 12:22:01

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I will try latest dev kernel first and 'nomodeset' parameter. There is still progress on the BGRT code. Maybe it's already fixed but not yet backported.


sys2064

Offline

#15 2017-05-25 12:56:16

R00KIE
Forum Moderator
From: Between a computer and a chair
Registered: 2008-09-14
Posts: 4,734

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I'd be more inclined to tell people to stay with linux-lts until this is fixed than using acpi=off for day to day usage, at least for people with laptops. The reason is, if I'm not mistaken, you will not have cpu power management and will generate more heat and use more power.


R00KIE
Tm90aGluZyB0byBzZWUgaGVyZSwgbW92ZSBhbG9uZy4K

Offline

#16 2017-05-25 15:33:58

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

So it is working again.

Installed the lts-kernel and its headers.
Did this while (arch-)chrooted into the system:

pacman -S linux-lts linux-lts-headers
nano /boot/loader/entries/arch.conf
[changed the bits featuring the usual mainline phrase by basically appending just "-lts" - however one could create another entry in the bootloader, see next line [1]
pacman -R linux (this isn't really necessary, one can keep the mainline kernel installed, it's just necessary to add an entry in the bootloader to boot with the LTS kernel!)
[reboot]

Typed this post on my main machine btw. Life makes sense again. smile
Will mark this as solved as I am the OP, but this shouldnt stop anyone from posting tips/advice or questions. Thanks for the help anyone.

[1] NOTE: I AM USING SYSTEMD-BOOT, NOT GRUB! Everyone ought to google this and at least check out these resources:
https://wiki.archlinux.org/index.php/Ke … to_install
https://bbs.archlinux.org/viewtopic.php?id=204583
https://unix.stackexchange.com/question … lts-kernel

Last edited by jones (2017-06-06 09:07:25)

Offline

#17 2017-05-27 21:10:02

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

https://bugzilla.kernel.org/show_bug.cgi?id=195633#c2

Dave Young wrote:

Can you print the bgrt table like below and save the kmesg? I would better to have a full kernel log, for the working kernel and failed kernel.

        pr_info("%s acpi_table_bgrt.version %hu\n", __func__, bgrt->version);
        pr_info("%s acpi_table_bgrt.status %hhu\n", __func__, bgrt->status);
        pr_info("%s acpi_table_bgrt.image_type %hhu\n", __func__, bgrt->image_type);
        pr_info("%s acpi_table_bgrt.image_address %llx\n", __func__, bgrt->image_address);
        print_hex_dump(KERN_INFO, "efi_bgrt_init acpi_table_bgrt", DUMP_PREFIX_OFFSET, 16, 1, bgrt, sizeof(*bgrt), false);

Possibly try inserting the code here.
https://git.kernel.org/pub/scm/linux/ke … 4.11.2#n35
Edit2:
Source file compiles but linking fails.
Edit3:
Cleaned build directory v4.11 without the revert but with the above lines added to efi-bgrt.c now compiles and links but not tested.  (too many changes to conclude anything sorry)
Edit4:
Cleaned build directory v4.11.2 without the revert but with the above lines added to efi-bgrt.c now compiles and links but not tested.
Cleaned build directory v4.11.2 with the revert and the above lines added to efi-bgrt.c fails to link.

  LD      drivers/built-in.o
==> ERROR: A failure occurred in build().
    Aborting...

Edit5:
Line 35 is probably too early as bgrt is only initialized on line 44 but that is after the acpi check so if you run it with acpi disabled it will not reach there if you run it with acpi enabled the output will be replaced on the console by the Oops.
Ideally needs a system with a serial port to dump console output to.
https://git.kernel.org/pub/scm/linux/ke … 4.11.2#n44

Last edited by loqs (2017-05-28 14:49:16)

Offline

#18 2017-05-30 17:46:00

wilberfan
Member
From: So. Cal
Registered: 2010-12-18
Posts: 248

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I've been having this issue for a couple of days.  Would downgrading the kernel to 4.10 (or something else) also solve this problem?


Hey, be nice...I'm new at this!

Offline

#19 2017-05-30 18:08:06

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Assuming it is the same issue see post #12 solutions are provided in posts #13, #15 and #16

Offline

#20 2017-06-04 02:32:13

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I need some info from affected and non-affected systems. Would be great if we could collect at least 3 of each.
Please do the following:

pacman -S iasl
sudo acpidump > acpi.dat
acpixtract -a acpi.dat
iasl -d bgrt.dat 
cat bgrt.dsl

Post the result like below. Don't forget to mention if the system is affected (freeze on kernel 4.11+) or not. Your current kernel (when doing acpidump) doesn't matter. You can do it on LTS kernel or any other. Thanks!

Example:

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20170303 (64-bit version)
 * Copyright (c) 2000 - 2017 Intel Corporation
 * 
 * Disassembly of bgrt.dat, Sat Jun  3 15:33:10 2017
 *
 * ACPI Data Table [BGRT]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "BGRT"    [Boot Graphics Resource Table]
[004h 0004   4]                 Table Length : 0000003C
[008h 0008   1]                     Revision : 00
[009h 0009   1]                     Checksum : 89
[00Ah 0010   6]                       Oem ID : "ALASKA"
[010h 0016   8]                 Oem Table ID : "A M I"
[018h 0024   4]                 Oem Revision : 01072009
[01Ch 0028   4]              Asl Compiler ID : "AMI "
[020h 0032   4]        Asl Compiler Revision : 00010013

[024h 0036   2]                      Version : 0001
[026h 0038   1]                       Status : 00
[027h 0039   1]                   Image Type : 00
[028h 0040   8]                Image Address : 0A08E01800000001
[030h 0048   4]                Image OffsetX : 00000000
[034h 0052   4]                Image OffsetY : 00000000

Raw Table Data: Length 60 (0x3C)

  0000: 42 47 52 54 3C 00 00 00 00 89 41 4C 41 53 4B 41  // BGRT<.....ALASKA
  0010: 41 20 4D 20 49 00 00 00 09 20 07 01 41 4D 49 20  // A M I.... ..AMI 
  0020: 13 00 01 00 01 00 00 00 01 00 00 00 18 E0 08 0A  // ................
  0030: 00 00 00 00 00 00 00 00 00 00 00 00              // ............

Last edited by Maniaxx (2017-06-04 02:43:57)


sys2064

Offline

#21 2017-06-04 08:20:39

noctavian
Member
Registered: 2013-07-11
Posts: 11

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I have an affected desktop system. I use grub to boot in UEFI mode. On kernel 4.11 it freezes at initramfs.

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20170224 (64-bit version)
 * Copyright (c) 2000 - 2017 Intel Corporation
 * 
 * Disassembly of bgrt.dat, Sun Jun  4 10:49:46 2017
 *
 * ACPI Data Table [BGRT]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "BGRT"    [Boot Graphics Resource Table]
[004h 0004   4]                 Table Length : 0000003C
[008h 0008   1]                     Revision : 00
[009h 0009   1]                     Checksum : B3
[00Ah 0010   6]                       Oem ID : "ALASKA"
[010h 0016   8]                 Oem Table ID : "A M I"
[018h 0024   4]                 Oem Revision : 01072009
[01Ch 0028   4]              Asl Compiler ID : "AMI "
[020h 0032   4]        Asl Compiler Revision : 00010013

[024h 0036   2]                      Version : 0001
[026h 0038   1]                       Status : 00
[027h 0039   1]                   Image Type : 00
[028h 0040   8]                Image Address : 09FFC01800000001
[030h 0048   4]                Image OffsetX : 00000000
[034h 0052   4]                Image OffsetY : 00000000

Raw Table Data: Length 60 (0x3C)

  0000: 42 47 52 54 3C 00 00 00 00 B3 41 4C 41 53 4B 41  // BGRT<.....ALASKA
  0010: 41 20 4D 20 49 00 00 00 09 20 07 01 41 4D 49 20  // A M I.... ..AMI 
  0020: 13 00 01 00 01 00 00 00 01 00 00 00 18 C0 FF 09  // ................
  0030: 00 00 00 00 00 00 00 00 00 00 00 00              // ............

I don't know if this is going to matter, but I boot with some virtualization options turned on for VGA passthrough.

[    0.000000] Linux version 4.10.13-1-ARCH (builduser@tobias) (gcc version 6.3.1 20170306 (GCC) ) #1 SMP PREEMPT Thu Apr 27 12:15:09 CEST 2017
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=921eb601-1f06-4afc-99ff-ccbf49648e28 rw intel_iommu=on pci-stub.ids=1002:68ba,1002:aa58 kvm-intel.nested=1 quiet

Offline

#22 2017-06-04 09:05:43

jones
Member
Registered: 2013-03-14
Posts: 137

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

Aloha Herr Maniaxx. Here you go! smile


edit: My motherboard is the ASROCK H67M, btw.

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20170303 (64-bit version)
 * Copyright (c) 2000 - 2017 Intel Corporation
 * 
 * Disassembly of bgrt.dat, Sun Jun  4 11:04:24 2017
 *
 * ACPI Data Table [BGRT]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "BGRT"    [Boot Graphics Resource Table]
[004h 0004   4]                 Table Length : 0000003C
[008h 0008   1]                     Revision : 00
[009h 0009   1]                     Checksum : 96
[00Ah 0010   6]                       Oem ID : "ALASKA"
[010h 0016   8]                 Oem Table ID : "A M I"
[018h 0024   4]                 Oem Revision : 01072009
[01Ch 0028   4]              Asl Compiler ID : "AMI "
[020h 0032   4]        Asl Compiler Revision : 00010013

[024h 0036   2]                      Version : 0001
[026h 0038   1]                       Status : 00
[027h 0039   1]                   Image Type : 00
[028h 0040   8]                Image Address : 09FCE01800000001
[030h 0048   4]                Image OffsetX : 00000000
[034h 0052   4]                Image OffsetY : 00000000

Raw Table Data: Length 60 (0x3C)

  0000: 42 47 52 54 3C 00 00 00 00 96 41 4C 41 53 4B 41  // BGRT<.....ALASKA
  0010: 41 20 4D 20 49 00 00 00 09 20 07 01 41 4D 49 20  // A M I.... ..AMI 
  0020: 13 00 01 00 01 00 00 00 01 00 00 00 18 E0 FC 09  // ................
  0030: 00 00 00 00 00 00 00 00 00 00 00 00              // ............

Last edited by jones (2017-06-05 10:49:45)

Offline

#23 2017-06-04 09:06:28

aethelstan
Member
Registered: 2017-06-03
Posts: 5

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

I have an affected desktop system (see also my other thread here: https://bbs.archlinux.org/viewtopic.php?id=226873).
Currently running fine again with the -lts kernel.

Here's the requested info from my system:

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20170303 (64-bit version)
 * Copyright (c) 2000 - 2017 Intel Corporation
 * 
 * Disassembly of bgrt.dat, Sun Jun  4 11:04:25 2017
 *
 * ACPI Data Table [BGRT]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "BGRT"    [Boot Graphics Resource Table]
[004h 0004   4]                 Table Length : 0000003C
[008h 0008   1]                     Revision : 00
[009h 0009   1]                     Checksum : 4C
[00Ah 0010   6]                       Oem ID : "ALASKA"
[010h 0016   8]                 Oem Table ID : "A M I"
[018h 0024   4]                 Oem Revision : 01072009
[01Ch 0028   4]              Asl Compiler ID : "AMI "
[020h 0032   4]        Asl Compiler Revision : 00010013

[024h 0036   2]                      Version : 0001
[026h 0038   1]                       Status : 00
[027h 0039   1]                   Image Type : 00
[028h 0040   8]                Image Address : 0A65C01800000001
[030h 0048   4]                Image OffsetX : 00000000
[034h 0052   4]                Image OffsetY : 00000000

Raw Table Data: Length 60 (0x3C)

  0000: 42 47 52 54 3C 00 00 00 00 4C 41 4C 41 53 4B 41  // BGRT<....LALASKA
  0010: 41 20 4D 20 49 00 00 00 09 20 07 01 41 4D 49 20  // A M I.... ..AMI 
  0020: 13 00 01 00 01 00 00 00 01 00 00 00 18 C0 65 0A  // ..............e.
  0030: 00 00 00 00 00 00 00 00 00 00 00 00              // ............

I don't use any custom kernel parameters.

Last edited by aethelstan (2017-06-04 09:06:47)

Offline

#24 2017-06-04 11:46:34

loqs
Member
Registered: 2014-03-06
Posts: 6,399

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

For the three working samples you might try the IRC channels I checked my system its ACPI does not contain a BGRT section sorry.

Offline

#25 2017-06-05 10:45:03

spinnau
Member
Registered: 2017-06-05
Posts: 34

Re: [SOLVED] Arch won't boot after selecting "Arch Linux" in systemd-boot

System with EFI boot freezing on kernel 4.11 at initramfs. Here is the output of the acpi dump:

/*
 * Intel ACPI Component Architecture
 * AML/ASL+ Disassembler version 20170303 (64-bit version)
 * Copyright (c) 2000 - 2017 Intel Corporation
 * 
 * Disassembly of bgrt.dat, Sun Jun  4 16:22:13 2017
 *
 * ACPI Data Table [BGRT]
 *
 * Format: [HexOffset DecimalOffset ByteLength]  FieldName : FieldValue
 */

[000h 0000   4]                    Signature : "BGRT"    [Boot Graphics Resource Table]
[004h 0004   4]                 Table Length : 0000003C
[008h 0008   1]                     Revision : 00
[009h 0009   1]                     Checksum : 5F
[00Ah 0010   6]                       Oem ID : "ALASKA"
[010h 0016   8]                 Oem Table ID : "A M I"
[018h 0024   4]                 Oem Revision : 01072009
[01Ch 0028   4]              Asl Compiler ID : "AMI "
[020h 0032   4]        Asl Compiler Revision : 00010013

[024h 0036   2]                      Version : 0001
[026h 0038   1]                       Status : 00
[027h 0039   1]                   Image Type : 00
[028h 0040   8]                Image Address : 0A62B01800000001
[030h 0048   4]                Image OffsetX : 00000000
[034h 0052   4]                Image OffsetY : 00000000

Raw Table Data: Length 60 (0x3C)

  0000: 42 47 52 54 3C 00 00 00 00 5F 41 4C 41 53 4B 41  // BGRT<...._ALASKA
  0010: 41 20 4D 20 49 00 00 00 09 20 07 01 41 4D 49 20  // A M I.... ..AMI 
  0020: 13 00 01 00 01 00 00 00 01 00 00 00 18 B0 62 0A  // ..............b.
  0030: 00 00 00 00 00 00 00 00 00 00 00 00              // ............

With the 4.10 kernel on my system BGRT was ignored, as memremap of the bmp image header failed. But despite this message, the system was booting fine.

[    0.112643] ioremap: invalid physical address a62b01800000001
[    ........]
[    0.112738] efi_bgrt: Ignoring BGRT: failed to map image header memory

I have also added more information to this kernel bug report https://bugzilla.kernel.org/show_bug.cgi?id=195633.

Offline

Board footer

Powered by FluxBB