You are not logged in.

#1 2017-06-21 18:56:15

Linuxplorer
Member
Registered: 2017-05-26
Posts: 11

[Resolved]Error installing conky-lua

I am trying to install conky-lua from AUR. The package build fails stating "unable to find program 'git'". Do I need to install the package 'git' in order for this to succeed? It is my understanding that git is a version control system for developers.

Thanks

edit: The answer to my question was simply yes. The git package is necessary for some packages to install correctly.

Last edited by Linuxplorer (2017-06-21 20:42:37)

Offline

#2 2017-06-21 19:00:09

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,373
Website

Re: [Resolved]Error installing conky-lua


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#3 2017-06-21 19:16:51

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,443
Website

Re: [Resolved]Error installing conky-lua

As Trilby's link recommends, you need to post full output and complete information if you want help.

Some packages require git to download source files from remote git repos. This is usually restricted to packages with the "-git" suffix, which indicates development versions, but makepkg can pull static versions from a git repo too.

conky-lua doesn't seem to require git, but one of its dependencies may. We could tell you which one if you post the full output of whatever command is failing. The error itself may indicate that a packager forget to add a build dependency to the PKGBUILD.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#4 2017-06-21 20:17:19

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: [Resolved]Error installing conky-lua

Hi Linuxplorer, "[Closed]" is a marking for threads which have actually been closed by a moderator. Editing the title with that only adds confusion. Please do not do that. I have removed it from this thread.

If you have found a solution, please post it. If not, please provide the information requested by Trilby and Xyne. If you think this thread has no further future, you can request a moderator actually close it by reporting your thread.

Please also read the Code of conduct, particularly these two sections,

Thank you.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#5 2017-06-21 22:21:39

loqs
Member
Registered: 2014-03-06
Posts: 9,227

Re: [Resolved]Error installing conky-lua

So https://aur.archlinux.org/packages/conky-lua/ is missing a makedepends on git you could leave a message on the aur package page asking the maintainer to include it.

Offline

#6 2017-06-21 22:38:31

Linuxplorer
Member
Registered: 2017-05-26
Posts: 11

Re: [Resolved]Error installing conky-lua

loqs wrote:

So https://aur.archlinux.org/packages/conky-lua/ is missing a makedepends on git you could leave a message on the aur package page asking the maintainer to include it.

I will do that. I learn more about this stuff everyday.

Offline

#7 2017-06-21 23:11:51

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,443
Website

Re: [Resolved]Error installing conky-lua

Linuxplorer wrote:
loqs wrote:

So https://aur.archlinux.org/packages/conky-lua/ is missing a makedepends on git you could leave a message on the aur package page asking the maintainer to include it.

I will do that. I learn more about this stuff everyday.

No. conky-lua does not seem to directly depend on git. One of it's dependencies might, but that is not the responsibility of the conky-lua maintainer. This is why we keep asking for the actual command output, so we can determine which package is missing the dependency.

I see that you have already left a comment on conky-lua page. hmm


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#8 2017-06-21 23:18:31

loqs
Member
Registered: 2014-03-06
Posts: 9,227

Re: [Resolved]Error installing conky-lua

Apologies for the confusion I looked at the packages upstream url not the source url.

Offline

#9 2017-06-22 00:27:57

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,373
Website

Re: [Resolved]Error installing conky-lua

OK, perhaps I should have been more verbose.  That package does not depend on git, and there is nothing in the PKGBUILD that looks like it should depend on git.  So your out-of-context paraphrased error message is confusing.  Many people in this thread are taking random stabs in the dark at what the problem *might* be, wherease if you would just provide the complete output we'd not have to be in the dark.

I did just try building this myself (after removing git) and it seems there is a problem in the Conky.cmake input.  The CMAKE_BUILD_TYPE is not actually being set to RELEASE (despite that being in the PKGBUILD).

The following sed line in the build function (right after the cd to the srcdir) fixes it:

sed -i 's/#\(set(RELEASE true)\)/\1/' cmake/Conky.cmake

(edit: see Xyne's solution below instead)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#10 2017-06-22 01:30:26

loqs
Member
Registered: 2014-03-06
Posts: 9,227

Re: [Resolved]Error installing conky-lua

@Trilby it appears the conky package in extra has a makedepends on git to work around the same issue.

Offline

#11 2017-06-22 01:42:53

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,443
Website

Re: [Resolved]Error installing conky-lua

Well, f#$%. tongue

Btw, just add

-D RELEASE=true

to the cmake command options in the build function.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

Board footer

Powered by FluxBB