You are not logged in.

#2326 2022-06-16 19:04:36

rep_movsd
Member
Registered: 2013-08-24
Posts: 115

Re: Laptops which run Arch

New laptop report

Intro

I recently upgraded from a Dell Precision M7710 to an M7760
My usual migration path is to copy the boot and root partitions onto the new system and it has always worked right out of the box.

I first installed Arch Linux on an M6500 in 2013 migrating to an M6700 in 2017 then I swapped that with my brothers M7710 in 2020, and now finally I gave him that back after getting the M7760.
I've NEVER had to reinstall, the same installation has been migrated across multiple harddisks (including mdraid RAID-0) and multiple laptops.

Only one minor issue happened during all this migrating - on the 7710, the screen brightness would default to nil when Plasma came up, it took some head scratching to detect that all that was needed was to raise it above 0 once and then it was fine.

The only mishap/failue that occured was in December 2021 when I forcefully powered off the system (while trying to get nvidia 4.70 to work) and my btrfs partition somehow corrupted. Trying tofix it I ended up borking my home directory for good. I restored from a full backup I had from October '21. 3 months lost, but most of my critical work stuff was on the cloud.

All this background is just a testament to how amazingly stable/fixable Arch Linux has been - Having used primarily Windows from 1998 until 2013, I cant even count the number of times I had to reinstall, repair or restore from backup, for various systems.

In case anyone has any 17" Precision with any issues, let me know, I may have a fix or some info.

Upgrade

The system came with Ubuntu preinstalled.

I did the usual - I rsync'd my older laptops root directory to an external drive. Since my /boot is on the EFI, I added that into /boot.

On the new system, I booted from a Linux Mint live USB drive, used gparted to make partitions for EFI and root. Then rsynced back and copied /boot stuff onto the EFI partition - it booted right away and all seemed well.

There were a few issues:

1) LCD Backlight keys did not have any effect - the /sys/class/acpi_backlight/brightness value did change, and KDE does show the brightness slider, but the brightness doesnt change. This laptop uses a WLED backlight. I am using xrandr to manually manage the brightness. Interestingly, on the Ubuntu install it worked - I don't know if it was using xrandr somehow. This needs to be investigated.

2) My previous M7710 laptop never worked with any kernel version > 5.12.9 and nvidia version > 465.x - the kernels would boot, but the display would go blank with Xorg log showing all 6 display outputs disconnected (check my earlier threads). On this one, the error was different, I got a kernel trap for the nvidia module with a message related to "ENDBR". seth told me it may be related to the ibt kernel setting. I made a clone installation to experiment with and tried the ibt=off kernel parameter. This worked and I was able to get the latest kernel and nvidia package working fine.

3) Hybrid graphics doesnt work - The BIOS says "Note: Hybrid graphics does not work on Linux" but I tried anyway. It gets to the point where X starts but that console freezes. Interestingly, the brightness keys work then. I think the acpi backlight control is supported on the Intel graphics controller. The Xorg log shows all output devices disconnected (familiar story!). There's not much use for hybrid graphics except powersaving, so not a big loss.

4) Display scaling - this was weird - probably my own fault when setting up the system first on the M7710 with a 4K UHD display. I had set the Display scaling to 200% (Like I generally did on Windows systems for high DPI). This worked but GTK apps always had some weirdness and I ended up using some GDK_SCALE and GDK_DPI_SCALE  settings that made some apps work correctly and others not. Today I figured out that you literally dont need to do anything - just leave the display at 100% and Plasma/QT apps automatically scale. Plasma also sets GDK_DPI_SCALE=2.75 automatically for GTK apps to scale - (17" 4kUHD screens have 264 dpi and 264/96 is 2.75)
Now all GTK apps like meld, gitk, gparted and so on scale fine, and so does Firefox (which was the biggest problem before)

---------------

The performance and usability has been just amazing on these M series 17" Precisions across all these years - all of the machines are still in decent working condition - even the 6300 from 2012 that I bought refurbished from the Dell outlet store is working as a Linux desktop system to date and shows no signs of hardware issues

Thanks to Dell (or is it the Linux kernel folks?) for making Linux relatively well supported on these machines - when you buy these, the support engineers also do not talk you down and dont complain that your OS environment is non standard - there is also no "Warranty void if opened" sticker anywhere - these systems are built to easily open and upgrade/repair.

Offline

#2327 2022-06-19 16:49:57

rep_movsd
Member
Registered: 2013-08-24
Posts: 115

Re: Laptops which run Arch

Update
---------

Scaling is not as simple as it seems!

QT and Plasma scale perfectly without any changes except 200% display scaling, but GDK apps need some settings

The standard GDK_DPI_SCALE, and GDK_SCALE need to be set, BUT

1) Some apps seem to ignore GDK_DPI_SCALE, while others override GDK_SCALE with GDK_DPI_SCALE
2) The environment variables need to be session wide

After endless experimentation - this works for me

GDK_DPI_SCALE=1
GDK_SCALE=3

The following apps work fine with this + 200% display scaling: thunderbird, gitk, meld, gparted, firefox
Ideally I should use 2.75 since my DPI is 96*2.75, but 3 seems to look the right size to me.

This combo seems to satisfy both the ones that use GDK_SCALE alone as well as those that seem to multiply
Putting these vars in any of .bash_profile, .bashrc, .xinitrc won't work correctly. The vars will show up for the apps launced from terminals (which load bash), but not affect the apps launched from desktop shortcuts etc.

The correct way to add session wide env vars on KDE seems to be to put a shell script in $HOME/.config/plasma-workspace/env/ as per https://userbase.kde.org/Session_Environment_Variables

Finally it seems OK now

Offline

#2328 2022-06-20 14:15:57

rep_movsd
Member
Registered: 2013-08-24
Posts: 115

Re: Laptops which run Arch

Update 2
------------

I spent a while trying to get PRIME to work
It seems to work out of the box and it solves the backlight issues

Install xf86-video-intel
Install nvidia-prime
delete the xorg.conf file

It will boot up with the Intel adapter as default and you can use prime-run to launch any app with the nVidia GPU

I tried this mode to see if Chrome video acceleration works better, but whatever I did, youtube videos wont accelerate on vaapi

So I decided to go for the source/sink mode with xrandr as per https://us.download.nvidia.com/XFree86/ … ndr14.html

Generate the xorg.conf file with nvidia-xconfig --prime and add

xrandr --setprovideroutputsource modesetting NVIDIA-0
xrandr --auto

This seems to work fine

Offline

Board footer

Powered by FluxBB