You are not logged in.

#1 2017-09-06 16:19:34

Qwoak
Member
From: France
Registered: 2017-08-03
Posts: 10

[SOLVED] Setting-up Wake-on-LAN

Hi everyone !

This time I would need some advices about Wake-on-LAN.

I currently studying computer sciences. For my studies, my teachers strongly recommend me to invest into a personal laptop computer (what I can't do) rather than using the ones provided by the school, because as we going to use a lot virtualization, and as I must return the laptop each end of class, transferring multiple VMs on/from an usb stick every time is not viable.

So the idea is that I could use the loaned laptop to take control of my more powerful desktop computer, and avoid useless invests.

For this I would like to set-up Wake-on-LAN, but I have an issue.

The problem is, when I shutdown my computer under Arch, my NIC seems to be switched off (No LED blinking), while it stays powered-on when I shutdown my computer under Windows (WOL works fine then).

I have enabled all the required settings in my BIOS.

So, I followed the wiki and did :

# ethtool enp3s0 | grep Wake-on

But I got nothing. Then :

# ethtool enp3s0

Settings for enp3s0:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Supported pause frame use: Symmetric Receive-only
	Supports auto-negotiation: Yes
	Advertised link modes:  10baseT/Half 10baseT/Full
	                        100baseT/Half 100baseT/Full
	                        1000baseT/Full
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: Yes
	Speed: 100Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: on
	MDI-X: Unknown
	Current message level: 0x000060e4 (24804)
			       link ifup rx_err tx_err hw wol
	Link detected: yes

But I see nothing about WOL.

So I have still tried :

# ethtool -s enp3s0 wol g

Cannot get current wake-on-lan settings: Operation not supported
  not setting wol

My network card is an Atheros Killer E2500 .

# lspci -v

03:00.0 Ethernet controller: Qualcomm Atheros Device e0b1 (rev 10)
	Subsystem: Micro-Star International Co., Ltd. [MSI] Device 7a78
	Flags: bus master, fast devsel, latency 0, IRQ 19
	Memory at df200000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at d000 [size=128]
	Capabilities: [40] Power Management version 3
	Capabilities: [58] Express Endpoint, MSI 00
	Capabilities: [c0] MSI: Enable- Count=1/16 Maskable+ 64bit+
	Capabilities: [d8] MSI-X: Enable+ Count=16 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [180] Device Serial Number ff-b3-7e-27-4c-cc-6a-ff
	Kernel driver in use: alx
	Kernel modules: alx

Any ideas ?

Thank you ^_^

Last edited by Qwoak (2017-09-07 15:34:14)

Offline

#2 2017-09-07 05:44:37

seth
Member
Registered: 2012-09-03
Posts: 3,670

Re: [SOLVED] Setting-up Wake-on-LAN

My network card is an Atheros Killer E2500 .

https://wiki.archlinux.org/index.php/Wa … er_support ...

Offline

#3 2017-09-07 10:56:01

Qwoak
Member
From: France
Registered: 2017-08-03
Posts: 10

Re: [SOLVED] Setting-up Wake-on-LAN

Oh thank you, I missed this. I'll try.

EDIT : Allright, it works.

Last edited by Qwoak (2017-09-07 15:33:31)

Offline

Board footer

Powered by FluxBB