You are not logged in.

#1 2017-09-13 10:38:47

peanut_0
Member
Registered: 2016-03-20
Posts: 14

[solved] bumblebee error - Could not enable discrete graphics card

I've followed the archwiki installation for bumblebee.

Output for 'optirun glxgears'

[ 1165.616565] [ERROR]Cannot access secondary GPU - error: Could not enable discrete graphics card

[ 1165.616591] [ERROR]Aborting because fallback start is disabled.

After stopping the bumblebeed via systemd and restarting using 'bumblebeed --debug' and running 'optirun glxgears' again, I get

[ 1323.384230] [DEBUG]bbswitch has been detected.
[ 1323.384306] [INFO]Switching method 'bbswitch' is available and will be used.
[ 1323.384338] [DEBUG]Active configuration:
[ 1323.384365] [DEBUG] bumblebeed config file: /etc/bumblebee/bumblebee.conf
[ 1323.384390] [DEBUG] X display: :8
[ 1323.384417] [DEBUG] LD_LIBRARY_PATH: /usr/lib/nvidia:/usr/lib32/nvidia:/usr/lib:/usr/lib32
[ 1323.384443] [DEBUG] Socket path: /var/run/bumblebee.socket
[ 1323.384470] [DEBUG] xorg.conf file: /etc/bumblebee/xorg.conf.nvidia
[ 1323.384496] [DEBUG] xorg.conf.d dir: /etc/bumblebee/xorg.conf.d
[ 1323.384522] [DEBUG] ModulePath: /usr/lib/nvidia/xorg,/usr/lib/xorg/modules
[ 1323.384549] [DEBUG] GID name: bumblebee
[ 1323.384575] [DEBUG] Power method: bbswitch
[ 1323.384602] [DEBUG] Stop X on exit: 1
[ 1323.384628] [DEBUG] Driver: nvidia
[ 1323.384654] [DEBUG] Driver module: nvidia
[ 1323.384680] [DEBUG] Card shutdown state: 1
[ 1323.384772] [DEBUG]Process /sbin/modprobe started, PID 17803.
[ 1323.386573] [DEBUG]Hiding stderr for execution of /sbin/modprobe
[ 1323.390783] [DEBUG]SIGCHILD received, but wait failed with No child processes
[ 1323.390796] [DEBUG]Configuration test passed.
[ 1323.391169] [INFO]bumblebeed 3.2.1 started
[ 1323.683461] [INFO]Initialization completed - now handling client requests
[ 1337.837581] [DEBUG]Accepted new connection
[ 1338.129954] [INFO]Switching dedicated card ON [bbswitch]
[ 1338.130034] [ERROR]Could not enable discrete graphics card
[ 1338.130793] [DEBUG]Socket closed.

I've looked at similar issues and it can't be due to tlp or external monitors because I'm not using either of those.

I do remember bumblebee working at some point in the past, but I'm not sure what happened to make it stop working.

Last edited by peanut_0 (2017-09-13 15:02:47)

Offline

#2 2017-09-13 14:27:29

seth
Member
Registered: 2012-09-03
Posts: 4,671

Re: [solved] bumblebee error - Could not enable discrete graphics card

Offline

#3 2017-09-13 15:02:32

peanut_0
Member
Registered: 2016-03-20
Posts: 14

Re: [solved] bumblebee error - Could not enable discrete graphics card

I don't use TLP, so it would be very weird if that was the problem.


It turns out adding bbswitch to the mkinitcpio.conf modules fixes the problem (https://bbs.archlinux.org/viewtopic.php?id=185865). (I'm not entirely sure why this works, but it does)

Offline

Board footer

Powered by FluxBB