You are not logged in.

#1 2017-09-23 16:35:39

DoXer
Member
Registered: 2017-08-27
Posts: 24

[Solved] fuse: unknown option(s): `-o _netdev,user'

Hi,
I'm running ARCH sinze 4 weeks and mounted my NAS-Filesystem in fstab like this (from the wiki) and it works since a reboot today.

michael@nas:/mnt/pool/freigabe /media/nas/freigabe  fuse.sshfs noauto,x-systemd.automount,_netdev,user,idmap=user,follow_symlinks,identityfile=/home/michael/.ssh/id_rsa,allow_other,default_permissions,uid=1000,gid=100 0 0

After the reboot the mount ist not working and i get the error

fuse: unknown option(s): `-o _netdev,user'

Looks like something with the last update. For the first I removed both options an mount is working, but I think I need both options.

grep fuse /var/log/pacman.log
[2017-08-27 00:26] [ALPM] installed fuse-common (3.1.1-1)
[2017-08-27 00:26] [ALPM] installed fuse3 (3.1.1-1)
[2017-08-27 13:04] [ALPM] installed fuse2 (2.9.7-3)
[2017-09-18 09:31] [ALPM] upgraded fuse-common (3.1.1-1 -> 3.2.0-1)
[2017-09-18 09:31] [ALPM] upgraded fuse2 (2.9.7-3 -> 2.9.7-4)
[2017-09-18 09:31] [ALPM] upgraded fuse3 (3.1.1-1 -> 3.2.0-1)

How can I fix this? How can I get information about the changes? I looked in manual fuse, fusermount3, but no hints.

Regards
Michael

Last edited by DoXer (2017-10-25 20:23:04)


--
Regards
Michael

Offline

#2 2017-09-23 19:30:15

randomguy
Member
Registered: 2007-06-19
Posts: 92

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Did you try downgrading systemd? This behaviour is strange, as those options shouldn't be passed to the fuse binary like that. I suspect this commit: https://github.com/systemd/systemd/comm … 52cb903bba

Offline

#3 2017-09-23 20:21:53

DoXer
Member
Registered: 2017-08-27
Posts: 24

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

No, I didn't try to downgrade.

Why systemd?


--
Regards
Michael

Offline

#4 2017-09-23 20:29:45

randomguy
Member
Registered: 2007-06-19
Posts: 92

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Systemd parses /etc/fstab and creates unit files for the mounts defined in it. Could you show me the output of systemctl status for the unit file? For me it was named after the mount target, so yours should be:

sudo systemctl status media-nas-freigabe.mount

If it doesn't exist under this exact name, check other *.mount unit files.

I could reproduce your problem on my end, mine shows:

● home-eddi-homessh.mount - /home/eddi/homessh
   Loaded: loaded (/etc/fstab; generated; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2017-09-23 21:53:55 CEST; 30min ago
    Where: /home/eddi/homessh
     What: eddi@localhost:/home/eddi
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)
  Process: 1156 ExecMount=/usr/bin/mount eddi@localhost:/home/eddi /home/eddi/homessh -t fuse.sshfs -o x-systemd.automount,_netdev,user,idmap=user,follow_symlinks,identityfile=/home/michael/.ssh/id_rsa,allow_other,default_permissions,uid=1000,gid=100 (code=exited, status=1/FAILURE)

Running the command (everything after ExecMount=) by hand yields your error:

$ sudo /usr/bin/mount eddi@localhost:/home/eddi /home/eddi/homessh -t fuse.sshfs -o x-systemd.automount,_netdev,user,idmap=user,follow_symlinks,identityfile=/home/michael/.ssh/id_rsa,allow_other,default_permissions,uid=1000,gid=100
fuse: unknown option(s): `-o _netdev,user'

Edit: Better guess for the unit file name...

Last edited by randomguy (2017-09-23 20:33:46)

Offline

#5 2017-09-23 21:25:47

xganesh
Member
Registered: 2010-03-15
Posts: 31

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Same problem here.
I have downgraded systemd from version "234.11-8" to "233.75-3" and the failure persists.

After doing:

# systemctl status FARAWAYDATA.mount

I get the following:

● FARAWAYDATA.mount - /FARAWAYDATA
   Loaded: loaded (/etc/fstab; generated; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2017-09-23 17:20:25 EDT; 9s ago
    Where: /FARAWAYDATA
     What: ele@MyFarAwayHost.boldlygoingnowhere.org:/FARAWAYDATA
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)
  Process: 10935 ExecMount=/usr/bin/mount ele@MyFarAwayHost.boldlygoingnowhere.org:/FARAWAYDATA /FARAWAYDATA -t fuse.sshfs -o reconnect,user,allow_other,x-systemd.automount,_netdev,idmap=user,uid=1000,gid=100,IdentityFile=/home/ele/.ssh/id_rsa,port=7204 (code=exited, status=1/FAILURE)

Sep 23 17:20:25 adria systemd[1]: Mounting /FARAWAYDATA...
Sep 23 17:20:25 adria systemd[1]: FARAWAYDATA.mount: Mount process exited, code=exited status=1
Sep 23 17:20:25 adria systemd[1]: Failed to mount /FARAWAYDATA.
Sep 23 17:20:25 adria systemd[1]: FARAWAYDATA.mount: Unit entered failed state.

Offline

#6 2017-09-23 21:48:17

randomguy
Member
Registered: 2007-06-19
Posts: 92

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

xganesh wrote:

Same problem here.
I have downgraded systemd from version "234.11-8" to "233.75-3" and the failure persists.

The suggested commit is just a guess, I am absolutely not sure.

Also, did you make sure that the unit file is regenerated after the downgrade? To make sure, I would change the mount target path, so a new unit with a new name will be created.

Did those fstab entries work for you both at some point in the past?

Offline

#7 2017-09-23 22:47:07

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,463

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

This has nothing to do with systemd.

This is the change to the fuse3 API. If fuse tells you it doesn't need these options anymore, it likely doesn't need these options anymore. It will mount with the access rights of the mount point, which is going to be your user.

Offline

#8 2017-09-23 22:53:14

randomguy
Member
Registered: 2007-06-19
Posts: 92

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Fair enough, but what about '_netdev'? My assumption is that it shouldn't appear in the generated .mount files to begin with.

Edit: _netdev is also totally irrelevant in this case. Systemd correctly adds Wants=network-online.target to the unit files with our without it.

V1del is right, just remove those options.

Last edited by randomguy (2017-09-23 23:26:33)

Offline

#9 2017-09-24 10:09:32

maxchaos
Member
Registered: 2017-09-24
Posts: 6

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Hi.
I am also experiencing the same issue.

I have several remote filesystems that I mount over sshfs with appropriate entries in /etc/fstab. Normally, I mount these fileystems manually but since my last system update I also get the same error.
I removed these two options from my fstab but then trying to manually mount them as a regular user fails with the following error

 mount: /mnt/remotefs: operation permitted for root only. 

This was not an issue before and is probably caused by the removal of option "user" which actually should be filesystem independent (according to mount's man pages anyway).

Offline

#10 2017-09-24 11:37:07

DoXer
Member
Registered: 2017-08-27
Posts: 24

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

randomguy wrote:

Systemd parses /etc/fstab and creates unit files for the mounts defined in it. Could you show me the output of systemctl status for the unit file? For me it was named after the mount target, so yours should be:

This is the entry in fstab now:

michael@nas:/mnt/pool/medien /media/nas/medien  fuse.sshfs noauto,x-systemd.automount,idmap=user,follow_symlinks,identityfile=/home/michael/.ssh/id_rsa,allow_other,default_permissions,uid=1000,gid=100 0 0
sudo systemctl status media-nas-freigabe.mount

gives:

Warning: media-nas-freigabe.mount changed on disk. Run 'systemctl daemon-reload' to reload units.
● media-nas-freigabe.mount - /media/nas/freigabe
   Loaded: loaded (/etc/fstab; generated; vendor preset: disabled)
   Active: active (mounted) since Sun 2017-09-24 13:31:19 CEST; 3min 18s ago
    Where: /media/nas/freigabe
     What: michael@nas:/mnt/pool/freigabe
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)
  Process: 10313 ExecMount=/usr/bin/mount michael@nas:/mnt/pool/freigabe /media/nas/freigabe -t fuse.sshfs -o x-systemd.automount,_netdev,user,idmap=user,follow_symlinks,identityfile=/home/

--
Regards
Michael

Offline

#11 2017-09-24 12:24:42

Buddlespit
Member
From: Chesapeake, Va.
Registered: 2014-02-07
Posts: 430

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

DoXer wrote:

Warning: media-nas-freigabe.mount changed on disk. Run 'systemctl daemon-reload' to reload units.

Offline

#12 2017-09-24 12:58:47

DoXer
Member
Registered: 2017-08-27
Posts: 24

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

After daemon-reload:

● media-nas-freigabe.mount - /media/nas/freigabe
   Loaded: loaded (/etc/fstab; generated; vendor preset: disabled)
   Active: active (mounted) since Sun 2017-09-24 14:57:43 CEST; 2s ago
    Where: /media/nas/freigabe
     What: michael@nas:/mnt/pool/freigabe
     Docs: man:fstab(5)
           man:systemd-fstab-generator(8)

--
Regards
Michael

Offline

#13 2017-09-24 18:37:08

shellback
Member
Registered: 2015-01-17
Posts: 9

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Hi!

I am also experience this issue.

And while removing those old options erases the error, I reaches another since (as maxchaos mentioned) removing of the options users hinders me from mounting since I need to be root for that.

Does anyone have any solution for this one yet?

Offline

#14 2017-09-25 15:20:18

pvl1
Member
Registered: 2014-01-14
Posts: 2

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

removing _netdev and user fixed the problem for me!
many thanks

Offline

#15 2017-09-26 07:49:48

bonanza
Member
Registered: 2015-06-08
Posts: 6

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

V1del wrote:

This has nothing to do with systemd.

This is the change to the fuse3 API. If fuse tells you it doesn't need these options anymore, it likely doesn't need these options anymore. It will mount with the access rights of the mount point, which is going to be your user.

Thanks for this information!
If I mount it using root (as normal user doesn't work anymore) I get different ownership and permissions:

before mount the permission of the mount point are:
Access: (0755/drwxr-xr-x)  Uid: ( 2121/   xx)   Gid: ( 2121/   xx)

after mounting via root:
Access: (2770/drwxrws---)  Uid: (    0/    root)   Gid: ( 2573/ yy )

where user "yy" is my username on the SSH server.
The used options in fstab are: rw,defaults,noauto,default_permissions,idmap=user,exec,allow_other


Am I doing something wrong?

Last edited by bonanza (2017-09-26 08:02:11)

Offline

#16 2017-09-26 08:47:27

maxchaos
Member
Registered: 2017-09-24
Posts: 6

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

After searching around I found that the previous mount helper, mount.fuse, was recently replaced by a new one, mount.sshfs, which is actually a symlink to the sshfs utility
(see corresponding issue and commit )

Taking a closer look at the sources of mount.fuse, I noticed that certain command-line options, with _netdev and user being among them. were ignored by default,
a feature that is missing from the new helper, which probably causes the issue at hand.

For now, I have submitted an issue on github and waiting for a response.

Offline

#17 2017-09-27 19:12:31

maxchaos
Member
Registered: 2017-09-24
Posts: 6

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

The issue seems to have been resolved on the upstream repository but the corresponding distribution's package has not been updated yet.

Should I report a bug on Arch's bug tracker?

Offline

#18 2017-09-28 00:20:15

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,379

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

If you want to open a bugreport asking for this commit to be backported into the Arch package, that is definitely something you could do.

(That does not necessarily mean the maintainer will agree to backport rather than waiting for a new release. OTOH this is technically a regression which is definitely a rationale to backport it.)


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#19 2017-09-28 20:10:10

32reg
Member
Registered: 2012-08-06
Posts: 24
Website

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Same issue here. Happened after 2017-09-22 upgrade.


http://linux32.ru - blog about linux

Offline

#20 2017-09-29 07:14:03

jancici
Member
From: Kalinovo,SK
Registered: 2011-12-04
Posts: 149

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

I did get into same trouble here.

I dont know, but for last few issues I had, there was more less systemd involved.

Offline

#21 2017-09-29 15:10:27

Nikus
Member
Registered: 2012-12-10
Posts: 10

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

I need regular users to be able to mount remote ssh folders. I used the user option in fstab to do that.
Removing the user option gives me the following error: operation permitted for root only
As user option is no longer accepted, what is the equivalent with fuse 3 API?

Offline

#22 2017-09-29 15:19:34

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 5,463

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

maxchaos wrote:

For now, I have submitted an issue on github and waiting for a response.

It has been established as a regression in sshfs, that will be fixed resp. has been fixed upstream.

Offline

#23 2017-09-30 11:31:30

maxchaos
Member
Registered: 2017-09-24
Posts: 6

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

I opened a bug report regarding this issue. Now we wait.

Last edited by maxchaos (2017-09-30 11:31:46)

Offline

#24 2017-09-30 11:46:07

Nicky726
Member
From: Czech Republic
Registered: 2008-02-15
Posts: 142
Website

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

With sshfs downgraded to 3.2.0-2 the user option works, in case you need it working now.


"Although the masters make the rules
For the wise men and the fools
I got nothing, Ma, to live up to."

Offline

#25 2017-09-30 11:49:14

doskoi
Member
Registered: 2016-04-10
Posts: 14

Re: [Solved] fuse: unknown option(s): `-o _netdev,user'

Why not just remove these options? The next version of sshfs will ignore them anyway.

Offline

Board footer

Powered by FluxBB