You are not logged in.

#1 2017-10-31 07:23:13

fettouhi
Member
Registered: 2007-05-07
Posts: 686

[SOLVED] Latest nvidia update breaks sddm/kde

I updated to the latest nvidia driver on Plasma 5 desktop with a 1080 GTX card. I made sure before I rebooted that mkinitcpio had run. But when booting sddm does not start my machine seems to hang. I can't even change tty. I then booted into single mode and disabled sddm. Now I get the terminal login prompt fine but I still cannot launch kde. How do I launch kde without launching sddm? I am unsure how to debug this.

Last edited by fettouhi (2017-11-01 16:13:16)

Offline

#2 2017-10-31 07:25:45

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 23,669
Website

Re: [SOLVED] Latest nvidia update breaks sddm/kde

You boot into a different target and disable ssdm.

The you read all the other threads about DM breakage with the nvidia upgrade. And post some relevant information: version numbers, journal entries, etc...



Moving to NC...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#3 2017-10-31 07:36:26

fettouhi
Member
Registered: 2007-05-07
Posts: 686

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Already disabled ssdm. Again I am unsure on how debug this. Since starting sddm freezes the machine.

Offline

#4 2017-10-31 07:53:01

fettouhi
Member
Registered: 2007-05-07
Posts: 686

Re: [SOLVED] Latest nvidia update breaks sddm/kde

I looked through journalctl and found this entry for today when I rebooted

nvidia: disagrees about version of symbol module_layout

but I have rebuild the module several times now. Why does it still complain?

Offline

#5 2017-10-31 08:10:00

Areeraj
Member
Registered: 2016-06-22
Posts: 2

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Same problem, lightm and gts450.
nvidia: disagrees about version of symbol module_layout

works again after downgrade.

Offline

#6 2017-10-31 08:13:14

fettouhi
Member
Registered: 2007-05-07
Posts: 686

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Areeraj wrote:

Same problem, lightm and gts450.
nvidia: disagrees about version of symbol module_layout

works again after downgrade.

OK, at least good to know I am not the only one with this problem.

Offline

#7 2017-10-31 08:43:34

knocked
Member
Registered: 2016-08-03
Posts: 4

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Have the same troubles.
Nvidia: disagrees about version of symbol module_layout

Offline

#8 2017-10-31 08:49:03

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 7,422
Website

Re: [SOLVED] Latest nvidia update breaks sddm/kde

If you have nothing new to add, please do not post.

https://wiki.archlinux.org/index.php/Co … mpty_posts

Please post the output of

pacman -Qs nvidia
pacman -Q linux
uname -a

How do I launch kde without launching sddm?

https://wiki.archlinux.org/index.php/KD … he_console

Last edited by WorMzy (2017-10-31 08:50:51)


Sakura:-
Mobo: ASUS P8Z77-V PRO // Processor: Intel Core i7-3770K 3.4GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR3 (@ 2133MHz) // Storage: 1x 3TB Seagate SATAII 5x 1TB Samsung SATAII, 2x 120GB Corsair SSD

Making lemonade from lemons since 2015.

Offline

#9 2017-10-31 08:51:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,037

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Don't post me too posts, probably the kernel module has been accidentally built against a newer kernel. There's already a -2 package release in the pipeline. The fix is likely going to come with the potential push of 4.13.10. If you want to be productive, install linux and nvidia from testing, and check if it works then. If it does, be patient for the release to make it to stable.

Offline

#10 2017-10-31 09:11:51

tinko992
Member
Registered: 2016-03-03
Posts: 6

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Hi, I opened a thread and it got closed as a duplicate referencing this one, so I think I do have something to add:

Hello, today my machine (P50 with nVidia Quadro M1000M) failed to boot to graphical target with the usual mode (Discrete Graphics) enabled in BIOS. It does work with Hybrid Mode enabled, though. I use proprietary nvidia drivers. Here are the versions:

yaourt -Q | grep nvidia
multilib/lib32-nvidia-cg-toolkit 3.1-5
multilib/lib32-nvidia-utils 387.22-1
extra/nvidia 387.22-1
community/nvidia-cg-toolkit 3.1-4
extra/nvidia-settings 387.12-1
extra/nvidia-utils 387.22-1
extra/opencl-nvidia 387.22-1
yaourt -Q | grep xorg-server
extra/xorg-server 1.19.5-1 (xorg)
extra/xorg-server-common 1.19.5-1 (xorg)
extra/xorg-server-xephyr 1.19.5-1 (xorg)
extra/xorg-server-xwayland 1.19.5-1 (xorg)[/quote]

yaourt -Q | grep gdm        
extra/gdm 3.26.2-1 (gnome)
extra/libgdm 3.26.2-1

with systemd.unit=multi-user.target I was able to boot to tty and I wasn't able to start the xorg-server with startx or xinit either, so I don't think it's an issue with gdm.
Here are some Log-lines that stood out

Oct 31 07:35:31 archlinux gnome-shell[1344]: Can't initialize KMS backend: could not find drm kms device
Oct 31 07:35:31 archlinux gnome-session[1337]: gnome-session-binary[1337]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Oct 31 07:35:31 archlinux gnome-session-binary[1337]: Unrecoverable failure in required component org.gnome.Shell.desktop
Oct 31 07:35:31 archlinux gnome-session-binary[1337]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Oct 31 07:35:31 archlinux gdm[1314]: GdmDisplay: display lasted 0.259654 seconds
Oct 31 07:35:31 archlinux systemd-logind[478]: Removed session c2.
Oct 31 07:35:31 archlinux gdm[1314]: Child process -1333 was already dead.
Oct 31 07:35:31 archlinux gdm[1314]: Child process 1322 was already dead.
Oct 31 07:35:31 archlinux gdm[1314]: Unable to kill session worker process
Oct 31 07:35:31 archlinux systemd[1]: Stopping User Manager for UID 120...
Oct 31 07:35:31 archlinux systemd[1326]: Stopping D-Bus User Message Bus...

Here is the full log of one of the boots in which I attempted to resolve the issue by getting package updates and tried to start the graphical session manually [[...]] indicate lines, that I edited for privacy reasons: https://pastebin.com/R6rDNDPB
Here is a pastebin-link of the Xorg.0.log https://pastebin.com/xKJgUh6u .
I tried to resolve the issue with a pacman -Syu and got some nvidia-stuff but the issue persisted.
I can't think of any change I made to the system before the first failure to boot to the graphical.target. It is likely though, that I ran pacman -Syu before the last reboot, because I get updates daily. With Hybrid mode enabled, the xorg-server works, my lsmod (with the working state) is:

lsmod | grep nvidia
lsmod | grep i915                                                                                                                                                                  
i915                 1683456  22
i2c_algo_bit           16384  1 i915
drm_kms_helper        131072  1 i915
drm                   303104  20 i915,drm_kms_helper
intel_gtt              20480  1 i915
video                  36864  2 thinkpad_acpi,i915
button                 16384  1 i915

Update
I installed testing/linux and testing/nvidia without updating anything else. While this broke other stuff (as expected from this mixing of packages) and didn't allow me to boot to graphical.target, it did allow me to startx from tty in multi-user.target, so I guess the issue might be fixed, once those get to out of testing.

Last edited by tinko992 (2017-10-31 09:38:17)

Offline

#11 2017-10-31 09:29:28

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,037

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Although inadvertently this might contain a hint: https://bbs.archlinux.org/viewtopic.php … 3#p1746193

Are you all having nvidia modules in your initramfs and neglected to rebuild that?

@tinko thanks for popping iin here as well, sorry to mod hat you again, but could you wrap terminal output in [ code ] tags instead? Makes the post more readable.

Offline

#12 2017-10-31 10:04:28

tinko992
Member
Registered: 2016-03-03
Posts: 6

Re: [SOLVED] Latest nvidia update breaks sddm/kde

ok, I activated testing and did a full system upgrade with yaourt -Syua and some issues persist. With this version I can start an X server with the proprietary driver. I still cannot boot to graphical target. Here is the output of journalctl -b -1 for an attempt to boot straight to graphical.target, after a full update to testing and setting the graphic card mode to "Discrete" (=nvidia only) in the UEFI configuration menu. Some unnecessary NetworkManager-lines are removed and some messages translated, but otherwise unedited: https://pastebin.com/abkQqPBV

Offline

#13 2017-10-31 10:10:44

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 3,037

Re: [SOLVED] Latest nvidia update breaks sddm/kde

This might be a different issue entirely, that incidentally collided with the one discussed here, look at: https://bbs.archlinux.org/viewtopic.php?id=231381 for the issue you are having now.

Offline

#14 2017-10-31 11:16:06

nourathar
Member
Registered: 2013-04-26
Posts: 86

Re: [SOLVED] Latest nvidia update breaks sddm/kde

From the date I am assuming the OP ran into this problem after updating to NVIDIA 387.22-1: I can confirm that I had the same error.
A few hours later NVIDIA 387.22-3 solved that problem (which in my case meant that I reverted to another error that has nothing to do with this thread).

Did you try that newer version of the driver ?

Offline

#15 2017-10-31 12:59:29

euromatlox
Member
Registered: 2017-02-10
Posts: 6

Re: [SOLVED] Latest nvidia update breaks sddm/kde

As I can see NVIDIA 387.22-1 is still the latest driver available. Where can that NVIDIA 387.22-3 driver be found ?

For me this new NVIDIA driver caused X Windowing to stop working (no screen available).

Since the other branch driver nvidia-340xx also supports my card (NVIdia GT 710) I switched to using it instead.

I am wondering if they are about to remove some cards from that Latest Short Lived Branch, and put them to Legacy branch.

Offline

#16 2017-10-31 13:34:01

alex3772
Member
Registered: 2013-10-18
Posts: 5

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Updating to nvidia-387.22-3 fixed it for me.

@euromatlox:
nvidia-387.22-3 is the latest version in extra, as you can see here: https://www.archlinux.org/packages/extra/x86_64/nvidia/

I assume by "As i can see" you mean you are using pacman to check.
Its possible that the mirror you are using is out of date.
See https://www.archlinux.org/mirrors/status/ for the status of mirrors and the link from above to see the current version of packages.

Offline

#17 2017-10-31 13:45:05

euromatlox
Member
Registered: 2017-02-10
Posts: 6

Re: [SOLVED] Latest nvidia update breaks sddm/kde

Yes you're right, nvidia 387.22-3 is the latest version. Pacman listing says nvidia 387.22-1 but browsing my mirror site shows 387.22-3 as available version.

Offline

#18 2017-11-01 16:12:56

fettouhi
Member
Registered: 2007-05-07
Posts: 686

Re: [SOLVED] Latest nvidia update breaks sddm/kde

nourathar wrote:

From the date I am assuming the OP ran into this problem after updating to NVIDIA 387.22-1: I can confirm that I had the same error.
A few hours later NVIDIA 387.22-3 solved that problem (which in my case meant that I reverted to another error that has nothing to do with this thread).

Did you try that newer version of the driver ?

Yeah, tried the new build and it works for me as well.

Offline

Board footer

Powered by FluxBB