You are not logged in.

#1 2018-01-11 05:39:20

glenb77
Member
Registered: 2014-10-02
Posts: 67

[SOLVED] apache php7 upgrade failures

i have apache running serving nextcloud and a mythweb install. for a month or two any updates would fail because of nextcloud not supporting php 7.2  Today there was a new version of nextcloud and pacman allowed the upgrade which installed php 7.2 and the modules i use for those packages.

after the install the server loaded but both nextcloud and mythweb failed. i attempted to downgrade back to 7.1 by going through pacman.log and getting prior versions of anything php or apache related from earlier today. and now i get a failure of httpd service to load with the error that:
libicui18n.so.59 is not found, when in fact that file is in my lib directory. so i am at a loss.

i did not change anything in an httpd conf file or php.ini

if anyone has any idea how to get the server running i'd appreciate the help

Last edited by glenb77 (2018-01-11 13:50:58)

Offline

#2 2018-01-11 05:44:18

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,747

Re: [SOLVED] apache php7 upgrade failures

The new version of nextcloud specifically requires the php71 packages. How did you manage to update without switching to those?

Offline

#3 2018-01-11 05:55:22

glenb77
Member
Registered: 2014-10-02
Posts: 67

Re: [SOLVED] apache php7 upgrade failures

yes it installed those, but also php-apache 7.2. but after update nextcloud did not work. i just put it back and i get this: This version of Nextcloud is not compatible with PHP 7.2.
You are currently running 7.2.1.

maybe that comes from the php-apache that was upgraded

Last edited by glenb77 (2018-01-11 05:58:15)

Offline

#4 2018-01-11 06:02:43

Scimmia
Fellow
Registered: 2012-09-01
Posts: 8,747

Re: [SOLVED] apache php7 upgrade failures

So you have a mixture of php 7.2 and 7.1? And you're surprised you have problems?

Offline

#5 2018-01-11 06:08:14

glenb77
Member
Registered: 2014-10-02
Posts: 67

Re: [SOLVED] apache php7 upgrade failures

just the upgrade gave me php71 and apache-php 7.2. that is what pacman did. when i downgraded pacman to apache-php 7.1 it won't load the server with error above. there is no php 7.2 installed anywhere. php was replaced by php71 per pacman. i am just looking for a way to revert back without restoring a backup which i would like to avoid. prior to today any upgrade would fail because of nextcloud. today's nextcloud package removed that failure

Offline

#6 2018-01-11 06:44:18

ayekat
Member
Registered: 2011-01-17
Posts: 1,467
Website

Re: [SOLVED] apache php7 upgrade failures

There is php71-apache. I think that would be a cleaner solution than downgrading packages.

I think overall it may be a good idea for you to look at the list of php71-... packages in [community].

Last edited by ayekat (2018-01-11 06:45:16)


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#7 2018-01-11 13:49:52

glenb77
Member
Registered: 2014-10-02
Posts: 67

Re: [SOLVED] apache php7 upgrade failures

thanks for the suggestion, i'm sure that  probably  would have worked. i wound up removing php71, installing php72 and installing nextcloud beta for vers 13 which got all working.

Offline

#8 2018-01-14 05:42:54

eschwartz
Fellow
Registered: 2014-08-08
Posts: 4,097

Re: [SOLVED] apache php7 upgrade failures


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

Board footer

Powered by FluxBB