You are not logged in.

#1 2018-02-27 15:42:28

robborg
Member
Registered: 2015-05-04
Posts: 5

[Solved]dnsmasq: cannot open or create lease file...Read-only filesys

Hi Everyone, 

*****UPDATE***
I found the cause of what was going on. I also had firejail running using the default dnsmasq profile is bad mmkay! It was blacklisting the /var/lib and some other /var directories that are needed. I used the firecfg --clean command and removed all the links to the profiles.



I am trying to setup networking in an lxc/lxd unprivileged container.  Every time I try to create a bridge it fails with this error:

dnsmasq: cannot open or create lease file /var/lib/lxd/networks/lxdbr0/dnsmasq.leases: Read-only file system

. I tried moving the file it writes to another location like /tmp with no luck. Let me know what else is needed and I can provide more information.

Here is some more info:

  • Archlinux root on zfs

  • Separate /var dataset

  • acltype=posixacl xattr=sa

  • canmount=off exec=off nosuid

Bob

Last edited by robborg (2018-02-27 19:59:27)

Offline

Board footer

Powered by FluxBB