You are not logged in.

#1 2018-03-08 16:45:01

fledermann
Member
From: Bielefeld, Germany
Registered: 2013-06-24
Posts: 43

[SOLVED] Help me troubleshoot my laughably slow network connection

Edit: okay, I found the problem. I connected to my smartphone hotspot and got 19Mbps. So, for some reason, my router doesn't like my Arch and slows it down. Weird. Hope I can fix this somehow.


Problem:
Everything is slow, both wired and wireless. Fast.com shows about 300kbps where it should be around 50Mbps.
Ping times are quite erratic:

[d@t ~]$ ping -c6 archlinux.org
PING archlinux.org (138.201.81.199) 56(84) bytes of data.
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=1 ttl=55 time=32.7 ms
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=2 ttl=55 time=58.6 ms
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=3 ttl=55 time=39.7 ms
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=4 ttl=55 time=95.9 ms
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=5 ttl=55 time=55.2 ms
64 bytes from apollo.archlinux.org (138.201.81.199): icmp_seq=6 ttl=55 time=36.1 ms

--- archlinux.org ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5007ms
rtt min/avg/max/mdev = 32.761/53.088/95.938/21.403 ms

It can't be :
- the router, because my smartphone reaches 30Mbps over wifi easily
- the hardware, because both devices work fine under other OS's

Im using NetworkManager with dhclient. dhcpcd is not installed.

$ /etc/hosts
127.0.0.1	localhost.localdomain	localhost
::1		ipv6-localhost		ipv6-localhost
192.168.178.1	router.localdomain	router 		t
$ /etc/resolv.conf
# Generated by NetworkManager
search fritz.box
nameserver 192.168.178.1
$ lspci -v
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-V (rev 05)
	Subsystem: Lenovo Ethernet Connection I217-V
	Flags: bus master, fast devsel, latency 0, IRQ 27
	Memory at f0500000 (32-bit, non-prefetchable) [size=128K]
	Memory at f053f000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at 4080 [size=32]
	Capabilities: <access denied>
	Kernel driver in use: e1000e
	Kernel modules: e1000e

02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8192EE PCIe Wireless Network Adapter
	Subsystem: Realtek Semiconductor Co., Ltd. RTL8192EE PCIe Wireless Network Adapter
	Flags: bus master, fast devsel, latency 0, IRQ 29
	I/O ports at 3000 [size=256]
	Memory at f0400000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: rtl8192ee
	Kernel modules: rtl8192ee
$ dmesg | grep e1000e
[    1.972764] e1000e: Intel(R) PRO/1000 Network Driver - 3.2.6-k
[    1.972765] e1000e: Copyright(c) 1999 - 2015 Intel Corporation.
[    1.974961] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    2.061425] e1000e 0000:00:19.0 0000:00:19.0 (uninitialized): registered PHC clock
[    2.134170] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 54:ee:75:19:31:a2
[    2.134178] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[    2.134213] e1000e 0000:00:19.0 eth0: MAC: 11, PHY: 12, PBA No: FFFFFF-0FF
[    2.675645] e1000e 0000:00:19.0 enp0s25: renamed from eth0
[    6.016238] e1000e: enp0s25 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
[    6.016242] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO
[  286.751978] e1000e: enp0s25 NIC Link is Up 10 Mbps Full Duplex, Flow Control: None
[  286.751988] e1000e 0000:00:19.0 enp0s25: 10/100 speed: disabling TSO
$ ethtool enp0s25
Settings for enp0s25:
	Supported ports: [ TP ]
	Supported link modes:   10baseT/Half 10baseT/Full 
	                        100baseT/Half 100baseT/Full 
	                        1000baseT/Full 
	Supported pause frame use: No
	Supports auto-negotiation: Yes
	Supported FEC modes: Not reported
	Advertised link modes:  Not reported
	Advertised pause frame use: No
	Advertised auto-negotiation: No
	Advertised FEC modes: Not reported
	Speed: 10Mb/s
	Duplex: Full
	Port: Twisted Pair
	PHYAD: 1
	Transceiver: internal
	Auto-negotiation: off
	MDI-X: on (auto)
Cannot get wake-on-lan settings: Operation not permitted
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: yes
$ ip route
default via 192.168.178.1 dev enp0s25 proto dhcp metric 100 
192.168.178.0/24 dev enp0s25 proto kernel scope link src 192.168.178.97 metric 100 
$ ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s25: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 54:ee:75:19:31:a2 brd ff:ff:ff:ff:ff:ff
    inet 192.168.178.97/24 brd 192.168.178.255 scope global dynamic noprefixroute enp0s25
       valid_lft 862508sec preferred_lft 862508sec
    inet6 fe80::a8af:b4b9:f1bc:5029/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp2s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 4a:93:d4:b5:94:a9 brd ff:ff:ff:ff:ff:ff

Last edited by fledermann (2018-03-08 20:13:38)

Offline

#2 2018-03-08 16:50:35

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,231
Website

Re: [SOLVED] Help me troubleshoot my laughably slow network connection


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2018-03-08 17:04:53

fledermann
Member
From: Bielefeld, Germany
Registered: 2013-06-24
Posts: 43

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

Care to elaborate? I've set my hostname, didn't change anything.

Offline

#4 2018-03-08 17:06:58

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,231
Website

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

Not setting a hostname can lead, particularly with NM, to a range of issues.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2018-03-08 17:24:31

Maniaxx
Member
From: .de
Registered: 2014-05-14
Posts: 191

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

- Check congestion mode:

$ sysctl net.ipv4.tcp_congestion_control
net.ipv4.tcp_congestion_control = cubic

- Take a look at the network traffic with Wireshark. Maybe there are massive errors or something like that.


sys2064

Offline

#6 2018-03-08 17:45:48

fledermann
Member
From: Bielefeld, Germany
Registered: 2013-06-24
Posts: 43

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

Thanks for the hints. Congestion mode is cubic. Meanwhile I tried

$ sudo systemctl stop NetworkManager
$ sudo dhclient -r
$ sudo dhclient -v enp0s25
Internet Systems Consortium DHCP Client 4.4.1
Copyright 2004-2018 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/enp0s25/54:ee:75:19:31:a2
Sending on   LPF/enp0s25/54:ee:75:19:31:a2
Sending on   Socket/fallback
DHCPDISCOVER on enp0s25 to 255.255.255.255 port 67 interval 6
DHCPOFFER of 192.168.178.91 from 192.168.178.1
DHCPREQUEST for 192.168.178.91 on enp0s25 to 255.255.255.255 port 67
DHCPACK of 192.168.178.91 from 192.168.178.1
bound to 192.168.178.91 -- renewal in 398831 seconds.

Same issue, so I don't think its related to NM directly.

Downloading wireshark now, but that will take a while.

Last edited by fledermann (2018-03-08 17:46:45)

Offline

#7 2018-03-08 19:23:35

fledermann
Member
From: Bielefeld, Germany
Registered: 2013-06-24
Posts: 43

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

I dont really know how to interpret the wireshark output, but here it is: https://pastebin.com/cqMftaiH. At about line 400 the speedtest started.

Now I've removed networkmanager, nm-applet and everything related including config files as well as dhclient. I installed dhcpcd again, so now everything should be like in a stock Arch system. Rebooted and set up networking manually.
Still the same problem.

Last edited by fledermann (2018-03-08 19:24:22)

Offline

#8 2018-03-22 08:04:36

deafeningsylence
Member
Registered: 2016-09-23
Posts: 52

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

Hey fledermann,

I had a very similar problem recently (the same 300KiB barrier) and it looks like you might have the same issue. Since:

 
Duplex: Full Port: Twisted Pair PHYAD: 1 Transceiver: internal Auto-negotiation: off

I don't know if it is intentional but your auto-negotiation is turned off, which is usually (except for some server scenarios) a bad idea because this feature auto-negotiates the common speed two network interface cards use. Thus, yiur router or switch or whatever is the other end likely falls back to half duplex mode when unable to negotiate, while your pc for some reason goes to full. When these speeds differ the connection suffers from a duplex mismatch where simplistically put many packets get lost because one end is firing more than the other takes in. This leads to super slow speed, most notably in any application needing more than stable 300KiB throughput, try twitch, it should be a horrible every-other-second-buffering lag clusterfuck (that frustrated me for weeks)

Since your NIC is capable of auto-negotiation, just turn it on with

ethtool -s enp0s25 autoneg on

and check if you got your speed back (.. Flash, kappa).

Once that is established, check if this setting oersists across reboots and also check if yiu accidentally ticked off the auto-neg box in network manager, which would disable it every reboot.

I sincerely hope that solves your problem because it would feel really great to pass on the knowledge to fix something that bothered me so much big_smile.

Offline

#9 2018-03-22 08:12:32

deafeningsylence
Member
Registered: 2016-09-23
Posts: 52

Re: [SOLVED] Help me troubleshoot my laughably slow network connection

Also, one other thing:

Im using NetworkManager with dhclient. dhcpcd is not installed.

Is there a reason you use two networkmanagers at once? I think you would only need one - if my limited linux knowledge doesn't fool me - Networkmanager should handle dynamic ip address assignment on its own, no need for an extra dhx or dhcpd service.

Offline

Board footer

Powered by FluxBB