You are not logged in.

#1 2018-04-02 04:13:21

Registered: 2013-01-23
Posts: 7

[IDENTIFIED] resolv.conf parsing fails with ipv6 % sign

after some time troubleshooting this I guess it's time to post in case someone can help.

I have the same radvd config from my router since months, I pass the RDNSS option for an IPv6 DNS server which is then parsed from Network manager and resolv.conf is populate with 2 IPv4 and 1 IPv6 entry like this:

# Generated by NetworkManager
nameserver X.X.X.X
nameserver Y.Y.Y.Y
nameserver A::B:C:D:E%enp3so

where enp3so is the interface name

This used to work just fine but more than a month now I have the issue that when I try to use nslookup, dig, host they complaint that resolv.conf parsing has failed, eg: "nslookup: parse of /etc/resolv.conf failed"

IF I edit the file and remove the "%enp3so" - which is added automatically by NetworkManager - it works.

But this used to work and this is the proper way anyhow.

I've tried to downgrade relevant packages to end of last year ones but still the same issue.

Any ideas? One hint, drill command works fine, probably using a different parser?

UPDATE: stupid me, the one package I didn't try up to now was bind-tools which provides the library!!!

downgrading to bind-tools-9.11.2.P1-1-x86_64.pkg.tar.xz  fixes the issue

upgrading to 9.12.x brings it back again. Time for a bug report I guess.

UPDATE 2: seems like this is the bug

Last edited by gbil (2018-04-02 04:30:40)


#2 2018-08-26 11:30:35

Registered: 2017-08-18
Posts: 1

Re: [IDENTIFIED] resolv.conf parsing fails with ipv6 % sign


I had this issue myself for quiet a time now and didn't realy know wether that was really a bug or if I configured something wrong. So thanks a lot for sharing this Information.
The easiest workaround is probably to tell networkmanager to only get the ipv6 address and no dns information over dhcpv6.

To do that, simply open the connection editor


Now chose your local network and click "edit". Then go to "IPv6 Settings" and chose "Automatic, address only" in the "Method" dropdown menu. If you need DNS over IPv6 you can enter an ipv6 address in the "DNS Servers" field below, but don't use a local one (like fe80::xxxx) because  Networkmanager will append the "%interface" bit automatically to any local address. Global addresses work just fine, so you can use youre ISP's one or OpenDNS or whatever you want.

I didn't find a way to configure Networkmanager to use this configuration per default for all connections. If anybody knows how to do that, I'd be really interested.


Board footer

Powered by FluxBB