You are not logged in.

#76 2018-10-23 19:30:48

scruffidog
Member
Registered: 2010-01-10
Posts: 7

Re: The IWD thread

tried iwd-0.10-1 with connman and still no joy. Still complians about dbus

How many people are using connman as the networking mgmnt facility ?

Offline

#77 2018-10-24 11:08:15

fabertawe
Member
From: Lloegr
Registered: 2009-11-24
Posts: 267

Re: The IWD thread

scruffidog wrote:

tried iwd-0.10-1 with connman and still no joy. Still complians about dbus

How many people are using connman as the networking mgmnt facility ?

Same failure for me, I've stuck with 0.7-1


i7 4790K 4.4GHz, ASRock Z97 Extreme6, 16GB 2400MHz, GTX 970, Arch x86_64

Offline

#78 2018-10-24 12:02:39

Babble
Member
Registered: 2018-10-24
Posts: 1

Re: The IWD thread

Is it possible to decrypt the password for an already known network?

Offline

#79 2018-10-25 14:43:53

sjensen
Member
From: Germany
Registered: 2018-08-08
Posts: 31

Re: The IWD thread

damjan wrote:

@sjensen
wpa_supplicant and iwd, can't work at the same time. Typically, both are started on demand (dbus activation), so if you configure NM to use iwd, then only iwd will start.

Well no, and that is exactly the problem. "iwd" and "wpa_supplicant" are started both at the same time over dbus, if i use

[device]
wifi.backend=iwd

I had to manually remove/mask "dbus-fi.w1.wpa_supplicant1.service".

Offline

#80 2018-10-25 17:53:52

damjan
Member
Registered: 2006-05-30
Posts: 401

Re: The IWD thread

was wpa_supplicant explicitly enabled? 'cause it doesn't start for me here when NM is set to use iwd

Offline

#81 2018-11-19 18:02:28

GeneArch
Member
Registered: 2013-07-28
Posts: 7

Re: The IWD thread

Is NM supposed to pass all the relevant info such as passwords etc to iwd the same way it does with wpa_supplicant?
I tried stopping NM, changing the backend to iwd - made sure wpa_s was not running - restarted NM and waited - no connection happened. logs had iwd complaing:

iwd[3906]: Unable to open /var/lib/iwd: No such file or directory

i have NOT set up any network by hand using iwctl - as I assumed changing backends that NM would pass all the relevant info to iwd.

changing backend back to wpa_supplicant works again.

So does anyone know whether NM able to use iwd without any additional intervention so that existing passwords, routes, ipv4/ipv6 and special dns settings will continue to work the same way?

thanks

Offline

#82 2018-11-23 03:36:35

bbaserdem
Member
Registered: 2017-07-27
Posts: 20

Re: The IWD thread

I had similar issues with enabling iwd NetworkManager. I have abandoned using NetworkManager alltogether though. Now I use iwd with dhcpcd.

I have a weirder issue. I use udev to rename my wireless interface to 'wifi'. Lately, I noticed very often that udev cannot rename the device because device is busy. Initially I thought the problem was with dhcpcd, and made the interfaces managed explicit and that seemingly solved the issue. However, a while later I was having the issue again.

Now I realize that iwd captures the interface before udev can change the name on boot sometimes, and prevents it from being renamed; which screws up some other stuff down the line. I followed the guide on another thread and issued the following override;

$ cat /etc/systemd/system/iwd.service.d/override.conf
[Unit]
Before=network.target
Wants=network.target

[Service]
ExecStart=
ExecStart=/usr/lib/iwd/iwd --nointerfaces "wlan[0-9]*"

This is fine, the interface is renamed. But if iwd is started before udev can rename, it cannot then recognize the newly made available `wifi` interface.

Last edited by bbaserdem (2018-11-23 03:36:55)

Offline

#83 2018-11-25 11:00:12

duffydack
Member
Registered: 2012-06-17
Posts: 8

Re: The IWD thread

bbaserdem wrote:
$ cat /etc/systemd/system/iwd.service.d/override.conf
[Unit]
Before=network.target
Wants=network.target

[Service]
ExecStart=
ExecStart=/usr/lib/iwd/iwd --nointerfaces "wlan[0-9]*"

This is fine, the interface is renamed. But if iwd is started before udev can rename, it cannot then recognize the newly made available `wifi` interface.

My setup suffers the same udev renaming race, tho it's very hit and miss.  I tried this override which gives me the proper iface name every boot, but never actually gets an ip, until I restart iwd and networkd.  Gone back to wpa_supplicant, for now....

Offline

#84 2018-11-25 13:25:42

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 82

Re: The IWD thread

I've run into the same race condition between udev and iwd that's referenced by systemd#7293. I actually opened a thread also.

I've sinced moved to the following override which has been working well:

$ cat /etc/systemd/system/iwd.service.d/override.conf
[Unit]
BindsTo=sys-subsystem-net-devices-wifi0.device
After=sys-subsystem-net-devices-wifi0.device

[Service]
ExecStart=
ExecStart=/usr/lib/iwd/iwd --interface wifi0

Interested in other's thoughts.

--edit
Should give credit to Pancho's post from this same thread which also has relevant links.

Last edited by CarbonChauvinist (2018-11-25 15:05:30)

Offline

#85 2018-11-25 13:47:55

duffydack
Member
Registered: 2012-06-17
Posts: 8

Re: The IWD thread

CarbonChauvinist wrote:

I've run into the same race condition between udev and iwd that's referenced by systemd#7293. I actually opened a thread also.

I've sinced moved to the following override which has been working well:

$ cat /etc/systemd/system/iwd.service.d/override.conf
[Unit]
BindsTo=sys-subsystem-net-devices-wifi0.device
After=sys-subsystem-net-devices-wifi0.device

[Service]
ExecStart=
ExecStart=/usr/lib/iwd/iwd --interface wifi0

Interested in other's thoughts.

Looking good so far.  Nice.

Offline

#86 2018-12-02 12:05:39

gothmog123
Member
Registered: 2012-10-31
Posts: 91

Re: The IWD thread

Still no way to get connman working with iwd? wpa_supplicant is a disaster for me - iwd fixes so many problems.

Offline

#87 2018-12-03 00:20:30

illis
Member
Registered: 2013-09-23
Posts: 14

Re: The IWD thread

gothmog123 wrote:

Still no way to get connman working with iwd? wpa_supplicant is a disaster for me - iwd fixes so many problems.

Using iwd 0.7 with connman. Thats been working fine. I did try 10.? at some point, but ran into issues with something renaming the network interface - so I reverted  back - I think there other people with the same issue further up this thread. Haven't tried any newer versions since.

Offline

#88 2018-12-03 00:27:06

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,241
Website

Re: The IWD thread

illis wrote:
gothmog123 wrote:

Still no way to get connman working with iwd? wpa_supplicant is a disaster for me - iwd fixes so many problems.

Using iwd 0.7 with connman. Thats been working fine.

No scanning though?


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#89 2018-12-03 00:34:14

illis
Member
Registered: 2013-09-23
Posts: 14

Re: The IWD thread

jasonwryan wrote:
illis wrote:
gothmog123 wrote:

Still no way to get connman working with iwd? wpa_supplicant is a disaster for me - iwd fixes so many problems.

Using iwd 0.7 with connman. Thats been working fine.

No scanning though?


Scanning works, but I think the trick is to use iwctl to scan

$ iwctl
[iwd]# device wlan0 scan
[iwd]# device wlan0 get-networks
$ connmanctl
connmanctl> services

Offline

#90 2018-12-03 00:50:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 26,241
Website

Re: The IWD thread

illis wrote:
jasonwryan wrote:
illis wrote:

Using iwd 0.7 with connman. Thats been working fine.

No scanning though?


Scanning works, but I think the trick is to use iwctl to scan

$ iwctl
[iwd]# device wlan0 scan
[iwd]# device wlan0 get-networks
$ connmanctl
connmanctl> services

Cool: thanks for the tip!


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#91 2018-12-04 19:51:06

duffydack
Member
Registered: 2012-06-17
Posts: 8

Re: The IWD thread

Got iwd working fine now, except for 1 issue.  NFS mounts fail to unmount during reboot/shutdown, and waits the usual 90s before it gives up.  I could lower the timer, but I'd rather fix the issue with IWD.  No issue with wpa_supplicant.  Anyone else same?

Offline

#92 2018-12-04 20:43:22

CarbonChauvinist
Member
Registered: 2012-06-16
Posts: 82

Re: The IWD thread

How are you mounting your NFS shares to begin with?

The following may help from the NFS wiki - look into using the systemd automount if you're not already.

If shutdown/reboot holds too long because of NFS, enable NetworkManager-wait-online.service to ensure that NetworkManager is not exited before the NFS volumes are unmounted. You may also try to add the x-systemd.requires=network-online.target mount option if shutdown takes too long.

Last edited by CarbonChauvinist (2018-12-04 20:44:16)

Offline

#93 2018-12-04 20:55:20

duffydack
Member
Registered: 2012-06-17
Posts: 8

Re: The IWD thread

CarbonChauvinist wrote:

How are you mounting your NFS shares to begin with?

The following may help from the NFS wiki - look into using the systemd automount if you're not already.

If shutdown/reboot holds too long because of NFS, enable NetworkManager-wait-online.service to ensure that NetworkManager is not exited before the NFS volumes are unmounted. You may also try to add the x-systemd.requires=network-online.target mount option if shutdown takes too long.

already using automount, with networkd (systemd-networkd-wait-online.service is enabled automatically when I enable networkd)
host:/share    /mnt/share    nfs    noauto,x-systemd.automount    0    0

I'll give x-systemd.requires=network-online.target a shot, thanks

Offline

#94 2018-12-04 21:07:33

duffydack
Member
Registered: 2012-06-17
Posts: 8

Re: The IWD thread

CarbonChauvinist wrote:

If shutdown/reboot holds too long because of NFS, enable NetworkManager-wait-online.service to ensure that NetworkManager is not exited before the NFS volumes are unmounted. You may also try to add the x-systemd.requires=network-online.target mount option if shutdown takes too long.

Tried it but still the same, waiting 90s.  I'll stick an idle timeout in the fstab mount for now.  It'll do.

Offline

#95 2018-12-07 18:01:25

pigiron
Member
From: USA
Registered: 2009-07-14
Posts: 145

Re: The IWD thread

Just a FYI if you get 44 minutes to spare.

Marcel Holtmann gave an overview/history/status/todo talk at the Embedded Linux Conference - Europe for iwd recently (October 2018).

  https://www.youtube.com/watch?v=QIqT2obSPDk

He covers the recent status for ConnMan, NetworkManager, ChromeOS, and iwdctl support about 20 minutes in.

The general take away I get is that iwd is still a WiP (Work in Progress), but it seems to be moving along nicely.

Now, if I could just shake this feeling that somehow Lennart Poettering is involved.

Offline

#96 2018-12-08 08:54:46

ua4000
Member
Registered: 2015-10-14
Posts: 126

Re: The IWD thread

I'm testing iwd + dhcpcd:
Do I have to enable both systemd units ?

Or is there another way, like this hook for wpa_supplicant https://wiki.archlinux.org/index.php/Dh … supplicant ?

Online

#97 2018-12-08 11:12:54

gothmog123
Member
Registered: 2012-10-31
Posts: 91

Re: The IWD thread

ua4000 wrote:

I'm testing iwd + dhcpcd:
Do I have to enable both systemd units ?

Or is there another way, like this hook for wpa_supplicant https://wiki.archlinux.org/index.php/Dh … supplicant ?

Yeah just enable both and it works like magic. But you won't have a tray applet.

Offline

#98 2018-12-15 10:13:55

ua4000
Member
Registered: 2015-10-14
Posts: 126

Re: The IWD thread

I tested a while: for me dhcpcd + iwd only works on every 2nd boot.
To get wireless working I figured out, that I have to restart iwd manually.

Setup:
dhcpcd enabled for all interfaces
iwd enabled
masked: systemd-networkd systemd-resolved

case 1: everything is fine after boot:

-- Reboot --
Dec 15 10:08:11 l18 systemd[1]: Starting Wireless service...
Dec 15 10:08:12 l18 iwd[303]: No asymmetric key support found.
Dec 15 10:08:12 l18 iwd[303]: TLS based WPA-Enterprise authentication methods will not function.
Dec 15 10:08:12 l18 iwd[303]: Kernel 4.20+ is required for this feature.
Dec 15 10:08:12 l18 iwd[303]: The following options are missing in the kernel:
Dec 15 10:08:12 l18 iwd[303]:         CONFIG_ASYMMETRIC_KEY_TYPE
Dec 15 10:08:12 l18 iwd[303]:         CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE
Dec 15 10:08:12 l18 iwd[303]:         CONFIG_PKCS7_MESSAGE_PARSER
Dec 15 10:08:12 l18 iwd[303]:         CONFIG_X509_CERTIFICATE_PARSER
Dec 15 10:08:12 l18 iwd[303]:         CONFIG_PKCS8_PRIVATE_KEY_PARSER
Dec 15 10:08:12 l18 iwd[303]: Wireless daemon version 0.12
Dec 15 10:08:12 l18 iwd[303]: Skipping optional configuration file /etc/iwd/main.conf
Dec 15 10:08:12 l18 systemd[1]: Started Wireless service.
Dec 15 10:08:12 l18 iwd[303]: Wiphy: 0, Name: phy0
Dec 15 10:08:12 l18 iwd[303]:         Bands: 2.4 GHz 5 GHz
Dec 15 10:08:12 l18 iwd[303]:         Ciphers: CCMP TKIP
Dec 15 10:08:12 l18 iwd[303]:         Supported iftypes: ad-hoc station
Dec 15 10:08:12 l18 iwd[303]: No ControlPortOverNL80211 setting, defaulting to True
Dec 15 10:08:12 l18 iwd[303]: Unable to add the net.connman.iwd.Adapter interface to /0
Dec 15 10:08:12 l18 iwd[303]: Unable to add the org.freedesktop.DBus.Properties interface to /0
Dec 15 10:08:12 l18 iwd[303]: Wiphy: 0, Name: phy0
Dec 15 10:08:12 l18 iwd[303]:         Bands: 2.4 GHz 5 GHz
Dec 15 10:08:12 l18 iwd[303]:         Ciphers: CCMP TKIP
Dec 15 10:08:12 l18 iwd[303]:         Supported iftypes: ad-hoc station
Dec 15 10:08:17 l18 iwd[303]: hardware_rekey not supported

case 2: On this boot, I had to restart iwd (Line: Terminate !) to get wireless working:

-- Reboot --
Dec 15 10:32:36 l18 systemd[1]: Starting Wireless service...
Dec 15 10:32:37 l18 iwd[309]: No asymmetric key support found.
Dec 15 10:32:37 l18 iwd[309]: TLS based WPA-Enterprise authentication methods will not function.
Dec 15 10:32:37 l18 iwd[309]: Kernel 4.20+ is required for this feature.
Dec 15 10:32:37 l18 iwd[309]: The following options are missing in the kernel:
Dec 15 10:32:37 l18 iwd[309]:         CONFIG_ASYMMETRIC_KEY_TYPE
Dec 15 10:32:37 l18 iwd[309]:         CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE
Dec 15 10:32:37 l18 iwd[309]:         CONFIG_PKCS7_MESSAGE_PARSER
Dec 15 10:32:37 l18 iwd[309]:         CONFIG_X509_CERTIFICATE_PARSER
Dec 15 10:32:37 l18 iwd[309]:         CONFIG_PKCS8_PRIVATE_KEY_PARSER
Dec 15 10:32:37 l18 iwd[309]: Wireless daemon version 0.12
Dec 15 10:32:37 l18 iwd[309]: Skipping optional configuration file /etc/iwd/main.conf
Dec 15 10:32:37 l18 systemd[1]: Started Wireless service.
Dec 15 10:32:37 l18 iwd[309]: Wiphy: 0, Name: phy0
Dec 15 10:32:37 l18 iwd[309]:         Bands: 2.4 GHz 5 GHz
Dec 15 10:32:37 l18 iwd[309]:         Ciphers: CCMP TKIP
Dec 15 10:32:37 l18 iwd[309]:         Supported iftypes: ad-hoc station
Dec 15 10:32:37 l18 iwd[309]: No ControlPortOverNL80211 setting, defaulting to True
Dec 15 10:33:11 l18 iwd[309]: 4-Way handshake failed for ifindex: 3, reason: 15

Dec 15 10:45:20 l18 iwd[309]: Terminate
Dec 15 10:45:20 l18 iwd[309]: Removing scan context for ifindex: 3
Dec 15 10:45:20 l18 systemd[1]: Stopping Wireless service...
Dec 15 10:45:21 l18 iwd[309]: D-Bus disconnected, quitting...
Dec 15 10:45:21 l18 systemd[1]: Stopped Wireless service.
Dec 15 10:45:21 l18 systemd[1]: Starting Wireless service...
Dec 15 10:45:21 l18 iwd[582]: No asymmetric key support found.
Dec 15 10:45:21 l18 iwd[582]: TLS based WPA-Enterprise authentication methods will not function.
Dec 15 10:45:21 l18 iwd[582]: Kernel 4.20+ is required for this feature.
Dec 15 10:45:21 l18 iwd[582]: The following options are missing in the kernel:
Dec 15 10:45:21 l18 iwd[582]:         CONFIG_ASYMMETRIC_KEY_TYPE
Dec 15 10:45:21 l18 iwd[582]:         CONFIG_ASYMMETRIC_PUBLIC_KEY_SUBTYPE
Dec 15 10:45:21 l18 iwd[582]:         CONFIG_PKCS7_MESSAGE_PARSER
Dec 15 10:45:21 l18 iwd[582]:         CONFIG_X509_CERTIFICATE_PARSER
Dec 15 10:45:21 l18 iwd[582]:         CONFIG_PKCS8_PRIVATE_KEY_PARSER
Dec 15 10:45:21 l18 iwd[582]: Wireless daemon version 0.12
Dec 15 10:45:21 l18 iwd[582]: Skipping optional configuration file /etc/iwd/main.conf
Dec 15 10:45:21 l18 iwd[582]: Wiphy: 0, Name: phy0
Dec 15 10:45:21 l18 iwd[582]:         Bands: 2.4 GHz 5 GHz
Dec 15 10:45:21 l18 iwd[582]:         Ciphers: CCMP TKIP
Dec 15 10:45:21 l18 iwd[582]:         Supported iftypes: ad-hoc station
Dec 15 10:45:21 l18 iwd[582]: No ControlPortOverNL80211 setting, defaulting to True
Dec 15 10:45:21 l18 systemd[1]: Started Wireless service.
Dec 15 10:45:25 l18 iwd[582]: hardware_rekey not supported

As far as I can see the difference is: to get wireless working the log has to show "hardware_rekey not supported".

Any ideas on this ?

Online

#99 2018-12-15 13:28:01

gothmog123
Member
Registered: 2012-10-31
Posts: 91

Re: The IWD thread

ua4000 wrote:

I tested a while: for me dhcpcd + iwd only works on every 2nd boot.
To get wireless working I figured out, that I have to restart iwd manually.


As far as I can see the difference is: to get wireless working the log has to show "hardware_rekey not supported".

Any ideas on this ?

Don't know how much this will help, but I have systemd device renaming disabled, so my wireless is always wlan0, maybe you can try that.

Offline

Board footer

Powered by FluxBB