You are not logged in.

#1 2018-05-29 09:50:34

ahstro
Member
Registered: 2017-03-13
Posts: 5

ffmpeg, ffmpeg2.8, and x265

I'm trying to run a system upgrade, but can't seem to upgrade ffmpeg nor x265.
Problem seems to be that ffmpeg2.8 is installed, and causing some dependency conflicts.
Not sure how to resolve this.

λ sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing x265 (2.8-1) breaks dependency 'libx265.so=151-64' required by ffmpeg2.8

Offline

#2 2018-05-29 10:45:56

crequill
Member
Registered: 2011-07-18
Posts: 10

Re: ffmpeg, ffmpeg2.8, and x265

pacman -R ffmpeg2.8

ffmpeg2.8 is not more used

Offline

#3 2018-05-29 10:46:32

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,321

Re: ffmpeg, ffmpeg2.8, and x265

Update your system more often, that dependency chain got resolved cleanly for 2 months

FWIW remove ffmpeg2.8 if necessary with the -Rdd option, the only package that should have this dependency in the repos is VLC which will be updated as well. If you have this dependency for an AUR package, you'd best check if there was an update

Offline

#4 2018-05-29 10:48:02

ahstro
Member
Registered: 2017-03-13
Posts: 5

Re: ffmpeg, ffmpeg2.8, and x265

I update my system multiple times a day, so don't think "more often" is a valid suggestion.
Removed ffmpeg2.8 and upgraded now. Not sure why it hadn't been removed, if you say it should've been.
Thanks!

Offline

#5 2018-05-29 11:06:00

thecdn
Member
Registered: 2007-06-12
Posts: 21

Re: ffmpeg, ffmpeg2.8, and x265

ahstro wrote:

I update my system multiple times a day, so don't think "more often" is a valid suggestion.

Agreed. I update every morning just ran into this issue this morning.

Offline

#6 2018-05-29 13:31:05

loqs
Member
Registered: 2014-03-06
Posts: 8,491

Re: ffmpeg, ffmpeg2.8, and x265

thecdn do you also regularly run `pacman -Qdt`?

Offline

#7 2018-05-29 14:16:48

wh00
Member
Registered: 2016-03-24
Posts: 20

Re: ffmpeg, ffmpeg2.8, and x265

thecdn wrote:
ahstro wrote:

I update my system multiple times a day, so don't think "more often" is a valid suggestion.

Agreed. I update every morning just ran into this issue this morning.

Same

edit:

loqs wrote:

thecdn do you also regularly run `pacman -Qdt`?

I have not in the past, but it seems like a good suggestion for the future! Thanks

Last edited by wh00 (2018-05-29 14:18:23)

Offline

#8 2018-05-29 18:04:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,321

Re: ffmpeg, ffmpeg2.8, and x265

Seems my memory is fuzzy, I thought we had a replaces directive, apparently not. Sorry for the noise. But yes, regularly checking and cleaning up after old orphans is a good habit to get into.

Offline

#9 2018-05-29 18:24:07

twelveeighty
Member
From: Alberta, Canada
Registered: 2011-09-04
Posts: 493

Re: ffmpeg, ffmpeg2.8, and x265

My list for `pacman -Qdt` was rather big. I'm still working on it, but I noticed that there were several packages that were originally installed as a dependency, but no longer *are* a dep. For example: akonadi and elfutils. Since I want to keep those, I use the following to mark them as "explicitly installed" to get them off the -Qdt list:

pacman -D --asexplicit <package>

Offline

#10 2018-05-29 18:49:52

eschwartz
Trusted User/Bug Wrangler
Registered: 2014-08-08
Posts: 2,853

Re: ffmpeg, ffmpeg2.8, and x265

V1del wrote:

Seems my memory is fuzzy, I thought we had a replaces directive, apparently not. Sorry for the noise. But yes, regularly checking and cleaning up after old orphans is a good habit to get into.

We do have one, but nothing "replaces" ffmpeg2.8, so why should we use it?


Managing AUR repos The Right Way -- aurpublish (now a standalone tool)

Offline

#11 2018-05-29 21:00:22

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,321

Re: ffmpeg, ffmpeg2.8, and x265

I know that we have one, I thought it did do that, for some reason, but now that I remember correctly, it was simply readded to allow an easier upgrade for a while.

Offline

#12 2018-05-29 21:21:34

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 955

Re: ffmpeg, ffmpeg2.8, and x265

Why did no-one ask this at weekend. I finally figured it out this morning, and suddenly here's the solution. Could have saved me a bucket load of heartache sad


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1060 6Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (2SSD - 4Spinners) + 1 x optical.
Linux user #545703

Offline

#13 2018-05-29 23:05:36

loqs
Member
Registered: 2014-03-06
Posts: 8,491

Re: ffmpeg, ffmpeg2.8, and x265

@Roken https://git.archlinux.org/svntogit/pack … dab006254b because no one else using testing had the issue?
Edit:
Missed https://bbs.archlinux.org/viewtopic.php?id=237497

Last edited by loqs (2018-05-29 23:41:37)

Offline

#14 2018-06-06 10:12:54

dkorzhevin
Member
From: Kiev, Ukraine
Registered: 2010-04-23
Posts: 61

Re: ffmpeg, ffmpeg2.8, and x265

Thx for the solution.

Offline

#15 2018-08-01 15:31:41

firesalamander
Member
Registered: 2018-03-10
Posts: 1

Re: ffmpeg, ffmpeg2.8, and x265

This was helpful.Thanks

Offline

Board footer

Powered by FluxBB